summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-11-24 22:37:16 +0000
committerMike Gilbert <floppym@gentoo.org>2012-11-24 22:37:16 +0000
commit3086444e260209e5cf0a8508f167e29c6b7cdff4 (patch)
tree68e8e70d636304b1f60ef263a7732eae137c226e
parentVersion bump. Removed old (diff)
downloadgentoo-2-3086444e260209e5cf0a8508f167e29c6b7cdff4.tar.gz
gentoo-2-3086444e260209e5cf0a8508f167e29c6b7cdff4.tar.bz2
gentoo-2-3086444e260209e5cf0a8508f167e29c6b7cdff4.zip
Raise minimum mercurial version to 2.3.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--dev-vcs/tortoisehg/ChangeLog6
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.6.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild10
3 files changed, 15 insertions, 5 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 2a6dd8884333..a1f520eaae59 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.25 2012/11/24 22:28:44 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.26 2012/11/24 22:37:16 floppym Exp $
+
+ 24 Nov 2012; Mike Gilbert <floppym@gentoo.org> tortoisehg-2.6.ebuild,
+ tortoisehg-9999.ebuild:
+ Raise minimum mercurial version to 2.3.
*tortoisehg-2.6 (24 Nov 2012)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild
index ab41ba70af48..7e17893c1fae 100644
--- a/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild,v 1.1 2012/11/24 22:28:44 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.6.ebuild,v 1.2 2012/11/24 22:37:16 floppym Exp $
EAPI=4
@@ -13,7 +13,7 @@ inherit distutils eutils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-2.2 <dev-vcs/mercurial-2.5"
+ HG_DEPEND=">=dev-vcs/mercurial-2.3 <dev-vcs/mercurial-2.5"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 7cdd42231757..a66ed5713814 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.12 2012/09/10 20:14:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.13 2012/11/24 22:37:16 floppym Exp $
EAPI=4
@@ -13,7 +13,7 @@ inherit distutils eutils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-2.2 <dev-vcs/mercurial-2.4"
+ HG_DEPEND=">=dev-vcs/mercurial-2.3 <dev-vcs/mercurial-2.5"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
@@ -76,3 +76,9 @@ src_install() {
newicon -s scalable icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
domenu contrib/${PN}.desktop
}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}