summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-09 09:09:58 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-09 09:09:58 +0000
commit3f18a93dbb453f82b154b293062c34f93a714572 (patch)
treed067f5903a14e5f7f2669b681150baca545d7c94
parentUpdate Changelog. (diff)
downloadgentoo-2-3f18a93dbb453f82b154b293062c34f93a714572.tar.gz
gentoo-2-3f18a93dbb453f82b154b293062c34f93a714572.tar.bz2
gentoo-2-3f18a93dbb453f82b154b293062c34f93a714572.zip
allow autotools_check_macro to parse multiple arguments and add LT_INIT to macro list to run libtoolize
-rw-r--r--eclass/autotools.eclass13
1 files changed, 7 insertions, 6 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index ac80e02e2299..b519dd2998ae 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.76 2008/06/01 01:43:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.77 2008/06/09 09:09:58 vapier Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -158,12 +158,10 @@ eaclocal() {
# libtool.eclass.
_elibtoolize() {
local opts
- local lttest
# Check if we should run libtoolize (AM_PROG_LIBTOOL is an older macro,
# check for both it and the current AC_PROG_LIBTOOL)
- lttest="$(autotools_check_macro "AC_PROG_LIBTOOL")$(autotools_check_macro "AM_PROG_LIBTOOL")"
- [[ -n $lttest ]] || return 0
+ [[ -n $(autotools_check_macro AC_PROG_LIBTOOL AM_PROG_LIBTOOL LT_INIT) ]] || return 0
[[ -f GNUmakefile.am || -f Makefile.am ]] && opts="--automake"
@@ -266,8 +264,11 @@ autotools_run_tool() {
# Internal function to check for support
autotools_check_macro() {
- [[ -f configure.ac || -f configure.in ]] && \
- WANT_AUTOCONF="2.5" autoconf --trace=$1 2>/dev/null
+ [[ -f configure.ac || -f configure.in ]] || return 0
+ local macro
+ for macro ; do
+ WANT_AUTOCONF="2.5" autoconf --trace="${macro}" 2>/dev/null
+ done
return 0
}