summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-06-29 16:45:37 +0000
committerDon Seiler <rizzo@gentoo.org>2004-06-29 16:45:37 +0000
commit3f4870686ba0b4a7da5dc966c1f7dab30d617a73 (patch)
tree6274f243f666a84cd54b5d1b2282ba0e1c39ee94
parent (Manifest recommit) (diff)
downloadgentoo-2-3f4870686ba0b4a7da5dc966c1f7dab30d617a73.tar.gz
gentoo-2-3f4870686ba0b4a7da5dc966c1f7dab30d617a73.tar.bz2
gentoo-2-3f4870686ba0b4a7da5dc966c1f7dab30d617a73.zip
Adding flaggable evolution support
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/gaim-0.79-r1.ebuild10
2 files changed, 15 insertions, 4 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 2ffe29d19b45..ae6768f498e0 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.193 2004/06/28 19:02:42 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.194 2004/06/29 16:45:37 rizzo Exp $
+
+ 29 Jun 2004; Don Seiler <rizzo@gentoo.org> gaim-0.79-r1.ebuild:
+ Making evolution support flaggable. Although the current versions of evolution
+ in portage aren't supported by gaim's gevolution, some users are using
+ breakmygentoo versions and this will make things a little easier for them.
+ Normally I would tell them 'tough cookies' but I thought I'd play nice, plus
+ this positions us for when newer versions of evolution _are_ in portage.
28 Jun 2004; Don Seiler <rizzo@gentoo.org>
-files/gaim-0.74-gnome-url-handler.patch,
diff --git a/net-im/gaim/gaim-0.79-r1.ebuild b/net-im/gaim/gaim-0.79-r1.ebuild
index e66e0cab4e45..01dcb094671f 100644
--- a/net-im/gaim/gaim-0.79-r1.ebuild
+++ b/net-im/gaim/gaim-0.79-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.79-r1.ebuild,v 1.2 2004/06/28 19:02:42 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.79-r1.ebuild,v 1.3 2004/06/29 16:45:37 rizzo Exp $
inherit flag-o-matic eutils gcc
use debug && inherit debug
-IUSE="nls perl spell nas debug crypt cjk gnutls silc"
+IUSE="nls perl spell nas debug crypt cjk gnutls silc evo"
DESCRIPTION="GTK Instant Messenger client"
HOMEPAGE="http://gaim.sourceforge.net/"
@@ -26,7 +26,10 @@ DEPEND=">=x11-libs/gtk+-2.0
spell? ( >=app-text/gtkspell-2.0.2 )
dev-libs/nss
gnutls? ( net-libs/gnutls )
- !mips? ( silc? ( >=net-im/silc-toolkit-0.9.12 ) )"
+ !mips? (
+ !ia64? ( evo? ( mail-client/evolution ) )
+ silc? ( >=net-im/silc-toolkit-0.9.12 )
+ )"
PDEPEND="crypt? ( >=net-im/gaim-encryption-2.27 )"
pkg_setup() {
@@ -72,6 +75,7 @@ src_compile() {
use spell || myconf="${myconf} --disable-gtkspell"
use nls || myconf="${myconf} --disable-nls"
use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ use evo || myconf="${myconf} --disable-gevolution"
if use gnutls ; then
myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"