summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-24 05:45:23 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-24 05:45:23 +0000
commit3f611ef82dfecfa0cecf9cd308a0571e4d400822 (patch)
treea819e680282b625682e6a2209ed23ed13a2166eb
parentVersion bump. (diff)
downloadgentoo-2-3f611ef82dfecfa0cecf9cd308a0571e4d400822.tar.gz
gentoo-2-3f611ef82dfecfa0cecf9cd308a0571e4d400822.tar.bz2
gentoo-2-3f611ef82dfecfa0cecf9cd308a0571e4d400822.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.0.6.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 37c31a103c30..8516bdbe3888 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.36 2011/05/06 14:59:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.37 2011/05/24 05:45:23 graaff Exp $
+
+*libxml-2.0.6 (24 May 2011)
+
+ 24 May 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.0.6.ebuild:
+ Version bump.
*libxml-2.0.5 (06 May 2011)
diff --git a/dev-ruby/libxml/libxml-2.0.6.ebuild b/dev-ruby/libxml/libxml-2.0.6.ebuild
new file mode 100644
index 000000000000..a2dba641d930
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.6.ebuild,v 1.1 2011/05/24 05:45:23 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}