summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-03-14 20:23:44 +0000
committerThomas Sachau <tommy@gentoo.org>2010-03-14 20:23:44 +0000
commit4758afc3c2beae6809e2c547d42be7a19d5dd652 (patch)
treea776d0113d9d4e13b00749ee0e153e128ee16cdc
parentAll: fixed one QA warning (dohtml -r needed) (diff)
downloadgentoo-2-4758afc3c2beae6809e2c547d42be7a19d5dd652.tar.gz
gentoo-2-4758afc3c2beae6809e2c547d42be7a19d5dd652.tar.bz2
gentoo-2-4758afc3c2beae6809e2c547d42be7a19d5dd652.zip
Version bump and fix some QA issues
(Portage version: 2.2_rc67-r2/cvs/Linux x86_64)
-rw-r--r--sys-fs/aufs2/ChangeLog10
-rw-r--r--sys-fs/aufs2/aufs2-0_p20100308.ebuild (renamed from sys-fs/aufs2/aufs2-0_p20090916-r1.ebuild)11
-rw-r--r--sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch12
-rw-r--r--sys-fs/aufs2/files/aufs2-base-33.patch81
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-33.patch203
5 files changed, 297 insertions, 20 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index f270c6d9f48d..52b6cabd990c 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.14 2010/03/06 22:03:26 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.15 2010/03/14 20:23:43 tommy Exp $
+
+*aufs2-0_p20100308 (14 Mar 2010)
+
+ 14 Mar 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -aufs2-0_p20090916-r1.ebuild, +aufs2-0_p20100308.ebuild,
+ -files/aufs2-0_p20090916-makefile.patch, +files/aufs2-base-33.patch,
+ +files/aufs2-standalone-33.patch:
+ Version bump, also fixes some QA issues
06 Mar 2010; Mark Loeser <halcy0n@gentoo.org> aufs2-0_p20090916-r1.ebuild,
+files/aufs2-0_p20090916-makefile.patch,
diff --git a/sys-fs/aufs2/aufs2-0_p20090916-r1.ebuild b/sys-fs/aufs2/aufs2-0_p20100308.ebuild
index d32b8f0f5bf0..e7fa04b6c03e 100644
--- a/sys-fs/aufs2/aufs2-0_p20090916-r1.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20100308.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20090916-r1.ebuild,v 1.3 2010/03/06 22:03:26 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100308.ebuild,v 1.1 2010/03/14 20:23:43 tommy Exp $
EAPI="2"
-inherit linux-mod toolchain-funcs
+inherit linux-mod multilib toolchain-funcs
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net"
@@ -25,7 +25,7 @@ MODULE_NAMES="aufs(misc:${S})"
pkg_setup() {
get_version
kernel_is lt 2 6 27 && die "kernel too old"
- kernel_is gt 2 6 31 && die "kernel too new"
+ kernel_is gt 2 6 33 && die "kernel too new"
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
@@ -50,9 +50,6 @@ pkg_setup() {
src_prepare() {
local branch=origin/aufs2-${KV_PATCH}
- if [[ $KV_PATCH == 31 ]] ; then
- branch=origin/aufs2
- fi
git checkout -q $branch || die
if ! use debug; then
sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
@@ -66,7 +63,7 @@ src_prepare() {
cd "${WORKDIR}"/${PN}-util
sed -i "/LDFLAGS += -static -s/d" Makefile || die
- epatch "${FILESDIR}"/{${P}-makefile.patch,utils-2.6.31.patch}
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
}
src_compile() {
diff --git a/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch b/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch
deleted file mode 100644
index 091df6b3cb8a..000000000000
--- a/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 9b8dec7..cca9c4f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -44,6 +44,7 @@ ${BinObj}: %.o: %.c ${LibUtilHdr} ${LibUtil}
-
- ${LibUtilObj}: %.o: %.c ${LibUtilHdr}
- ${LibUtil}: ${LibUtil}(${LibUtilObj})
-+.NOTPARALLEL: ${LibUtil}
-
- # this is unnecessary on 64bit system?
- rdu64.c: rdu.c
diff --git a/sys-fs/aufs2/files/aufs2-base-33.patch b/sys-fs/aufs2/files/aufs2-base-33.patch
new file mode 100644
index 000000000000..2ec0d397433f
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-base-33.patch
@@ -0,0 +1,81 @@
+aufs2 base patch for linux-2.6.33
+
+diff --git a/fs/namei.c b/fs/namei.c
+index a4855af..1d12d37 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -1207,7 +1207,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1217,7 +1217,7 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+diff --git a/fs/splice.c b/fs/splice.c
+index 3920866..b13a9a2 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1053,8 +1053,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
+ loff_t *, size_t, unsigned int);
+@@ -1081,9 +1081,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ ssize_t (*splice_read)(struct file *, loff_t *,
+ struct pipe_inode_info *, size_t, unsigned int);
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 05b441d..91bc74e 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -73,6 +73,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
+ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
+ int (*open)(struct inode *, struct file *));
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+
+ extern int follow_down(struct path *);
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 18e7c7c..8393b5c 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -82,4 +82,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
diff --git a/sys-fs/aufs2/files/aufs2-standalone-33.patch b/sys-fs/aufs2/files/aufs2-standalone-33.patch
new file mode 100644
index 000000000000..8ea735b788f2
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-33.patch
@@ -0,0 +1,203 @@
+aufs2 standalone patch for linux-2.6.33
+
+diff --git a/fs/namei.c b/fs/namei.c
+index 1d12d37..7cb8e5d 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -349,6 +349,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1216,6 +1217,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+ int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+@@ -1238,6 +1240,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index c768f73..0fd78c3 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -39,6 +39,7 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/open.c b/fs/open.c
+index 040cef7..453b782 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -226,6 +226,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return ret;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index b13a9a2..3931ee0 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1077,6 +1077,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+@@ -1103,6 +1104,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+
+ return splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/commoncap.c b/security/commoncap.c
+index f800fdb..ea457bc 100644
+--- a/security/commoncap.c
++++ b/security/commoncap.c
+@@ -946,3 +946,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+ }
+ return ret;
+ }
++EXPORT_SYMBOL(cap_file_mmap);
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index 6cf8fd2..008e0d8 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -514,6 +514,7 @@ found:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/security.c b/security/security.c
+index 122b748..a4a3d99 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -404,6 +404,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(path, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ {
+@@ -411,6 +412,7 @@ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *path, struct dentry *dentry)
+ {
+@@ -418,6 +420,7 @@ int security_path_unlink(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *path, struct dentry *dentry,
+ const char *old_name)
+@@ -426,6 +429,7 @@ int security_path_symlink(struct path *path, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(path, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -434,6 +438,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -444,6 +449,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path, loff_t length,
+ unsigned int time_attrs)
+@@ -452,6 +458,7 @@ int security_path_truncate(struct path *path, loff_t length,
+ return 0;
+ return security_ops->path_truncate(path, length, time_attrs);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+
+ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ mode_t mode)
+@@ -460,6 +467,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ return 0;
+ return security_ops->path_chmod(dentry, mnt, mode);
+ }
++EXPORT_SYMBOL(security_path_chmod);
+
+ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ {
+@@ -467,6 +475,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ return 0;
+ return security_ops->path_chown(path, uid, gid);
+ }
++EXPORT_SYMBOL(security_path_chown);
+
+ int security_path_chroot(struct path *path)
+ {
+@@ -543,6 +552,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -557,6 +567,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -657,6 +668,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
+@@ -684,6 +696,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ return ret;
+ return ima_file_mmap(file, prot);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)