summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-05 14:34:23 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-05 14:34:23 +0000
commit48f7545d94fb602df462073e851258cf27a07362 (patch)
tree1b97c4a92ca1ee2b7c1ee02dd33e1f0568ca246c
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-48f7545d94fb602df462073e851258cf27a07362.tar.gz
gentoo-2-48f7545d94fb602df462073e851258cf27a07362.tar.bz2
gentoo-2-48f7545d94fb602df462073e851258cf27a07362.zip
Use make rules instead of applying a useless patch.
-rw-r--r--dev-lang/nasm/ChangeLog5
-rw-r--r--dev-lang/nasm/nasm-0.98.38.ebuild22
2 files changed, 14 insertions, 13 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 6ed571b6ad64..209354640450 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/nasm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.25 2004/05/11 09:23:18 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.26 2004/06/05 14:34:23 agriffis Exp $
+
+ 05 Jun 2004; Aron Griffis <agriffis@gentoo.org> nasm-0.98.38.ebuild:
+ Use make rules instead of applying a useless patch.
11 May 2004; Travis Tilley <lv@gentoo.org> nasm-0.98.38.ebuild:
added ~amd64 keyword
diff --git a/dev-lang/nasm/nasm-0.98.38.ebuild b/dev-lang/nasm/nasm-0.98.38.ebuild
index 2831a8d18a3b..79d6035ceec6 100644
--- a/dev-lang/nasm/nasm-0.98.38.ebuild
+++ b/dev-lang/nasm/nasm-0.98.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.38.ebuild,v 1.5 2004/05/11 09:23:18 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.38.ebuild,v 1.6 2004/06/05 14:34:23 agriffis Exp $
inherit eutils
@@ -17,31 +17,29 @@ DEPEND="!build? ( dev-lang/perl )
doc? ( virtual/ghostscript sys-apps/texinfo )
sys-devel/gcc"
-src_unpack() {
- unpack ${A}
-
- [ -z "`use doc`" ] && cd ${S} && epatch ${FILESDIR}/nasm-0.98.36-remove-doc-target.diff
-}
-
src_compile() {
./configure --prefix=/usr || die
- if [ `use build` ] ; then
- make nasm
+ if use build; then
+ make nasm || die
else
- make everything || die
+ make all rdf || die
+ if use doc; then
+ make doc || die
+ fi
fi
+
}
src_install() {
- if [ `use build` ] ; then
+ if use build; then
dobin nasm
else
dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx}
dosym /usr/bin/rdf2bin /usr/bin/rdf2com
doman nasm.1 ndisasm.1
dodoc AUTHORS CHANGES ChangeLog INSTALL README TODO
- if [ `use doc` ] ; then
+ if use doc; then
doinfo doc/info/*
dohtml doc/html/*
dodoc doc/nasmdoc.*