summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-17 19:02:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-17 19:02:34 +0000
commit4de08d671b6b416ae2b05eda395077d49a7e4ba0 (patch)
tree3effd86a1cb42cb40b485ff0b141a630a162c3f5
parentVersion bump. Don't install "deprecated" modprobe.d/modules.conf files. Bump ... (diff)
downloadgentoo-2-4de08d671b6b416ae2b05eda395077d49a7e4ba0.tar.gz
gentoo-2-4de08d671b6b416ae2b05eda395077d49a7e4ba0.tar.bz2
gentoo-2-4de08d671b6b416ae2b05eda395077d49a7e4ba0.zip
Version bump
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
-rw-r--r--sci-libs/libnova/ChangeLog10
-rw-r--r--sci-libs/libnova/libnova-0.15.0.ebuild42
2 files changed, 49 insertions, 3 deletions
diff --git a/sci-libs/libnova/ChangeLog b/sci-libs/libnova/ChangeLog
index 4a85f402fef6..53579a8e1950 100644
--- a/sci-libs/libnova/ChangeLog
+++ b/sci-libs/libnova/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libnova
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.14 2011/08/07 00:34:18 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.15 2012/07/17 19:02:34 bicatali Exp $
+
+*libnova-0.15.0 (17 Jul 2012)
+
+ 17 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +libnova-0.15.0.ebuild:
+ Version bump
*libnova-0.14.0 (07 Aug 2011)
@@ -58,4 +63,3 @@
21 May 2003; Matthew Kennedy <mkennedy@gentoo.org> libnova-0.7.0.ebuild:
initial import
-
diff --git a/sci-libs/libnova/libnova-0.15.0.ebuild b/sci-libs/libnova/libnova-0.15.0.ebuild
new file mode 100644
index 000000000000..73c3b19a32f0
--- /dev/null
+++ b/sci-libs/libnova/libnova-0.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/libnova-0.15.0.ebuild,v 1.1 2012/07/17 19:02:34 bicatali Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
+HOMEPAGE="http://libnova.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ if use examples; then
+ make clean
+ rm -f examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}