summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-03 19:18:23 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-03 19:18:23 +0000
commit54a9aed8b8c5eca8f9b7f69738153a14e9a705ca (patch)
treed4690ba1f5da2eb2389c8e808fc469caa7e0f2e3
parentDrop old. Remove remains of .la files. (diff)
downloadgentoo-2-54a9aed8b8c5eca8f9b7f69738153a14e9a705ca.tar.gz
gentoo-2-54a9aed8b8c5eca8f9b7f69738153a14e9a705ca.tar.bz2
gentoo-2-54a9aed8b8c5eca8f9b7f69738153a14e9a705ca.zip
Fix longdesc. Fix trailing whitespace. Use base eclass for PATCHES array (future use).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-libs/shivavg/ChangeLog7
-rw-r--r--media-libs/shivavg/metadata.xml5
-rw-r--r--media-libs/shivavg/shivavg-0.2.1.ebuild26
3 files changed, 21 insertions, 17 deletions
diff --git a/media-libs/shivavg/ChangeLog b/media-libs/shivavg/ChangeLog
index b3cd6c39bbd9..ad1911fd0ab0 100644
--- a/media-libs/shivavg/ChangeLog
+++ b/media-libs/shivavg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/shivavg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/shivavg/ChangeLog,v 1.1 2010/07/21 16:13:39 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/shivavg/ChangeLog,v 1.2 2010/08/03 19:18:23 scarabeus Exp $
+
+ 03 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> shivavg-0.2.1.ebuild,
+ metadata.xml:
+ Fix longdesc. Fix trailing whitespace. Use base eclass for PATCHES array
+ (future use).
*shivavg-0.2.1 (21 Jul 2010)
diff --git a/media-libs/shivavg/metadata.xml b/media-libs/shivavg/metadata.xml
index e4f583129506..228a9ef2e4d5 100644
--- a/media-libs/shivavg/metadata.xml
+++ b/media-libs/shivavg/metadata.xml
@@ -5,4 +5,9 @@
<maintainer>
<email>lu_zero@gentoo.org</email>
</maintainer>
+<longdescription>
+ShivaVG is an open-source ANSI C implementation of the Khronos'
+OpenVG specification for hardware-accelerated vector graphics API. It is built
+entirely on top of OpenGL.
+</longdescription>
</pkgmetadata>
diff --git a/media-libs/shivavg/shivavg-0.2.1.ebuild b/media-libs/shivavg/shivavg-0.2.1.ebuild
index 312239cc2989..c02dfafb6792 100644
--- a/media-libs/shivavg/shivavg-0.2.1.ebuild
+++ b/media-libs/shivavg/shivavg-0.2.1.ebuild
@@ -1,39 +1,33 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/shivavg/shivavg-0.2.1.ebuild,v 1.1 2010/07/21 16:13:39 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/shivavg/shivavg-0.2.1.ebuild,v 1.2 2010/08/03 19:18:23 scarabeus Exp $
-EAPI=2
-
-inherit autotools
-
-DESCRIPTION="ShivaVG is an open-source ANSI C implementation of the Khronos'
-OpenVG specification for hardware-accelerated vector graphics API. It is built
-entirely on top of OpenGL."
-HOMEPAGE="http://shivavg.sourceforge.net"
+EAPI=3
MY_PN="ShivaVG"
MY_P="${MY_PN}-${PV}"
+inherit base autotools
+DESCRIPTION="open-source implementation of the Khronos' OpenVG specification"
+HOMEPAGE="http://shivavg.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~arm ~amd64"
+KEYWORDS="~arm ~amd64 ~x86"
IUSE=""
RDEPEND="virtual/glu
- virtual/glut
- virtual/opengl"
+ virtual/glut
+ virtual/opengl"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ base_src_prepare
+
sed -i -e 's:LDFLAGS="$LDFLAGS :LIBS=":g' \
configure.in
eautoreconf
}
-
-src_install() {
- emake DESTDIR=${D} install || die
-}