summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 13:02:11 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 13:02:11 +0000
commit54fcaf9d18ad6d9814802c9ed5add7b6fdd9a4f8 (patch)
treef558556c0a7498569f0fffdbe6d084823b7f4c61
parentBump text to 1.1.0.1 (diff)
downloadgentoo-2-54fcaf9d18ad6d9814802c9ed5add7b6fdd9a4f8.tar.gz
gentoo-2-54fcaf9d18ad6d9814802c9ed5add7b6fdd9a4f8.tar.bz2
gentoo-2-54fcaf9d18ad6d9814802c9ed5add7b6fdd9a4f8.zip
Bump tls to 1.2.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/tls/ChangeLog10
-rw-r--r--dev-haskell/tls/tls-1.1.2.ebuild41
-rw-r--r--dev-haskell/tls/tls-1.2.2.ebuild50
3 files changed, 58 insertions, 43 deletions
diff --git a/dev-haskell/tls/ChangeLog b/dev-haskell/tls/ChangeLog
index 6192a89efb41..0460b91bc66c 100644
--- a/dev-haskell/tls/ChangeLog
+++ b/dev-haskell/tls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/tls
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.4 2013/11/24 19:39:28 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.5 2014/03/09 13:02:11 gienah Exp $
+
+*tls-1.2.2 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +tls-1.2.2.ebuild,
+ -tls-1.1.2.ebuild:
+ Bump tls to 1.2.2
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> tls-1.1.5.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/tls/tls-1.1.2.ebuild b/dev-haskell/tls/tls-1.1.2.ebuild
deleted file mode 100644
index 2564011dad4b..000000000000
--- a/dev-haskell/tls/tls-1.1.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/tls-1.1.2.ebuild,v 1.1 2013/08/26 08:20:07 qnikst Exp $
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.2.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
-HOMEPAGE="http://github.com/vincenthz/hs-tls"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+compat"
-
-RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
- >=dev-haskell/certificate-1.3.0:=[profile?]
- <dev-haskell/certificate-1.4.0:=[profile?]
- dev-haskell/crypto-pubkey:=[profile?]
- =dev-haskell/crypto-random-api-0.2*:=[profile?]
- >=dev-haskell/cryptohash-0.6:=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/network:=[profile?]
- >=dev-lang/ghc-6.10.4:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/cprng-aes
- >=dev-haskell/quickcheck-2
- dev-haskell/test-framework
- dev-haskell/test-framework-quickcheck2
- )"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag compat compat)
-}
diff --git a/dev-haskell/tls/tls-1.2.2.ebuild b/dev-haskell/tls/tls-1.2.2.ebuild
new file mode 100644
index 000000000000..0213ed5b961b
--- /dev/null
+++ b/dev-haskell/tls/tls-1.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/tls-1.2.2.ebuild,v 1.1 2014/03/09 13:02:11 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="http://github.com/vincenthz/hs-tls"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat"
+
+RDEPEND="dev-haskell/asn1-encoding:=[profile?]
+ >=dev-haskell/asn1-types-0.2.0:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/cipher-aes-0.2:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ dev-haskell/cipher-rc4:=[profile?]
+ dev-haskell/crypto-numbers:=[profile?]
+ >=dev-haskell/crypto-pubkey-0.2.4:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.6:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/x509-1.4.3:=[profile?] <dev-haskell/x509-1.5.0:=[profile?]
+ >=dev-haskell/x509-store-1.4.4:=[profile?]
+ >=dev-haskell/x509-validation-1.5.0:=[profile?] <dev-haskell/x509-validation-1.6.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cprng-aes-0.5
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat)
+}