summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-20 12:14:03 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-20 12:14:03 +0000
commit56db9eef41f2963c1827852adc767bd7da5822a7 (patch)
tree1ae60fc8263f321d865bf48a545a8491e9f41eba
parentadd =sys-libs/glibc-2.6* to package.mask (like already done with (diff)
downloadgentoo-2-56db9eef41f2963c1827852adc767bd7da5822a7.tar.gz
gentoo-2-56db9eef41f2963c1827852adc767bd7da5822a7.tar.bz2
gentoo-2-56db9eef41f2963c1827852adc767bd7da5822a7.zip
Fix building with -Wl,--as-needed.
(Portage version: 2.1.3_rc8)
-rw-r--r--x11-misc/fluxconf/ChangeLog6
-rw-r--r--x11-misc/fluxconf/files/fluxconf-0.9.9-asneeded.patch11
-rw-r--r--x11-misc/fluxconf/fluxconf-0.9.9.ebuild13
3 files changed, 28 insertions, 2 deletions
diff --git a/x11-misc/fluxconf/ChangeLog b/x11-misc/fluxconf/ChangeLog
index 304df43e97c9..4fb07a6ea3e0 100644
--- a/x11-misc/fluxconf/ChangeLog
+++ b/x11-misc/fluxconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fluxconf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxconf/ChangeLog,v 1.33 2007/07/20 12:00:00 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxconf/ChangeLog,v 1.34 2007/07/20 12:14:03 drac Exp $
+
+ 20 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/fluxconf-0.9.9-asneeded.patch, fluxconf-0.9.9.ebuild:
+ Fix building with -Wl,--as-needed.
*fluxconf-0.9.9 (20 Jul 2007)
diff --git a/x11-misc/fluxconf/files/fluxconf-0.9.9-asneeded.patch b/x11-misc/fluxconf/files/fluxconf-0.9.9-asneeded.patch
new file mode 100644
index 000000000000..a3fd32c7cfe8
--- /dev/null
+++ b/x11-misc/fluxconf/files/fluxconf-0.9.9-asneeded.patch
@@ -0,0 +1,11 @@
+diff -ur fluxconf-0.9.9.orig/src/Makefile.am fluxconf-0.9.9/src/Makefile.am
+--- fluxconf-0.9.9.orig/src/Makefile.am 2004-02-02 21:45:27.000000000 +0200
++++ fluxconf-0.9.9/src/Makefile.am 2007-07-20 15:07:08.000000000 +0300
+@@ -5,6 +5,7 @@
+ fluxconf_SOURCES=fluxconf.c fluxmenu.c fluxkeys.c fluxbare.c actions.c
+ fluxconf_INCLUDES=include/globals.h include/defines.h include/functions.h xpm/dalogo.h xpm/fc_menu.xpm xpm/fc_keys.xpm xpm/fc_conf.xpm
+ fluxconf_CFLAGS=-Iinclude/ -Ixpm/ -ggdb -D_GNU_SOURCE -Werror
++fluxconf_LDADD=-lgtk-x11-2.0
+
+ #noinst_PROGRAMS=fluxkeys
+ #fluxconf_LDFLAGS=`$(GTKCONF) --libs --cflags`
diff --git a/x11-misc/fluxconf/fluxconf-0.9.9.ebuild b/x11-misc/fluxconf/fluxconf-0.9.9.ebuild
index 757bb4686f9e..39801518e592 100644
--- a/x11-misc/fluxconf/fluxconf-0.9.9.ebuild
+++ b/x11-misc/fluxconf/fluxconf-0.9.9.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxconf/fluxconf-0.9.9.ebuild,v 1.1 2007/07/20 12:00:00 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxconf/fluxconf-0.9.9.ebuild,v 1.2 2007/07/20 12:14:03 drac Exp $
+
+WANT_AUTOMAKE="1.7"
+
+inherit autotools eutils
DESCRIPTION="Configuration editor for fluxbox"
SRC_URI="http://devaux.fabien.free.fr/flux/${P}.tar.gz"
@@ -14,6 +18,13 @@ IUSE="nls"
RDEPEND=">=x11-libs/gtk+-2"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautomake
+}
+
src_compile() {
econf $(use_enable nls)
emake || die "emake failed."