summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-06-05 17:20:53 +0000
committerThomas Sachau <tommy@gentoo.org>2009-06-05 17:20:53 +0000
commit5d24063cb5e5b3d541bb3b967a22a799f314d7f7 (patch)
tree579c4d2052ace101cb3c9092d6c64fd72596a82f
parentAdd ~sparc for testing, part of Bug #272046. (diff)
downloadgentoo-2-5d24063cb5e5b3d541bb3b967a22a799f314d7f7.tar.gz
gentoo-2-5d24063cb5e5b3d541bb3b967a22a799f314d7f7.tar.bz2
gentoo-2-5d24063cb5e5b3d541bb3b967a22a799f314d7f7.zip
Bump to latest git version, add ramfs support for bug 272418
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--sys-fs/aufs2/ChangeLog9
-rw-r--r--sys-fs/aufs2/aufs2-0_p20090601.ebuild90
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-29.patch21
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone.patch21
-rw-r--r--sys-fs/aufs2/metadata.xml3
5 files changed, 100 insertions, 44 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 29ff0d93d36b..c899453b3038 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.2 2009/05/24 18:30:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.3 2009/06/05 17:20:53 tommy Exp $
+
+*aufs2-0_p20090601 (05 Jun 2009)
+
+ 05 Jun 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ files/aufs2-standalone-29.patch, files/aufs2-standalone.patch,
+ +aufs2-0_p20090601.ebuild, metadata.xml:
+ Bump to latest git version
24 May 2009; Markus Meier <maekke@gentoo.org> aufs2-0_p20090504.ebuild:
add ~x86, bug #270036
diff --git a/sys-fs/aufs2/aufs2-0_p20090601.ebuild b/sys-fs/aufs2/aufs2-0_p20090601.ebuild
new file mode 100644
index 000000000000..1ab380895cf1
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20090601.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20090601.ebuild,v 1.1 2009/06/05 17:20:53 tommy Exp $
+
+EGIT_REPO_URI="http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-standalone.git"
+
+inherit git linux-mod toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug hinotify ramfs"
+
+DEPEND=""
+RDEPEND="!sys-fs/aufs"
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ get_version
+ if ! grep -qs "EXPORT_SYMBOL(deny_write_access);" ${KV_DIR}/fs/namei.c; then
+ ewarn "Patching your kernel..."
+ cd ${KV_DIR}
+ if kernel_is eq 2 6 27; then
+ epatch "${FILESDIR}"/aufs2-standalone.patch
+ elif kernel_is eq 2 6 28; then
+ epatch "${FILESDIR}"/aufs2-standalone.patch
+ elif kernel_is eq 2 6 29; then
+ epatch "${FILESDIR}"/aufs2-standalone-29.patch
+ else
+ die "no supported kernel found"
+ fi
+ elog "You need to compile your kernel with the applied patch"
+ elog "to be able to load and use the aufs kernel module"
+ fi
+
+ linux-mod_pkg_setup
+}
+src_unpack() {
+ if kernel_is eq 2 6 27; then
+ EGIT_BRANCH="aufs2-27"
+ EGIT_TREE="8e8d6394f50d9cfdc434766ea2434018788ca111"
+ elif kernel_is eq 2 6 28; then
+ EGIT_BRANCH="aufs2-28"
+ EGIT_TREE="78e9abebac8f283dd4f113f392a9943a7b212b0e"
+ elif kernel_is eq 2 6 29; then
+ EGIT_BRANCH="aufs2-29"
+ EGIT_TREE="d2db0dbfac69b5a04df5a78a454a2c9b8c658aa6"
+ else
+ die "no supported kernel found"
+ fi
+ git_src_unpack
+ cd "${S}"
+
+ use debug || sed -i "s:DEBUG = y:DEBUG =:g" config.mk
+ use hinotify && sed -i "s:HINOTIFY =:HINOTIFY = y:g" config.mk
+ use ramfs && sed -i "s:RAMFS =:RAMFS = y:g" config.mk
+
+ EGIT_REPO_URI="http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-util.git"
+ EGIT_TREE="8d4217be37b74732afa80bc6e6519bd9df7ea1af"
+ EGIT_PROJECT="aufs2-utils"
+ EGIT_BRANCH=""
+ local S=${S}-utils
+ git_src_unpack
+ cd "${S}"
+ sed -i "/LDFLAGS += -static -s/d" Makefile
+}
+
+src_compile() {
+ ARCH=i386
+ use amd64 && ARCH=x86_64
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR} || die
+ cd "${S}"-utils
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+ docinto design
+ dodoc design/*.txt || die
+ cd "${S}"-utils
+ emake DESTDIR="${D}" install || die
+ docinto
+ newdoc README README-utils || die
+}
diff --git a/sys-fs/aufs2/files/aufs2-standalone-29.patch b/sys-fs/aufs2/files/aufs2-standalone-29.patch
index 75ff5eeaa073..63d6900f57bd 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-29.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-29.patch
@@ -1,14 +1,5 @@
aufs2 standalone patch for linux-2.6.29
-diff --git a/fs/Makefile b/fs/Makefile
-index dc20db3..a4e9a65 100644
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -124,3 +124,4 @@ obj-$(CONFIG_DEBUG_FS) += debugfs/
- obj-$(CONFIG_OCFS2_FS) += ocfs2/
- obj-$(CONFIG_BTRFS_FS) += btrfs/
- obj-$(CONFIG_GFS2_FS) += gfs2/
-+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/fs/namei.c b/fs/namei.c
index bbc15c2..e54d1b2 100644
--- a/fs/namei.c
@@ -128,18 +119,6 @@ index 6ce5014..af66b69 100644
/**
* generic_shutdown_super - common helper for ->kill_sb()
-diff --git a/include/linux/Kbuild b/include/linux/Kbuild
-index 106c3ba..d0c7262 100644
---- a/include/linux/Kbuild
-+++ b/include/linux/Kbuild
-@@ -34,6 +34,7 @@ header-y += atmppp.h
- header-y += atmsap.h
- header-y += atmsvc.h
- header-y += atm_zatm.h
-+header-y += aufs_type.h
- header-y += auto_fs4.h
- header-y += ax25.h
- header-y += b1lli.h
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index 23bf02f..49e5b47 100644
--- a/include/linux/lockdep.h
diff --git a/sys-fs/aufs2/files/aufs2-standalone.patch b/sys-fs/aufs2/files/aufs2-standalone.patch
index 775f9ed7ef21..aacd3760e849 100644
--- a/sys-fs/aufs2/files/aufs2-standalone.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone.patch
@@ -1,14 +1,5 @@
aufs2 standalone patch for linux-2.6.28
-diff --git a/fs/Makefile b/fs/Makefile
-index d9f8afe..1f206a2 100644
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -122,3 +122,4 @@ obj-$(CONFIG_HPPFS) += hppfs/
- obj-$(CONFIG_DEBUG_FS) += debugfs/
- obj-$(CONFIG_OCFS2_FS) += ocfs2/
- obj-$(CONFIG_GFS2_FS) += gfs2/
-+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/fs/namei.c b/fs/namei.c
index d34e0f9..2779304 100644
--- a/fs/namei.c
@@ -140,18 +131,6 @@ index 2967562..34040d6 100644
static long __do_fsync(unsigned int fd, int datasync)
{
-diff --git a/include/linux/Kbuild b/include/linux/Kbuild
-index e531783..14ecb7c 100644
---- a/include/linux/Kbuild
-+++ b/include/linux/Kbuild
-@@ -34,6 +34,7 @@ header-y += atmppp.h
- header-y += atmsap.h
- header-y += atmsvc.h
- header-y += atm_zatm.h
-+header-y += aufs_type.h
- header-y += auto_fs4.h
- header-y += ax25.h
- header-y += b1lli.h
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index 29aec6e..dfcb13b 100644
--- a/include/linux/lockdep.h
diff --git a/sys-fs/aufs2/metadata.xml b/sys-fs/aufs2/metadata.xml
index 2af1090ccd54..0187df67f6be 100644
--- a/sys-fs/aufs2/metadata.xml
+++ b/sys-fs/aufs2/metadata.xml
@@ -6,7 +6,8 @@
<email>tommy@gentoo.org</email>
</maintainer>
<use>
- <flag name='hinotify'>Enable hinotify support</flag>
<flag name='debug'>Enable additional debugging support</flag>
+ <flag name='hinotify'>Enable hinotify support</flag>
+ <flag name='ramfs'>Enable initramfs/rootfs support</flag>
</use>
</pkgmetadata>