summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-09-26 22:31:33 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-09-26 22:31:33 +0000
commit5fa1a913c73cd678dbcd2fbb27a6bca77147b94e (patch)
tree6b83d71fba25d813072acf450563c02fe268a95b
parentVersion bump. (diff)
downloadgentoo-2-5fa1a913c73cd678dbcd2fbb27a6bca77147b94e.tar.gz
gentoo-2-5fa1a913c73cd678dbcd2fbb27a6bca77147b94e.tar.bz2
gentoo-2-5fa1a913c73cd678dbcd2fbb27a6bca77147b94e.zip
Fix bug #232081, gcc-4.3 compat. Thanks to Magnus Granberg <zorry@ume.nu>.
(Portage version: 2.2_rc10/cvs/Linux 2.6.25.8 i686)
-rw-r--r--sys-devel/gettext/ChangeLog6
-rw-r--r--sys-devel/gettext/files/gettext-0.17-open-args.patch25
-rw-r--r--sys-devel/gettext/gettext-0.17.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 0d46e2002d08..0b6bdab189d6 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.165 2008/08/02 12:04:24 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.166 2008/09/26 22:31:33 loki_val Exp $
+
+ 26 Sep 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/gettext-0.17-open-args.patch, gettext-0.17.ebuild:
+ Fix bug #232081, gcc-4.3 compat. Thanks to Magnus Granberg <zorry@ume.nu>.
02 Aug 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/sys-devel/gettext/files/gettext-0.17-open-args.patch b/sys-devel/gettext/files/gettext-0.17-open-args.patch
new file mode 100644
index 000000000000..330cbf614631
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.17-open-args.patch
@@ -0,0 +1,25 @@
+2007-11-07 Jim Meyering <meyering@redhat.com>
+ Bruno Haible <bruno@clisp.org>
+
+ * write-catalog.c (msgdomain_list_print): Fix open() call.
+
+--- gettext-tools/src/write-catalog.c 7 Oct 2007 19:35:31 -0000 1.4
++++ gettext-tools/src/write-catalog.c 7 Nov 2007 11:43:15 -0000
+@@ -1,5 +1,5 @@
+ /* GNU gettext - internationalization aids
+- Copyright (C) 1995-1998, 2000-2006 Free Software Foundation, Inc.
++ Copyright (C) 1995-1998, 2000-2007 Free Software Foundation, Inc.
+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -220,7 +220,9 @@
+ /* Open the output file. */
+ if (!to_stdout)
+ {
+- fd = open (filename, O_WRONLY | O_CREAT);
++ fd = open (filename, O_WRONLY | O_CREAT | O_TRUNC,
++ /* 0666 in portable POSIX notation: */
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if (fd < 0)
+ {
+ const char *errno_description = strerror (errno);
diff --git a/sys-devel/gettext/gettext-0.17.ebuild b/sys-devel/gettext/gettext-0.17.ebuild
index 8ff4e4868110..3da6cb4f0973 100644
--- a/sys-devel/gettext/gettext-0.17.ebuild
+++ b/sys-devel/gettext/gettext-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.17.ebuild,v 1.12 2008/07/02 20:39:13 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.17.ebuild,v 1.13 2008/09/26 22:31:33 loki_val Exp $
inherit flag-o-matic eutils multilib toolchain-funcs mono libtool
@@ -29,6 +29,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch #85054
epatch "${FILESDIR}"/${PN}-0.15-expat-no-dlopen.patch #146211
+ epatch "${FILESDIR}"/${PN}-0.17-open-args.patch #232081
# bundled libtool seems to be broken so skip certain rpath tests
# http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html