summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-10 10:48:17 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-10 10:48:17 +0000
commit60c3af0faade0720f12d07ad98960f537c797b53 (patch)
tree3e522e3b422cbe2cf7052fa952a75759f956dc3e
parentStable for ppc64, wrt bug #527084 (diff)
downloadgentoo-2-60c3af0faade0720f12d07ad98960f537c797b53.tar.gz
gentoo-2-60c3af0faade0720f12d07ad98960f537c797b53.tar.bz2
gentoo-2-60c3af0faade0720f12d07ad98960f537c797b53.zip
Fix building against sys-libs/ncurses[tinfo] (bug #528578).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--sys-process/ftop/ChangeLog6
-rw-r--r--sys-process/ftop/files/ftop-1.0-tinfo.patch10
-rw-r--r--sys-process/ftop/ftop-1.0.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-process/ftop/ChangeLog b/sys-process/ftop/ChangeLog
index 30de39aba688..41094c3ba530 100644
--- a/sys-process/ftop/ChangeLog
+++ b/sys-process/ftop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/ftop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/ftop/ChangeLog,v 1.1 2014/01/30 00:21:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/ftop/ChangeLog,v 1.2 2014/11/10 10:48:17 jer Exp $
+
+ 10 Nov 2014; Jeroen Roovers <jer@gentoo.org> +files/ftop-1.0-tinfo.patch,
+ ftop-1.0.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #528578).
*ftop-1.0 (30 Jan 2014)
diff --git a/sys-process/ftop/files/ftop-1.0-tinfo.patch b/sys-process/ftop/files/ftop-1.0-tinfo.patch
new file mode 100644
index 000000000000..cdbc30efa48e
--- /dev/null
+++ b/sys-process/ftop/files/ftop-1.0-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,6 +15,7 @@
+
+ # Checks for libraries.
+ AC_CHECK_LIB([curses], [initscr])
++AC_SEARCH_LIBS(stdscr,tinfo)
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/sys-process/ftop/ftop-1.0.ebuild b/sys-process/ftop/ftop-1.0.ebuild
index 18539a914e27..9c94fe9e186a 100644
--- a/sys-process/ftop/ftop-1.0.ebuild
+++ b/sys-process/ftop/ftop-1.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/ftop/ftop-1.0.ebuild,v 1.1 2014/01/30 00:21:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/ftop/ftop-1.0.ebuild,v 1.2 2014/11/10 10:48:17 jer Exp $
EAPI="5"
+AUTOTOOLS_AUTORECONF=frob
inherit autotools-utils
DESCRIPTION="Monitor open files and filesystems"
@@ -17,4 +18,7 @@ KEYWORDS="~amd64"
DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-overflow.patch ) \ No newline at end of file
+PATCHES=(
+ "${FILESDIR}"/${P}-overflow.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)