summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-01-16 19:51:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-01-16 19:51:49 +0000
commit63ca4d2d21b4808af119c35b8ee0d8d78074f857 (patch)
treeca1acfc476b6cfaeec11fd15bec89c36df31a225
parentalpha stable wrt #198820, thanks to Tobias Klausmann for testing (diff)
downloadgentoo-2-63ca4d2d21b4808af119c35b8ee0d8d78074f857.tar.gz
gentoo-2-63ca4d2d21b4808af119c35b8ee0d8d78074f857.tar.bz2
gentoo-2-63ca4d2d21b4808af119c35b8ee0d8d78074f857.zip
new stable version and development version
(Portage version: 2.1.4)
-rw-r--r--x11-libs/cairo/ChangeLog10
-rw-r--r--x11-libs/cairo/cairo-1.4.14.ebuild (renamed from x11-libs/cairo/cairo-1.5.4-r2.ebuild)28
-rw-r--r--x11-libs/cairo/cairo-1.5.6.ebuild (renamed from x11-libs/cairo/cairo-1.5.4-r1.ebuild)7
-rw-r--r--x11-libs/cairo/files/cairo-1.5.4-sparc-alignment.patch13
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.4.143
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.5.4-r13
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.5.4-r23
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.5.63
8 files changed, 25 insertions, 45 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 863e8ab1c1cb..4fd54f094759 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.159 2008/01/08 20:36:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.160 2008/01/16 19:51:48 cardoe Exp $
+
+*cairo-1.5.6 (16 Jan 2008)
+*cairo-1.4.14 (16 Jan 2008)
+
+ 16 Jan 2008; Doug Klima <cardoe@gentoo.org>
+ -files/cairo-1.5.4-sparc-alignment.patch, +cairo-1.4.14.ebuild,
+ -cairo-1.5.4-r1.ebuild, -cairo-1.5.4-r2.ebuild, +cairo-1.5.6.ebuild:
+ new stable version and development version
*cairo-1.5.4-r2 (08 Jan 2008)
diff --git a/x11-libs/cairo/cairo-1.5.4-r2.ebuild b/x11-libs/cairo/cairo-1.4.14.ebuild
index d676e03e8e9a..ab2bf4926cfb 100644
--- a/x11-libs/cairo/cairo-1.5.4-r2.ebuild
+++ b/x11-libs/cairo/cairo-1.4.14.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.5.4-r2.ebuild,v 1.1 2008/01/08 20:36:07 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.4.14.ebuild,v 1.1 2008/01/16 19:51:48 cardoe Exp $
inherit eutils flag-o-matic libtool
DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="http://cairographics.org/"
-SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug directfb doc glitz opengl svg X xcb test"
+IUSE="debug directfb doc glitz opengl svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
RDEPEND="media-libs/fontconfig
>=media-libs/freetype-2.1.4
- sys-libs/zlib
media-libs/libpng
- >=x11-libs/pixman-0.9.4
X? (
x11-libs/libXrender
x11-libs/libXext
@@ -32,17 +33,10 @@ RDEPEND="media-libs/fontconfig
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.19
- test? (
- virtual/ghostscript
- >=app-text/poppler-bindings-0.4.1
- x11-libs/pango
- x11-libs/gtk+
- svg? ( >=gnome-base/librsvg-2.15.0 )
- )
X? ( x11-proto/renderproto
xcb? ( x11-proto/xcb-proto ) )
doc? (
- >=dev-util/gtk-doc-1.6
+ >=dev-util/gtk-doc-1.3
~app-text/docbook-xml-dtd-4.2
)"
@@ -50,12 +44,6 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # SPARC alignment patch
- epatch "${FILESDIR}"/${P}-sparc-alignment.patch
-
- # Mozilla corruption patch
- epatch "${FILESDIR}"/${P}-fix-private.patch
-
# We need to run elibtoolize to ensure correct so versioning on FreeBSD
elibtoolize
}
@@ -69,7 +57,7 @@ src_compile() {
fi
econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
- $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
+ $(use_enable svg) $(use_enable glitz) \
$(use_enable debug test-surfaces) --enable-pdf --enable-png \
--enable-freetype --enable-ps $(use_enable xcb) \
|| die "configure failed"
diff --git a/x11-libs/cairo/cairo-1.5.4-r1.ebuild b/x11-libs/cairo/cairo-1.5.6.ebuild
index c2d3e81a727b..24d7cb36be5f 100644
--- a/x11-libs/cairo/cairo-1.5.4-r1.ebuild
+++ b/x11-libs/cairo/cairo-1.5.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.5.4-r1.ebuild,v 1.1 2007/12/27 14:19:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.5.6.ebuild,v 1.1 2008/01/16 19:51:48 cardoe Exp $
inherit eutils flag-o-matic libtool
@@ -50,9 +50,6 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # SPARC alignment patch
- epatch "${FILESDIR}"/${P}-sparc-alignment.patch
-
# We need to run elibtoolize to ensure correct so versioning on FreeBSD
elibtoolize
}
diff --git a/x11-libs/cairo/files/cairo-1.5.4-sparc-alignment.patch b/x11-libs/cairo/files/cairo-1.5.4-sparc-alignment.patch
deleted file mode 100644
index 2a7e0f290688..000000000000
--- a/x11-libs/cairo/files/cairo-1.5.4-sparc-alignment.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cairo-path-fixed.c.orig 2007-12-27 00:01:13.000000000 +0000
-+++ src/cairo-path-fixed.c 2007-12-27 00:02:10.000000000 +0000
-@@ -415,8 +415,8 @@
- buf->num_points = 0;
- buf->buf_size = buf_size;
-
-- buf->op = (cairo_path_op_t *) (buf + 1);
-- buf->points = (cairo_point_t *) (buf->op + buf_size);
-+ buf->points = (cairo_point_t *) (buf + 1);
-+ buf->op = (cairo_path_op_t *) (buf->points + 2 * buf_size);
- }
-
- return buf; \ No newline at end of file
diff --git a/x11-libs/cairo/files/digest-cairo-1.4.14 b/x11-libs/cairo/files/digest-cairo-1.4.14
new file mode 100644
index 000000000000..cf308e82b25d
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.4.14
@@ -0,0 +1,3 @@
+MD5 e8c442ff821c0719a69508fecba9038f cairo-1.4.14.tar.gz 3283608
+RMD160 9e7c87a292c889b06b29e9622be0a7daa3ddd6fd cairo-1.4.14.tar.gz 3283608
+SHA256 8914f9c34a77bf9d908b0c617c2d7ffebdd6d1e855cfd367d2a1b3d677f22e3c cairo-1.4.14.tar.gz 3283608
diff --git a/x11-libs/cairo/files/digest-cairo-1.5.4-r1 b/x11-libs/cairo/files/digest-cairo-1.5.4-r1
deleted file mode 100644
index 716222d0cdcb..000000000000
--- a/x11-libs/cairo/files/digest-cairo-1.5.4-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2738af237fc125f7e7d3e7bf8c5728c4 cairo-1.5.4.tar.gz 3283307
-RMD160 2ccdbd21adf344dc7405951d919a89610deb6d14 cairo-1.5.4.tar.gz 3283307
-SHA256 dafc9c43fe20977ece09aeff699d42b1f55a7f7465ca76baf96d42a379d36b57 cairo-1.5.4.tar.gz 3283307
diff --git a/x11-libs/cairo/files/digest-cairo-1.5.4-r2 b/x11-libs/cairo/files/digest-cairo-1.5.4-r2
deleted file mode 100644
index 716222d0cdcb..000000000000
--- a/x11-libs/cairo/files/digest-cairo-1.5.4-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2738af237fc125f7e7d3e7bf8c5728c4 cairo-1.5.4.tar.gz 3283307
-RMD160 2ccdbd21adf344dc7405951d919a89610deb6d14 cairo-1.5.4.tar.gz 3283307
-SHA256 dafc9c43fe20977ece09aeff699d42b1f55a7f7465ca76baf96d42a379d36b57 cairo-1.5.4.tar.gz 3283307
diff --git a/x11-libs/cairo/files/digest-cairo-1.5.6 b/x11-libs/cairo/files/digest-cairo-1.5.6
new file mode 100644
index 000000000000..893818a47f92
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.5.6
@@ -0,0 +1,3 @@
+MD5 3ebb218d5625b9339df819c4c03e462e cairo-1.5.6.tar.gz 3433496
+RMD160 319b452affacea71b15502a9d461a23bfc93553c cairo-1.5.6.tar.gz 3433496
+SHA256 e6f900f10cec90b905588dff17b3c80b0fab928b93b4cd7520d39b5e3490d2bf cairo-1.5.6.tar.gz 3433496