summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-08 16:30:44 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-08 16:30:44 +0000
commit68f794e6c98f76ee6095bd7e2b7364606a9a5686 (patch)
tree7ae869edb9ba1dbf98c53cd3dcf29efebee0a313
parentFix gecos in ChangeLog entry. (diff)
downloadgentoo-2-68f794e6c98f76ee6095bd7e2b7364606a9a5686.tar.gz
gentoo-2-68f794e6c98f76ee6095bd7e2b7364606a9a5686.tar.bz2
gentoo-2-68f794e6c98f76ee6095bd7e2b7364606a9a5686.zip
version bump
(Portage version: 2.1.3.7)
-rw-r--r--www-apache/anyterm/ChangeLog9
-rw-r--r--www-apache/anyterm/anyterm-1.1.15.ebuild100
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch75
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt59
-rw-r--r--www-apache/anyterm/files/digest-anyterm-1.1.153
5 files changed, 245 insertions, 1 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index 0f822cea2cb9..f934e29ef695 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/anyterm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.7 2007/09/01 13:12:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.8 2007/09/08 16:30:43 hollow Exp $
+
+*anyterm-1.1.15 (08 Sep 2007)
+
+ 08 Sep 2007; Benedikt Böhm <hollow@gentoo.org>
+ +files/anyterm-1.1.15-browser-gentoo.patch,
+ +files/anyterm-1.1.15-postinst-en.txt, +anyterm-1.1.15.ebuild:
+ version bump
01 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing twp from metadata due to his retirement (see #190561 for reference).
diff --git a/www-apache/anyterm/anyterm-1.1.15.ebuild b/www-apache/anyterm/anyterm-1.1.15.ebuild
new file mode 100644
index 000000000000..52a4e304ff26
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.15.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.15.ebuild,v 1.1 2007/09/08 16:30:43 hollow Exp $
+
+inherit apache-module eutils toolchain-funcs webapp
+
+KEYWORDS="~x86"
+
+DESCRIPTION="A terminal anywhere."
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="opera pam ssl"
+
+DEPEND="dev-libs/boost
+ >=dev-libs/rote-0.2.8
+ >=sys-devel/gcc-3
+ virtual/ssh
+ pam? ( www-apache/mod_auth_pam )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="ANYTERM"
+use pam && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D AUTH_PAM"
+use ssl && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D SSL"
+APACHE2_MOD_FILE="${S}/apachemod/.libs/${PN}.so"
+DOCFILES="CHANGELOG README"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+need_apache2
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ apache-module_pkg_setup
+
+ if use ssl && ! built_with_use www-servers/apache ssl; then
+ eerror "Build www-servers/apache with USE=ssl." && die
+ die
+ fi
+
+ if ! built_with_use dev-libs/boost threads; then
+ eerror "Build dev-libs/boost with USE=threads."
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-browser-gentoo.patch"
+ sed -i -e "s:apr-config:$(apr_config):g" apachemod/Makefile
+}
+
+src_compile() {
+ ( cd apachemod && emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed" )
+
+ # Modify browser files to reflect USE flags.
+ for flag in opera pam ssl ; do
+ if use ${flag} ; then
+ sed -i -e "s/^#USE=${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=-${flag}#/D" browser/{*,.htaccess}
+ else
+ sed -i -e "s/^#USE=-${flag}#//" browser/{*,.htaccess}
+ sed -i -e "/^#USE=${flag}#/D" browser/{*,.htaccess}
+ fi
+ done
+}
+
+src_install() {
+ apache-module_src_install
+
+ webapp_src_preinst
+ cp -f browser/{*,.htaccess} "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en "${FILESDIR}/${P}-postinst-en.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ apache-module_pkg_postinst
+
+ if ! use ssl ; then
+ ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
+ fi
+ if ! use pam ; then
+ ewarn "USE=-pam: You will have to add your own authentication"
+ ewarn " mechanism."
+ fi
+ if use opera ; then
+ ewarn "USE=opera: Be sure to disable some logging in your Apache"
+ ewarn " configuration files!"
+ fi
+ if ! use ssl || ! use pam || use opera ; then
+ ewarn "For more information see http://anyterm.org/security.html"
+ fi
+}
diff --git a/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch b/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch
new file mode 100644
index 000000000000..0b06a5121a30
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch
@@ -0,0 +1,75 @@
+Index: anyterm-1.1.15/browser/anyterm.js
+===================================================================
+--- anyterm-1.1.15.orig/browser/anyterm.js
++++ anyterm-1.1.15/browser/anyterm.js
+@@ -24,16 +24,21 @@ var term;
+ var open=false;
+ var session;
+
+-var method="POST";
+-//var method="GET";
++#USE=opera#//var method="POST";
++#USE=opera#var method="GET";
++#USE=-opera#var method="POST";
++#USE=-opera#//var method="GET";
+
+ // Random sequence numbers are needed to prevent Opera from caching
+ // replies
+
+ var is_opera = navigator.userAgent.toLowerCase().indexOf("opera") != -1;
+-if (is_opera) {
+- method="GET";
+-}
++#USE=opera#if (is_opera) {
++#USE=opera# method="GET";
++#USE=opera#}
++#USE=-opera#//if (is_opera) {
++#USE=-opera#// method="GET";
++#USE=-opera#//}
+
+ var seqnum_val=Math.round(Math.random()*100000);
+ function cachebust() {
+Index: anyterm-1.1.15/browser/.htaccess
+===================================================================
+--- anyterm-1.1.15.orig/browser/.htaccess
++++ anyterm-1.1.15/browser/.htaccess
+@@ -6,6 +6,8 @@
+ # will be ignored if the anyterm module has not been loaded.
+
+ <IfModule anyterm>
++#USE=ssl#<IfModule mod_ssl.c>
++#USE=pam#<IfModule mod_auth_pam.c>
+
+ # Use an anyterm_command directive to specify the command to run
+ # inside the terminal:
+@@ -24,6 +26,16 @@
+ # Example:
+ # anyterm_command '/path/to/anygetty --remotehost "Anyterm: %h" --autologin=%u'
+
++# twp: Use ssh to avoid problems with Gentoo's /bin/login.
++anyterm_command '/usr/bin/ssh %u@localhost'
++
++#USE=ssl#SSLRequireSSL
++#USE=ssl#
++#USE=pam#AuthPAM_Enabled on
++#USE=pam#AuthType Basic
++#USE=pam#AuthName "Anyterm"
++#USE=pam#Require valid-user
++#USE=pam#
+ <Files anyterm-module>
+ SetHandler anyterm
+
+@@ -34,9 +46,12 @@
+ # CustomLog /path/to/logfile combined env=!DONTLOG
+ # See the Apache documentation for details. Note "=!" not "!=" !
+
+- # SetEnv DONTLOG
++#USE=opera# SetEnv DONTLOG
++#USE=-opera# # SetEnv DONTLOG
+ </Files>
+
++#USE=pam#</IfModule>
++#USE=ssl#</IfModule>
+ # Additional Security Issues
+
+ # If you're just testing Anyterm on a machine that's not connected to
diff --git a/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt b/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt
new file mode 100644
index 000000000000..19a11013aa2f
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt
@@ -0,0 +1,59 @@
+DEFAULT GENTOO INSTALLATION
+
+The default Gentoo installation is designed to work and be as secure as
+possible out-of-the box as long as you have USE="ssl pam -opera".
+
+
+USE FLAGS
+
++ssl forces anyterm to only run over secure (HTTPS) connections.
+-ssl disables secure connections, all data will pass over the network in
+ plain text, including passwords!
++pam enables PAM authentication, so anyone with an account on your computer
+ can use anyterm without any further configuration.
+-pam means that you will have to configure your own authentication
+ mechanism.
++opera Enables a workaround for a bug in the Opera browser, but you will have
+ to modify apache's logging behaviour to prevent snooping by local
+ users.
+-opera Disables the Opera bug workaround.
+
+
+INSTALLATION INSTRUCTIONS
+
+1. Add the following flags to APACHE2_OPTS in /etc/init.d/apache2:
+ -D ANYTERM
+ -D SSL -D SSL_DEFAULT_VHOST # if USE=ssl
+ -D AUTH_PAM # if USE=pam
+
+2. If you have USE=vhosts then you need to add the following directives to
+ each virtual host's configuration file:
+ <Directory "${MY_INSTALLDIR}">
+ AllowOverride All
+ </Directory>
+
+3. If you have USE=opera then you should disable logging of some requests. In
+ each apache configuration file add env=!DONTLOG to each CustomLog
+ directive. For example:
+
+ USE="ssl -vhosts": edit /etc/apache2/modules.d/41_mod_ssl.default-vhost.conf:
+
+ CustomLog logs/ssl_request_log \
+ "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b" \
+ env=!DONTLOG
+
+ USE="-ssl -vhosts": edit /etc/apache2/modules.d/00_mod_log_config.conf:
+ CustomLog logs/access_log common env=!DONTLOG
+
+4. Restart apache2:
+ /etc/init.d/apache2 restart
+
+5. Browse to:
+ https://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=ssl
+ http://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=-ssl
+
+
+MORE INFORMATION
+
+http://anyterm.org/
+http://anyterm.org/security.html
diff --git a/www-apache/anyterm/files/digest-anyterm-1.1.15 b/www-apache/anyterm/files/digest-anyterm-1.1.15
new file mode 100644
index 000000000000..d49169fc6d69
--- /dev/null
+++ b/www-apache/anyterm/files/digest-anyterm-1.1.15
@@ -0,0 +1,3 @@
+MD5 12a3620e892cfbff89663a568b826911 anyterm-1.1.15.tbz2 192092
+RMD160 b4ee6524a6fd4002b1e2c111382aeff392b3a554 anyterm-1.1.15.tbz2 192092
+SHA256 f5c3fa8077f510ec0c17c8de107179c77bdf7f1b8328c124cb52846e9ee283e5 anyterm-1.1.15.tbz2 192092