summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-09-12 03:33:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-09-12 03:33:27 +0000
commit6a5d0e2e820f671d6e9ac0792e572bbbf8a05b44 (patch)
tree8fac0458bab97a6c5a03dbfae0064559fe8b0d1c
parentnew masked versions (diff)
downloadgentoo-2-6a5d0e2e820f671d6e9ac0792e572bbbf8a05b44.tar.gz
gentoo-2-6a5d0e2e820f671d6e9ac0792e572bbbf8a05b44.tar.bz2
gentoo-2-6a5d0e2e820f671d6e9ac0792e572bbbf8a05b44.zip
new masked versions
-rw-r--r--kde-base/kdelibs/Manifest4
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1.41
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.2.0_alpha11
-rw-r--r--kde-base/kdelibs/kdelibs-3.1.4.ebuild74
-rw-r--r--kde-base/kdelibs/kdelibs-3.2.0_alpha1.ebuild79
5 files changed, 157 insertions, 2 deletions
diff --git a/kde-base/kdelibs/Manifest b/kde-base/kdelibs/Manifest
index cff452918e84..dfac0d018639 100644
--- a/kde-base/kdelibs/Manifest
+++ b/kde-base/kdelibs/Manifest
@@ -1,12 +1,12 @@
MD5 434626ef575100a44e7f2424082808b5 kdelibs-3.1.2.ebuild 2441
MD5 c6d6b8ad780f8c1bbc8f3402c6f9c2e4 kdelibs-3.1.2-r1.ebuild 2539
-MD5 dce4e3498f89aa5894bf277b840eb944 kdelibs-3.1.4.ebuild 2412
+MD5 a83aebb0de921de3a1a024ce1f788519 kdelibs-3.1.4.ebuild 2409
MD5 8a21daa4525f5d8edef9d9be0d4a3354 kdelibs-3.0.4-r1.ebuild 2303
MD5 c1904a08290952b668274da4df0aad8a kdelibs-3.1.1a.ebuild 2647
MD5 e907b234e307a34e574f3225b3f7d17b kdelibs-3.0.5b-r1.ebuild 1994
MD5 b738a6c4ff97493257f186b1dfb853ee kdelibs-3.0.5b.ebuild 1921
MD5 621f70f91c99b562de58c3c346c5629b kdelibs-3.1.3.ebuild 2428
-MD5 dde75e1c36bcd7560e96f84b9800b68f kdelibs-3.2.0_alpha1.ebuild 2325
+MD5 f7962c661878c9a88c9d6b7a9b359e7b kdelibs-3.2.0_alpha1.ebuild 2245
MD5 ecb842ef67a00a4a3348c92a784cc3b7 kdelibs-2.2.2a-r2.ebuild 2570
MD5 d3644c194ed974e8fdafaa060f287b2f kdelibs-3.1.3-r1.ebuild 2499
MD5 5aa43e439b3ef851f203aecc9a100507 ChangeLog 14848
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1.4 b/kde-base/kdelibs/files/digest-kdelibs-3.1.4
new file mode 100644
index 000000000000..64103ae52421
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1.4
@@ -0,0 +1 @@
+MD5 82c265de78d53c7060a09c5cb1a78942 kdelibs-3.1.4.tar.bz2 10537433
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.2.0_alpha1 b/kde-base/kdelibs/files/digest-kdelibs-3.2.0_alpha1
new file mode 100644
index 000000000000..330ae8d3ae25
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.2.0_alpha1
@@ -0,0 +1 @@
+MD5 84f510cd42ff72d7520df4ff3f6c5a98 kdelibs-3.1.91.tar.bz2 11559018
diff --git a/kde-base/kdelibs/kdelibs-3.1.4.ebuild b/kde-base/kdelibs/kdelibs-3.1.4.ebuild
new file mode 100644
index 000000000000..cf265fd6013c
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.4.ebuild,v 1.1 2003/09/12 03:33:23 caleb Exp $
+inherit kde
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/$PV/src/${P}.tar.bz2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=""
+RDEPEND="doc? ( ~app-doc/kdelibs-apidocs-$PV )"
+newdepend "dev-lang/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ app-text/ghostscript
+ media-libs/libart_lgpl
+ sys-devel/gettext
+ ~kde-base/arts-1.1.4"
+
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+ use alpha && cd ${S} && epatch ${FILESDIR}/${P}-kjs-alphaev6-gcc3-workaround.patch
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ # kdelibs-apidocs is provided by kdelibs-apidocs ebuild, kdelibs ebuild
+ # shouldn't install anything into kdelibs-apidocs (bug #15102)
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+}
+
+#pkg_postinst() {
+# einfo "If you have kde 3.0.x installed, please upgrade to kdeils-3.0.5a-r2 and kdebase-3.0.5a-r1.
+# If they don't have your arch's keywords, edit /etc/env.d/65kdelibs-3.0.*, remove the KDEDIRS=
+# line and env-update."
+#}
diff --git a/kde-base/kdelibs/kdelibs-3.2.0_alpha1.ebuild b/kde-base/kdelibs/kdelibs-3.2.0_alpha1.ebuild
new file mode 100644
index 000000000000..5670f0ca1312
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.2.0_alpha1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.2.0_alpha1.ebuild,v 1.1 2003/09/12 03:33:23 caleb Exp $
+inherit kde
+
+MY_PV=3.1.91
+S=${WORKDIR}/${PN}-${MY_PV}
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.2"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/unstable/${MY_PV}/src/${PN}-${MY_PV}.tar.bz2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+#RDEPEND="doc? ( ~app-doc/kdelibs-apidocs-$PV )"
+DEPEND="dev-lang/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ app-text/ghostscript
+ media-libs/libart_lgpl
+ sys-devel/gettext
+ ~kde-base/arts-1.2.0_alpha1"
+
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+need-autoconf 2.5
+
+set-kdedir ${PV}
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+ use alpha && cd ${S} && epatch ${FILESDIR}/${P}-kjs-alphaev6-gcc3-workaround.patch
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ # kdelibs-apidocs is provided by kdelibs-apidocs ebuild, kdelibs ebuild
+ # shouldn't install anything into kdelibs-apidocs (bug #15102)
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+}
+