summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-10 20:24:37 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-10 20:24:37 +0000
commit6be7029d736a891e09de4bc7a69412fa426ff0cc (patch)
treebb79dd35640738ceffdc950d685a3541b8e6b9ab
parentpull in a few upstream patches, minor update (diff)
downloadgentoo-2-6be7029d736a891e09de4bc7a69412fa426ff0cc.tar.gz
gentoo-2-6be7029d736a891e09de4bc7a69412fa426ff0cc.tar.bz2
gentoo-2-6be7029d736a891e09de4bc7a69412fa426ff0cc.zip
Version bump (bug #487678). Lots of changes, lots of new dependencies, see http://segfault.linuxmint.com/2014/04/cinnamon-2-2/ for the announcement.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
-rw-r--r--gnome-extra/cinnamon/ChangeLog11
-rw-r--r--gnome-extra/cinnamon/cinnamon-2.2.6.ebuild224
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-2.2.6-automagic-gnome-bluetooth.patch44
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-2.2.6-optional-networkmanager.patch89
4 files changed, 367 insertions, 1 deletions
diff --git a/gnome-extra/cinnamon/ChangeLog b/gnome-extra/cinnamon/ChangeLog
index 46d06a0d0d8b..1d51697cfc0a 100644
--- a/gnome-extra/cinnamon/ChangeLog
+++ b/gnome-extra/cinnamon/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/cinnamon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.36 2014/04/26 08:23:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.37 2014/05/10 20:24:37 tetromino Exp $
+
+*cinnamon-2.2.6 (10 May 2014)
+
+ 10 May 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cinnamon-2.2.6.ebuild,
+ +files/cinnamon-2.2.6-automagic-gnome-bluetooth.patch,
+ +files/cinnamon-2.2.6-optional-networkmanager.patch:
+ Version bump (bug #487678). Lots of changes, lots of new dependencies, see
+ http://segfault.linuxmint.com/2014/04/cinnamon-2-2/ for the announcement.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> cinnamon-1.8.8.1-r2.ebuild:
Adapt to latest pygobject don't providing python2.6 support
diff --git a/gnome-extra/cinnamon/cinnamon-2.2.6.ebuild b/gnome-extra/cinnamon/cinnamon-2.2.6.ebuild
new file mode 100644
index 000000000000..5bb88d418a8a
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-2.2.6.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/cinnamon-2.2.6.ebuild,v 1.1 2014/05/10 20:24:37 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit autotools eutils gnome2 multilib pax-utils python-single-r1
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+MY_PV="${PV/_p/-UP}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/linuxmint/Cinnamon/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz
+ http://dev.gentoo.org/~pacho/gnome/cinnamon-1.8/gnome-3.8.patch"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+bluetooth +networkmanager"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ app-misc/ca-certificates
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.29.10:2
+ >=dev-libs/gobject-introspection-0.10.1
+ >=dev-libs/json-glib-0.13.2
+ >=dev-libs/libcroco-0.6.2:0.6
+ dev-libs/libxml2:2
+ gnome-base/gconf:2[introspection]
+ gnome-base/librsvg
+ >=gnome-extra/cinnamon-desktop-1.0:0=[introspection]
+ gnome-extra/cinnamon-menus[introspection]
+ >=gnome-extra/cjs-1.9.0
+ >=media-libs/clutter-1.7.5:1.0[introspection]
+ media-libs/cogl:1.0=[introspection]
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/libcanberra
+ media-sound/pulseaudio:0=[glib]
+ net-libs/libsoup:2.4[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.0.0:3[introspection]
+ x11-libs/pango[introspection]
+ >=x11-libs/startup-notification-0.11
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ >=x11-wm/muffin-1.9.1[introspection]
+ ${PYTHON_DEPS}
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.1:=[introspection] )
+ networkmanager? (
+ gnome-base/libgnome-keyring
+ >=net-misc/networkmanager-0.8.999[introspection] )
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Each block:
+# 2. Introspection stuff + dconf needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
+# user switching with gdm-3.1.x)
+# 6. caribou needed for on-screen keyboard
+# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python, imaging, lxml needed for cinnamon-settings
+# 9. gnome-icon-theme-symbolic needed for various icons
+# 10. pygobject needed for menu editor
+# 11. nemo - default file manager, tightly integrated with cinnamon
+# TODO(lxnay): fix error: libgnome-desktop/gnome-rr-labeler.h: No such file or directory
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ sys-power/upower[introspection]
+
+ gnome-extra/cinnamon-session
+
+ gnome-extra/cinnamon-settings-daemon
+
+ >=sys-apps/accountsservice-0.6.14[introspection]
+
+ >=app-accessibility/caribou-0.3
+
+ x11-misc/xdg-utils
+
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gconf-python:2
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/pypam[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+
+ x11-themes/gnome-icon-theme-symbolic
+
+ gnome-extra/nemo
+ gnome-extra/cinnamon-control-center
+ gnome-extra/cinnamon-screensaver
+
+ bluetooth? ( net-wireless/cinnamon-bluetooth )
+ networkmanager? (
+ gnome-extra/nm-applet
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-python/polib[${PYTHON_USEDEP}]
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ !!=dev-lang/spidermonkey-1.8.2*
+"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+S="${WORKDIR}/Cinnamon-${PV}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix GNOME 3.8 support
+ epatch "${FILESDIR}/background.patch"
+
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ epatch "${FILESDIR}/${PN}-2.2.6-automagic-gnome-bluetooth.patch"
+
+ # Optional NetworkManager, bug #488684
+ epatch "${FILESDIR}/${PN}-2.2.6-optional-networkmanager.patch"
+
+ # Gentoo uses /usr/$(get_libdir), not /usr/lib even for python
+ sed -e "s:/usr/lib/:/usr/$(get_libdir)/:" \
+ -e 's:"/usr/lib":"/usr/'"$(get_libdir)"'":' \
+ -i files/usr/share/polkit-1/actions/org.cinnamon.settings-users.policy \
+ -i files/usr/lib/cinnamon-settings-users/cinnamon-settings-users.py \
+ -i files/usr/lib/cinnamon-screensaver-lock-dialog/cinnamon-screensaver-lock-dialog.py \
+ -i files/usr/lib/cinnamon-settings/cinnamon-settings.py \
+ -i files/usr/lib/cinnamon-settings/modules/cs_backgrounds.py \
+ -i files/usr/lib/cinnamon-settings/data/spices/applet-detail.html \
+ -i files/usr/lib/cinnamon-settings/bin/*.py \
+ -i files/usr/lib/cinnamon-desktop-editor/cinnamon-desktop-editor.py \
+ -i files/usr/lib/cinnamon-menu-editor/cme/*.py \
+ -i files/usr/bin/* || die "sed failed"
+ if [[ "$(get_libdir)" != lib ]]; then
+ mv files/usr/lib "files/usr/$(get_libdir)" || die "mv failed"
+ fi
+
+ if ! use networkmanager; then
+ rm -rv files/usr/share/cinnamon/applets/network@cinnamon.org || die
+ fi
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Don't error out on warnings
+ gnome2_src_configure \
+ --disable-jhbuild-wrapper-script \
+ $(use_with bluetooth) \
+ $(use_enable networkmanager) \
+ --with-ca-certificates="${EPREFIX}/etc/ssl/certs/ca-certificates.crt" \
+ BROWSER_PLUGIN_DIR="${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED}usr/$(get_libdir)/cinnamon-"{desktop-editor,json-makepot,launcher,looking-glass,menu-editor,screensaver-lock-dialog,settings,settings-users}
+ # Fix broken shebangs
+ sed -e "s%#!.*python%#!${PYTHON}%" \
+ -i "${ED}usr/bin/cinnamon-"{desktop-editor,json-makepot,launcher,looking-glass,menu-editor,screensaver-lock-dialog,settings,settings-users} \
+ -i "${ED}usr/$(get_libdir)/cinnamon-settings/cinnamon-settings.py" || die
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}usr/bin/cinnamon"
+
+ # Doesn't exist on Gentoo, causing this to be a dead symlink
+ rm -f "${ED}etc/xdg/menus/cinnamon-applications-merged" || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "org.cinnamon.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "Cinnamon has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to"
+ ewarn "open-source drivers."
+ fi
+
+ if has_version "media-libs/mesa[video_cards_radeon]" ||
+ has_version "media-libs/mesa[video_cards_r300]" ||
+ has_version "media-libs/mesa[video_cards_r600]"; then
+ elog "Cinnamon is unstable under classic-mode r300/r600 mesa drivers."
+ elog "Make sure that gallium architecture for r300 and r600 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[gallium]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=gallium."
+ fi
+ fi
+}
diff --git a/gnome-extra/cinnamon/files/cinnamon-2.2.6-automagic-gnome-bluetooth.patch b/gnome-extra/cinnamon/files/cinnamon-2.2.6-automagic-gnome-bluetooth.patch
new file mode 100644
index 000000000000..aa2e82bd13fa
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-2.2.6-automagic-gnome-bluetooth.patch
@@ -0,0 +1,44 @@
+From 40750fc87b7a1cad60d0e605732b9df50dd16c11 Mon Sep 17 00:00:00 2001
+From: root <admin@catmur.co.uk>
+Date: Sun, 8 Jan 2012 13:55:05 +0000
+Subject: [PATCH] Fix automagic gnome-bluetooth dependency
+
+https://bugs.gentoo.org/show_bug.cgi?id=398145
+
+Ed Catmur 2012-01-08 13:46:22 UTC
+libgnome-bluetooth-applet is a private library so they shouldn't be linking
+against it anyway. I tried to work out how to tell libtool to add it to rpath
+but got totally lost.
+
+I'll see if I can work out how to fix the automagic gnome-bluetooth dependency
+so I can at least merge USE=-bluetooth.
+---
+ configure.ac | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index c0e43e1..bc764e1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -111,6 +111,8 @@ PKG_CHECK_MODULES(GVC, libpulse libpulse-mainloop-glib gobject-2.0)
+ PKG_CHECK_MODULES(DESKTOP_SCHEMAS, cinnamon-desktop >= 1.0.0)
+
+ AC_MSG_CHECKING([for bluetooth support])
++AC_ARG_WITH([bluetooth], AS_HELP_STRING([--without-bluetooth], [Build without gnome-bluetooth library (default: auto)]))
++AS_IF([test "x$with_bluetooth" != "xno"], [
+ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [BLUETOOTH_DIR=`$PKG_CONFIG --variable=applet_libdir gnome-bluetooth-1.0`
+ BLUETOOTH_LIBS=`$PKG_CONFIG --variable=applet_libs gnome-bluetooth-1.0`
+@@ -123,6 +125,9 @@ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [AC_DEFINE([HAVE_BLUETOOTH],[0])
+ AC_SUBST([HAVE_BLUETOOTH],[0])
+ AC_MSG_RESULT([no])])
++], [AC_DEFINE([HAVE_BLUETOOTH],[0])
++ AC_SUBST([HAVE_BLUETOOTH],[0])
++ AC_MSG_RESULT([no])])
+
+ MUFFIN_GIR_DIR=`$PKG_CONFIG --variable=girdir libmuffin`
+ MUFFIN_TYPELIB_DIR=`$PKG_CONFIG --variable=typelibdir libmuffin`
+--
+1.9.2
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-2.2.6-optional-networkmanager.patch b/gnome-extra/cinnamon/files/cinnamon-2.2.6-optional-networkmanager.patch
new file mode 100644
index 000000000000..aeed8deac007
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-2.2.6-optional-networkmanager.patch
@@ -0,0 +1,89 @@
+From 26fbdd602e60baded13e203fdc5c90c063a089e4 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 10 May 2014 15:14:05 -0400
+Subject: [PATCH] Make networkmanager dependency optional for Gentoo
+
+---
+ configure.ac | 36 ++++++++++++++++++++++++++++++++++--
+ js/misc/config.js.in | 2 ++
+ src/Makefile.am | 5 ++++-
+ 3 files changed, 40 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bc764e1..894379b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,8 +81,40 @@ PKG_CHECK_MODULES(CINNAMON, gio-2.0 >= $GIO_MIN_VERSION
+ libstartup-notification-1.0 >= $STARTUP_NOTIFICATION_MIN_VERSION
+ gobject-introspection-1.0 >= $GOBJECT_INTROSPECTION_MIN_VERSION
+ libcanberra
+- polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
+- libnm-glib libnm-util gnome-keyring-1)
++ polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes)
++
++##########################
++# Check for NetworkManager
++##########################
++NM_MIN_VERSION=0.9
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib libnm-util gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ CINNAMON_CFLAGS="$CINNAMON_CFLAGS $NETWORKMANAGER_CFLAGS"
++ CINNAMON_LIBS="$CINNAMON_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
+
+ PKG_CHECK_MODULES(CINNAMON_PERF_HELPER, gtk+-3.0 gio-2.0)
+
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 704989b..df7e014 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -8,5 +8,7 @@ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ const GJS_VERSION = '@GJS_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* The system TLS CA list */
+ const CINNAMON_SYSTEM_CA_FILE = '@CINNAMON_SYSTEM_CA_FILE@';
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 06d7f93..fe12cb9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -267,7 +267,10 @@ libcinnamon_la_LIBADD = \
+ libcinnamon_la_CPPFLAGS = $(cinnamon_cflags)
+
+ Cinnamon-0.1.gir: libcinnamon.la St-1.0.gir
+-Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-Muffin.0 Soup-2.4 CMenu-3.0 NetworkManager-1.0 NMClient-1.0
++Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-Muffin.0 Soup-2.4 CMenu-3.0
++if HAVE_NETWORKMANAGER
++Cinnamon_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Cinnamon_0_1_gir_CFLAGS = $(libcinnamon_la_CPPFLAGS) -I $(srcdir)
+ Cinnamon_0_1_gir_LIBS = libcinnamon.la
+ Cinnamon_0_1_gir_FILES = $(libcinnamon_la_gir_sources)
+--
+1.9.2
+