summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-01 13:38:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-01 13:38:46 +0000
commit727ee6249e342fc4b33459fe67745c557445d280 (patch)
tree85e731b2cc80a0c80bf7a948d86956340066becb
parentMarked ~hppa (bug #282263). (diff)
downloadgentoo-2-727ee6249e342fc4b33459fe67745c557445d280.tar.gz
gentoo-2-727ee6249e342fc4b33459fe67745c557445d280.tar.bz2
gentoo-2-727ee6249e342fc4b33459fe67745c557445d280.zip
Bump to 1.6.5. Fixes #238151. Patches by Calogero Lo Leggio.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
-rw-r--r--net-analyzer/zabbix/ChangeLog14
-rw-r--r--net-analyzer/zabbix/metadata.xml2
-rw-r--r--net-analyzer/zabbix/zabbix-1.6.5.ebuild281
3 files changed, 295 insertions, 2 deletions
diff --git a/net-analyzer/zabbix/ChangeLog b/net-analyzer/zabbix/ChangeLog
index 8fbe316727b3..898ea7ca4691 100644
--- a/net-analyzer/zabbix/ChangeLog
+++ b/net-analyzer/zabbix/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-analyzer/zabbix
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.10 2008/08/04 20:23:44 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.11 2009/09/01 13:38:46 patrick Exp $
+
+*zabbix-1.6.5 (01 Sep 2009)
+
+ 01 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/1.6.5/init.d/zabbix-agentd, +files/1.6.5/init.d/zabbix-server,
+ +files/1.6.5/postinstall-en.txt, +files/1.6.5/zabbix_agent.conf,
+ +files/1.6.5/zabbix_agentd.conf, +files/1.6.5/zabbix_proxy.conf,
+ +files/1.6.5/zabbix_server.conf, +files/1.6.5/zabbix_trapper.conf,
+ +zabbix-1.6.5.ebuild, metadata.xml:
+ Bump to 1.6.5. Fixes #238151. Patches by Calogero Lo Leggio.
04 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Describe local USE flags for GLEP 56.
diff --git a/net-analyzer/zabbix/metadata.xml b/net-analyzer/zabbix/metadata.xml
index 4727ffab9031..0646ec0255d4 100644
--- a/net-analyzer/zabbix/metadata.xml
+++ b/net-analyzer/zabbix/metadata.xml
@@ -16,6 +16,8 @@ configure different types of notifications for pre-defined events.
<use>
<flag name='agent'>Enable zabbix agent (for to-be-monitored machines)</flag>
<flag name='frontend'>Enable zabbix web frontend</flag>
+ <flag name='proxy'>Enable proxy support</flag>
+ <flag name='openipmi'>Enable openipmi things</flag>
<flag name='server'>Enable zabbix server</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/zabbix/zabbix-1.6.5.ebuild b/net-analyzer/zabbix/zabbix-1.6.5.ebuild
new file mode 100644
index 000000000000..7e7b3e79d336
--- /dev/null
+++ b/net-analyzer/zabbix/zabbix-1.6.5.ebuild
@@ -0,0 +1,281 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.6.5.ebuild,v 1.1 2009/09/01 13:38:46 patrick Exp $
+
+inherit eutils flag-o-matic webapp depend.php
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="agent curl frontend jabber ldap mysql oracle postgres proxy server snmp sqlite3 openipmi"
+DEPEND="virtual/libc
+ snmp? ( net-analyzer/net-snmp )
+ ldap? (
+ net-nds/openldap
+ =dev-libs/cyrus-sasl-2*
+ net-libs/gnutls
+ )
+ mysql? ( virtual/mysql )
+ sqlite3? ( =dev-db/sqlite-3* )
+ postgres? ( virtual/postgresql-base )
+ jabber? ( dev-libs/iksemel )
+ curl? ( net-misc/curl )
+ openipmi? ( sys-libs/openipmi )"
+RDEPEND="${RDEPEND}
+ proxy? ( net-analyzer/fping )
+ server? ( net-analyzer/fping )"
+
+useq frontend && need_php_httpd
+
+pkg_setup() {
+ if useq server || useq proxy ; then
+ local dbnum dbtypes="mysql oracle postgres sqlite3" dbtype
+ declare -i dbnum=0
+ for dbtype in ${dbtypes}; do
+ useq ${dbtype} && let dbnum++
+ done
+ if [ ${dbnum} -gt 1 ]; then
+ eerror
+ eerror "You can't use more than one database type in Zabbix."
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "Multiple database types selected."
+ elif [ ${dbnum} -lt 1 ]; then
+ eerror
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "No database type selected."
+ fi
+ if useq oracle; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror "The environment variable ORACLE_HOME must be set"
+ eerror "and point to the correct location."
+ eerror "It looks like you don't have Oracle installed."
+ eerror
+ die "Environment variable ORACLE_HOME is not set"
+ fi
+ if has_version 'dev-db/oracle-instantclient-basic'; then
+ ewarn
+ ewarn "Please ensure you have a full install of the Oracle client."
+ ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+ ewarn
+ fi
+ fi
+ fi
+
+ if useq frontend; then
+ webapp_pkg_setup
+ require_gd
+ fi
+
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+pkg_postinst() {
+ if useq server || useq proxy ; then
+ elog
+ elog "You need to configure your database for Zabbix."
+ elog
+ elog "Have a look at /usr/share/zabbix/database for"
+ elog "database creation and upgrades."
+ elog
+ elog "For more info read the Zabbix manual at"
+ elog "http://www.zabbix.com/documentation.php"
+ elog
+
+ zabbix_homedir="$(egetent passwd zabbix | cut -d : -f 6 )"
+ if [ -n "${zabbix_homedir}" ] && \
+ [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+ ewarn
+ ewarn "The user 'zabbix' should have his homedir changed"
+ ewarn "to /var/lib/zabbix/home if you want to use"
+ ewarn "custom alert scripts."
+ ewarn
+ ewarn "A real homedir might be needed for configfiles"
+ ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+ ewarn "using sendxmpp for Jabber alerts)."
+ ewarn
+ ewarn "To change the homedir use:"
+ ewarn " usermod -d /var/lib/zabbix/home zabbix"
+ ewarn
+ fi
+ fi
+
+ if useq server; then
+ elog
+ elog "For distributed monitoring you have to run:"
+ elog
+ elog "zabbix_server -n <nodeid>"
+ elog
+ elog "This will convert database data for use with Node ID"
+ elog "and also adds a local node."
+ elog
+ fi
+
+ elog "--"
+ elog
+ elog "Add these lines in the /etc/services :"
+ elog
+ elog "zabbix-agent 10050/tcp Zabbix Agent"
+ elog "zabbix-agent 10050/udp Zabbix Agent"
+ elog "zabbix-trapper 10051/tcp Zabbix Trapper"
+ elog "zabbix-trapper 10051/udp Zabbix Trapper"
+ elog
+
+ # repeat fowners/fperms functionality from src_install()
+ # here to catch wrong permissions on existing files in
+ # the live filesystem (yeah, that sucks).
+ chown -R zabbix:zabbix \
+ "${ROOT}"/etc/zabbix \
+ "${ROOT}"/var/lib/zabbix \
+ "${ROOT}"/var/lib/zabbix/home \
+ "${ROOT}"/var/lib/zabbix/scripts \
+ "${ROOT}"/var/log/zabbix \
+ "${ROOT}"/var/run/zabbix
+ chmod 0750 \
+ "${ROOT}"/etc/zabbix \
+ "${ROOT}"/var/lib/zabbix \
+ "${ROOT}"/var/lib/zabbix/home \
+ "${ROOT}"/var/lib/zabbix/scripts \
+ "${ROOT}"/var/log/zabbix \
+ "${ROOT}"/var/run/zabbix
+
+ chmod 0640 \
+ "${ROOT}"/etc/zabbix/zabbix_*
+
+ if useq server || useq proxy ; then
+ # check for fping
+ fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+ case "${fping_perms}" in
+ 4[157][157][157])
+ ;;
+ *)
+ ewarn
+ ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+ ewarn "you have to make /usr/sbin/fping setuid root and executable"
+ ewarn "by everyone. Run the following command to fix it:"
+ ewarn
+ ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+ ewarn
+ ewarn "Please be aware that this might impose a security risk,"
+ ewarn "depending on the code quality of fping."
+ ewarn
+ ebeep 3
+ epause 5
+ ;;
+ esac
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable server) \
+ $(use_enable proxy) \
+ $(use_enable agent) \
+ $(use_with ldap) \
+ $(use_with snmp net-snmp) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with oracle) \
+ $(use_with sqlite3) \
+ $(use_with jabber) \
+ $(use_with curl libcurl) \
+ $(use_with openipmi openipmi) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ keepdir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ if useq server; then
+ insinto /etc/zabbix
+ doins \
+ "${FILESDIR}/${PV}"/zabbix_server.conf \
+ "${FILESDIR}/${PV}"/zabbix_trapper.conf
+ doinitd \
+ "${FILESDIR}/${PV}"/init.d/zabbix-server
+ dosbin \
+ src/zabbix_server/zabbix_server
+ dodir \
+ /usr/share/zabbix/database
+ insinto /usr/share/zabbix/database
+ doins -r \
+ upgrades \
+ create
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_server.conf \
+ /etc/zabbix/zabbix_trapper.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_server.conf \
+ /etc/zabbix/zabbix_trapper.conf
+ fi
+
+ if useq agent; then
+ insinto /etc/zabbix
+ doins \
+ "${FILESDIR}/${PV}"/zabbix_agent.conf \
+ "${FILESDIR}/${PV}"/zabbix_agentd.conf
+ doinitd \
+ "${FILESDIR}/${PV}"/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_get/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fi
+
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ dodoc README INSTALL NEWS ChangeLog
+
+ if useq frontend; then
+ webapp_src_preinst
+ cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en "${FILESDIR}/${PV}"/postinstall-en.txt
+ webapp_configfile \
+ "${MY_HTDOCSDIR}"/include/db.inc.php \
+ "${MY_HTDOCSDIR}"/include/config.inc.php
+ webapp_src_install
+ fi
+}