summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-29 15:10:12 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-29 15:10:12 +0000
commit7600c0587a37c494054a0aa8f8cdedc873740c7e (patch)
treeb38e91ea1ddf96d141fbcb8a9701a2599794e030
parentAnother one.. (diff)
downloadgentoo-2-7600c0587a37c494054a0aa8f8cdedc873740c7e.tar.gz
gentoo-2-7600c0587a37c494054a0aa8f8cdedc873740c7e.tar.bz2
gentoo-2-7600c0587a37c494054a0aa8f8cdedc873740c7e.zip
Version bump to 2.6.3. Reworked USE flags to be more specific to each avidemux package, the way its meant to be; introduced additional support for some libraries through USE flags as a conseuence.
(Portage version: 2.1.11.59/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
-rw-r--r--media-libs/avidemux-core/ChangeLog10
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.3.ebuild98
-rw-r--r--media-libs/avidemux-core/metadata.xml4
3 files changed, 109 insertions, 3 deletions
diff --git a/media-libs/avidemux-core/ChangeLog b/media-libs/avidemux-core/ChangeLog
index 78244ef1c063..8087b86c4cae 100644
--- a/media-libs/avidemux-core/ChangeLog
+++ b/media-libs/avidemux-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/avidemux-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.2 2013/03/16 22:00:45 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.3 2013/03/29 15:10:12 tomwij Exp $
+
+*avidemux-core-2.6.3 (29 Mar 2013)
+
+ 29 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +avidemux-core-2.6.3.ebuild,
+ metadata.xml:
+ Version bump to 2.6.3. Reworked USE flags to be more specific to each avidemux
+ package, the way its meant to be; introduced additional support for some
+ libraries through USE flags as a conseuence.
16 Mar 2013; Tom Wijsman <TomWij@gentoo.org> avidemux-core-2.6.2.ebuild:
Made avidemux-core block old versions of avidemux that had the core libraries,
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.3.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.3.ebuild
new file mode 100644
index 000000000000..e24f20cb6de3
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-2.6.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-2.6.3.ebuild,v 1.1 2013/03/29 15:10:12 tomwij Exp $
+
+EAPI="5"
+
+PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
+inherit cmake-utils eutils flag-o-matic l10n toolchain-funcs
+
+SLOT="2.6"
+MY_PN="${PN/-core/}"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks."
+HOMEPAGE="http://fixounet.free.fr/${MY_PN}"
+SRC_URI="mirror://sourceforge/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls sdl system-ffmpeg vdpau xv"
+
+DEPEND="
+ !<media-video/avidemux-${PV}
+ dev-db/sqlite
+ nls? ( sys-devel/gettext )
+ sdl? ( media-libs/libsdl )
+ system-ffmpeg? ( >=media-video/ffmpeg-1.0[aac,cpudetection,mp3,theora] )
+ xv? ( x11-libs/libXv )
+ vdpau? ( x11-libs/libvdpau )
+"
+RDEPEND="
+ $DEPEND
+"
+DEPEND="
+ $DEPEND
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
+ rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "Failed to remove ffmpeg."
+
+ sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "Failed to remove ffmpeg."
+ sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "Failed to remove ffmpeg."
+ sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "Failed to remove ffmpeg."
+ else
+ # Avoid existing avidemux installations from making the build process fail, bug #461496.
+ sed -i -e "s:getFfmpegLibNames(\"\${sourceDir}\"):getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):g" cmake/admFFmpegUtil.cmake || die "Failed to avoid existing avidemux installation from making the build fail."
+ fi
+
+}
+
+src_configure() {
+ local x mycmakeargs
+
+ mycmakeargs="
+ $(cmake-utils_use nls GETTEXT)
+ $(cmake-utils_use sdl SDL)
+ $(cmake-utils_use vdpau VDPAU)
+ $(cmake-utils_use xv XVIDEO)
+ "
+ use debug && POSTFIX="_debug" && mycmakeargs+="-DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug"
+
+ mkdir "${S}"/buildCore || die "Can't create build folder."
+ cd "${S}"/buildCore || die "Can't enter build folder."
+
+ cmake -DAVIDEMUX_SOURCE_DIR="${S}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ ${mycmakeargs} -G "Unix Makefiles" ../"avidemux_core${POSTFIX}/" || die "cmake failed."
+}
+
+src_compile() {
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+
+ # TODO: Report -j1 problem upstream, seems to be within ffmpeg code.
+ cd "${S}"/buildCore || die "Can't enter build folder."
+ emake -j1 CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ # TODO: Report -j1 problem upstream, seems to be within ffmpeg code.
+ cd "${S}"/buildCore || die "Can't enter build folder."
+ emake DESTDIR="${ED}" -j1 install
+
+ dodoc "${S}"/{AUTHORS,README}
+}
diff --git a/media-libs/avidemux-core/metadata.xml b/media-libs/avidemux-core/metadata.xml
index 6f2bfe61299a..4b80e439b8c6 100644
--- a/media-libs/avidemux-core/metadata.xml
+++ b/media-libs/avidemux-core/metadata.xml
@@ -7,8 +7,8 @@
</maintainer>
<herd>video</herd>
<use>
- <flag name="aften">Enable A/52 (AC-3) audio encoder support</flag>
- <flag name="amr">Enable Adaptive Multi-Rate format support via <pkg>media-libs/opencore-amr</pkg></flag>
+ <flag name="aften">Enable A/52 (AC-3) audio encoder support.</flag>
+ <flag name="amr">Enable Adaptive Multi-Rate format support via <pkg>media-libs/opencore-amr</pkg>.</flag>
<flag name="system-ffmpeg">Use the ffmpeg provided by the system.</flag>
</use>
</pkgmetadata>