summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 16:57:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 16:57:58 +0000
commit76093dfab25bdf023e0d3f3002ee70a7f1c8f3a5 (patch)
tree2448107ea5b1b6dd3439f0e9967d7d71a5e9e8f4
parentwhitespace (diff)
downloadgentoo-2-76093dfab25bdf023e0d3f3002ee70a7f1c8f3a5.tar.gz
gentoo-2-76093dfab25bdf023e0d3f3002ee70a7f1c8f3a5.tar.bz2
gentoo-2-76093dfab25bdf023e0d3f3002ee70a7f1c8f3a5.zip
Patch to fix building with gcc-4.3 from Martin Väth, bug #218939
(Portage version: 2.1.5_rc6)
-rw-r--r--games-arcade/burgerspace/ChangeLog6
-rw-r--r--games-arcade/burgerspace/burgerspace-1.8.2.ebuild8
-rw-r--r--games-arcade/burgerspace/files/burgerspace-1.8.2-gcc43.patch22
3 files changed, 32 insertions, 4 deletions
diff --git a/games-arcade/burgerspace/ChangeLog b/games-arcade/burgerspace/ChangeLog
index efd864c9dad2..73de645aab79 100644
--- a/games-arcade/burgerspace/ChangeLog
+++ b/games-arcade/burgerspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/burgerspace
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/ChangeLog,v 1.10 2008/04/08 01:47:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/ChangeLog,v 1.11 2008/04/30 16:57:57 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/burgerspace-1.8.2-gcc43.patch, burgerspace-1.8.2.ebuild:
+ Patch to fix building with gcc-4.3 from Martin Väth, bug #218939
08 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org>
burgerspace-1.8.2.ebuild:
diff --git a/games-arcade/burgerspace/burgerspace-1.8.2.ebuild b/games-arcade/burgerspace/burgerspace-1.8.2.ebuild
index 2a0fefaabefe..7df7d9221dc2 100644
--- a/games-arcade/burgerspace/burgerspace-1.8.2.ebuild
+++ b/games-arcade/burgerspace/burgerspace-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.2.ebuild,v 1.2 2008/04/08 01:47:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.2.ebuild,v 1.3 2008/04/30 16:57:57 nyhm Exp $
inherit autotools eutils games
@@ -23,12 +23,14 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
AT_M4DIR=macros eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS HACKING NEWS README THANKS TODO
+ dodoc AUTHORS NEWS README THANKS
prepgamesdirs
}
diff --git a/games-arcade/burgerspace/files/burgerspace-1.8.2-gcc43.patch b/games-arcade/burgerspace/files/burgerspace-1.8.2-gcc43.patch
new file mode 100644
index 000000000000..f229490302b8
--- /dev/null
+++ b/games-arcade/burgerspace/files/burgerspace-1.8.2-gcc43.patch
@@ -0,0 +1,22 @@
+--- src/BurgerSpaceEngine.cpp
++++ src/BurgerSpaceEngine.cpp
+@@ -26,16 +26,17 @@
+
+ #include <flatzebra/PixmapLoadError.h>
+
+-#include <assert.h>
++#include <cassert>
+ #include <fstream>
+ #include <iomanip>
++#include <algorithm>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <time.h>
+-#include <errno.h>
++#include <cerrno>
+
+
+ /* Tiles: