summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-07-02 11:52:20 +0000
committerMikle Kolyada <zlogene@gentoo.org>2015-07-02 11:52:20 +0000
commit7718eae735659c41c1d5ad78af6d00b48181a55f (patch)
treeb9c5c517638c47734c0109eef95be7e507e363f1
parentVersion bump (diff)
downloadgentoo-2-7718eae735659c41c1d5ad78af6d00b48181a55f.tar.gz
gentoo-2-7718eae735659c41c1d5ad78af6d00b48181a55f.tar.bz2
gentoo-2-7718eae735659c41c1d5ad78af6d00b48181a55f.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
-rw-r--r--dev-perl/Net-Patricia/ChangeLog7
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-perl/Net-Patricia/ChangeLog b/dev-perl/Net-Patricia/ChangeLog
index 9007d2a51776..02c13b075e93 100644
--- a/dev-perl/Net-Patricia/ChangeLog
+++ b/dev-perl/Net-Patricia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Net-Patricia
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.52 2015/05/13 07:01:11 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.53 2015/07/02 11:52:20 zlogene Exp $
+
+*Net-Patricia-1.220.0 (02 Jul 2015)
+
+ 02 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> +Net-Patricia-1.220.0.ebuild:
+ Version bump
13 May 2015; Jack Morgan <jmorgan@gentoo.org> Net-Patricia-1.210.0-r1.ebuild:
ppc64 stable wrt bug #537464
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
new file mode 100644
index 000000000000..e0a222963a97
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild,v 1.1 2015/07/02 11:52:20 zlogene Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"