summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 20:09:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 20:09:47 +0000
commit771a5733217ba9bbec93c3beaa891597fa0c8883 (patch)
treec729b4fd88930df41a3c5810a14efd7528308cfd
parentversion bump as per bug #259018 thanks to Arfrever (diff)
downloadgentoo-2-771a5733217ba9bbec93c3beaa891597fa0c8883.tar.gz
gentoo-2-771a5733217ba9bbec93c3beaa891597fa0c8883.tar.bz2
gentoo-2-771a5733217ba9bbec93c3beaa891597fa0c8883.zip
Fix for gcc 4.3.3 / fortify_sources. Patch by Romain Perier.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--sys-fs/avfs/ChangeLog11
-rw-r--r--sys-fs/avfs/avfs-0.9.8-r1.ebuild58
-rw-r--r--sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch11
3 files changed, 78 insertions, 2 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index 4e3f04b4a5a2..41a05a3e1c29 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/avfs
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.17 2008/07/05 09:36:48 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.18 2009/03/01 20:09:46 patrick Exp $
+
+*avfs-0.9.8-r1 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch,
+ +avfs-0.9.8-r1.ebuild:
+ Fix for gcc 4.3.3 / fortify_sources. Patch by Romain Perier.
05 Jul 2008; Tobias Scherbaum <dertobi123@gentoo.org> avfs-0.9.8.ebuild:
ppc stable, bug #230531
diff --git a/sys-fs/avfs/avfs-0.9.8-r1.ebuild b/sys-fs/avfs/avfs-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..fd5539c9a607
--- /dev/null
+++ b/sys-fs/avfs/avfs-0.9.8-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.8-r1.ebuild,v 1.1 2009/03/01 20:09:46 patrick Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files."
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-fs/fuse-2.4"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+
+pkg_setup() {
+ kernel_is lt 2 6 && die "Must have a version 2.6 kernel. Cannot continue. :("
+}
+
+src_compile() {
+ # Fixs bug #258295
+ epatch "${FILESDIR}/${P}-gcc43_fix_open_missing_mode.patch"
+ econf --enable-fuse --enable-library || die "Sorry, can't configure :("
+ emake || die "Sorry make failed :("
+}
+
+src_install() {
+ einstall || die "Sorry, make install failed :("
+ # remove cruft
+ dobin scripts/avfs-config
+ cd "${D}"/usr
+ rm -f bin/davpass bin/ftppass
+ rm -fr sbin ../etc
+ cd "${S}"
+ cd doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ cd ..
+ dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ docinto scripts
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ echo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch b/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch
new file mode 100644
index 000000000000..fff205250af2
--- /dev/null
+++ b/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch
@@ -0,0 +1,11 @@
+--- ../avfs-0.9.8_orig/modules/urar.c 2007-05-14 20:21:23.000000000 +0200
++++ modules/urar.c 2009-02-09 13:48:56.780225932 +0100
+@@ -587,7 +587,7 @@
+ if(res < 0)
+ return res;
+
+- fd = open(tmpfile, O_RDWR | O_CREAT | O_TRUNC);
++ fd = open(tmpfile, O_RDWR | O_CREAT | O_TRUNC, 0644);
+ if(fd == -1) {
+ res = -errno;
+ av_log(AVLOG_ERROR, "RAR: Could not open %s: %s", tmpfile,