summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 11:21:56 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 11:21:56 +0000
commit77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9 (patch)
tree15a3b3743bc1a97ca2d70f3357d2126c9ccc73b8
parentnew version (diff)
downloadgentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.tar.gz
gentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.tar.bz2
gentoo-2-77b73e8dbbe778f0ba110c1c17cec31c9d0b62f9.zip
A=-fix
-rw-r--r--dev-db/edb/edb-1.0.2-r1.ebuild27
-rw-r--r--dev-db/mysql/mysql-3.23.38.ebuild7
-rw-r--r--dev-db/mysql/mysql-3.23.39.ebuild7
-rw-r--r--dev-db/mysql/mysql-3.23.41.ebuild132
-rw-r--r--dev-db/postgresql/postgresql-7.0.3-r2.ebuild6
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild53
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild48
7 files changed, 136 insertions, 144 deletions
diff --git a/dev-db/edb/edb-1.0.2-r1.ebuild b/dev-db/edb/edb-1.0.2-r1.ebuild
index ad6f06222f8d..b00f748ea0ce 100644
--- a/dev-db/edb/edb-1.0.2-r1.ebuild
+++ b/dev-db/edb/edb-1.0.2-r1.ebuild
@@ -1,29 +1,30 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/edb/edb-1.0.2-r1.ebuild,v 1.1 2001/10/06 12:36:36 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/edb/edb-1.0.2-r1.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Enlightment Data Base"
-SRC_URI="http://prdownloads.sourceforge.net/enlightenment/${A}"
+SRC_URI="http://prdownloads.sourceforge.net/enlightenment/${P}.tar.gz"
HOMEPAGE="http://enlightenment.org"
RDEPEND="virtual/glibc
>=x11-libs/gtk+-1.2.10-r4"
-DEPEND="$RDEPEND sys-apps/which"
-src_compile() {
-
- try ./configure --prefix=/usr --enable-compat185 --enable-dump185 \
- --enable-cxx --host=${CHOST}
- try make
+DEPEND="$RDEPEND
+ sys-apps/which"
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --enable-compat185 \
+ --enable-dump185 \
+ --enable-cxx
+ assert
+
+ emake || die
}
src_install () {
-
- try make DESTDIR=${D} install
-
+ make DESTDIR=${D} install || die
}
-
diff --git a/dev-db/mysql/mysql-3.23.38.ebuild b/dev-db/mysql/mysql-3.23.38.ebuild
index 8d8462e54719..31c42cb73c6b 100644
--- a/dev-db/mysql/mysql-3.23.38.ebuild
+++ b/dev-db/mysql/mysql-3.23.38.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.38.ebuild,v 1.3 2001/06/09 19:46:14 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.38.ebuild,v 1.4 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="The MySQL Database"
-SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${A}
- http://www.mysql.com/Downloads/MySQL-3.23/${A}"
+SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${P}.tar.gz
+ http://www.mysql.com/Downloads/MySQL-3.23/${P}.tar.gz"
HOMEPAGE="http://www.mysql.com/"
diff --git a/dev-db/mysql/mysql-3.23.39.ebuild b/dev-db/mysql/mysql-3.23.39.ebuild
index 1c14c4fcdbdf..bb3e4e174619 100644
--- a/dev-db/mysql/mysql-3.23.39.ebuild
+++ b/dev-db/mysql/mysql-3.23.39.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.39.ebuild,v 1.1 2001/06/20 15:33:27 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.39.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="The MySQL Database"
-SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${A}
- http://www.mysql.com/Downloads/MySQL-3.23/${A}"
+SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${P}.tar.gz
+ http://www.mysql.com/Downloads/MySQL-3.23/${P}.tar.gz"
HOMEPAGE="http://www.mysql.com/"
diff --git a/dev-db/mysql/mysql-3.23.41.ebuild b/dev-db/mysql/mysql-3.23.41.ebuild
index a9c9404d0723..cde1daf350f2 100644
--- a/dev-db/mysql/mysql-3.23.41.ebuild
+++ b/dev-db/mysql/mysql-3.23.41.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Parag Mehta <pm@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.41.ebuild,v 1.3 2001/10/29 08:14:55 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.41.ebuild,v 1.4 2001/11/10 11:21:56 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,21 +11,18 @@ SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${A}
HOMEPAGE="http://www.mysql.com/"
-DEPEND="virtual/glibc
- sys-devel/automake
- sys-devel/libtool
- sys-devel/autoconf
- sys-apps/procps
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- readline? ( >=sys-libs/readline-4.1 )
- >=sys-libs/ncurses-5.1
- >=sys-libs/zlib-1.1.3"
-
RDEPEND="virtual/glibc
readline? ( >=sys-libs/readline-4.1 )
>=sys-libs/ncurses-5.1
>=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-apps/procps
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -40,65 +37,64 @@ src_unpack() {
}
src_compile() {
-
- local myconf
-
- # MySQL doesn't like optimizations
- export CFLAGS="${CFLAGS/-O?/}"
- export CXXFLAGS="${CXXFLAGS/-O?/}"
-
- if [ "`use tcpd`" ]
- then
- myconf="--with-libwrap"
- fi
-
- if [ "`use readline`" ]
- then
- # Means use system readline
- myconf="$myconf --without-readline"
- fi
-
- if [ "$DEBUG" == "true" ]
- then
- myconf="$myconf --with-debug"
- else
- myconf="$myconf --without-debug"
- fi
+ local myconf
+
+ # MySQL doesn't like optimizations
+ export CFLAGS="${CFLAGS/-O?/}"
+ export CXXFLAGS="${CXXFLAGS/-O?/}"
+
+ if [ "`use tcpd`" ]
+ then
+ myconf="--with-libwrap"
+ fi
+
+ if [ "`use readline`" ]
+ then
+ # Means use system readline
+ myconf="$myconf --without-readline"
+ fi
+
+ if [ "$DEBUG" == "true" ]
+ then
+ myconf="$myconf --with-debug"
+ else
+ myconf="$myconf --without-debug"
+ fi
- try CXX=gcc ./configure --prefix=/usr \
- --enable-shared \
- --enable-static \
- --enable-assembler \
- --enable-thread-safe-client \
- --with-low-memory \
- --libdir=/usr/lib \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/mysql \
- --localstatedir=/var/mysql \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-mysql-user=mysql \
- --with-berkeley-db=${S}/bdb \
- --with-innodb \
- $myconf
-
- try make testdir=/usr/share/mysql/test benchdir=/usr/share/mysql/bench
+ CXX=gcc ./configure --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ --enable-assembler \
+ --enable-thread-safe-client \
+ --with-low-memory \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/mysql \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-mysql-user=mysql \
+ --with-berkeley-db=${S}/bdb \
+ --with-innodb \
+ $myconf || die
+
+ make testdir=/usr/share/mysql/test benchdir=/usr/share/mysql/bench
+ assert
}
src_install() {
-
-
# Install MySQL
- try make install prefix=${D}/usr \
- libdir=${D}/usr/lib \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/mysql \
- localstatedir=${D}/var/mysql \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- testdir=${D}/usr/share/mysql/test \
- benchdir=${D}/usr/share/mysql/bench
+ make prefix=${D}/usr \
+ libdir=${D}/usr/lib \
+ libexecdir=${D}/usr/sbin \
+ sysconfdir=${D}/etc/mysql \
+ localstatedir=${D}/var/mysql \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ testdir=${D}/usr/share/mysql/test \
+ benchdir=${D}/usr/share/mysql/bench \
+ install || die
# Move Client Libs
@@ -115,7 +111,6 @@ src_install() {
# MySQL Docs
-
dodoc README MIRRORS
cd ${S}/Docs
docinto ps
@@ -124,12 +119,9 @@ src_install() {
dodoc manual.txt
docinto html
dodoc manual.html manual_toc.html
-
}
pkg_config () {
-
- echo "Setting up symlinks..."
- ${ROOT}/usr/sbin/rc-update add mysql
-
+ echo "Setting up symlinks..."
+ ${ROOT}/usr/sbin/rc-update add mysql
}
diff --git a/dev-db/postgresql/postgresql-7.0.3-r2.ebuild b/dev-db/postgresql/postgresql-7.0.3-r2.ebuild
index dac1c3ed27a5..8ad9f591de04 100644
--- a/dev-db/postgresql/postgresql-7.0.3-r2.ebuild
+++ b/dev-db/postgresql/postgresql-7.0.3-r2.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r2.ebuild,v 1.2 2001/07/24 03:33:22 lamer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r2.ebuild,v 1.3 2001/11/10 11:21:56 hallski Exp $
-#P=
-A=${P}.tar.gz
S=${WORKDIR}/${P}/src
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/v7.0.3/${A}"
+SRC_URI="ftp://ftp.postgresql.org/pub/v7.0.3/${P}.tar.gz"
HOMEPAGE="http://postgresql.readysetnet.com/"
DEPEND=">=dev-lang/tcl-tk-8"
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
index 2b222ab7e40d..1592281fbd46 100644
--- a/dev-db/unixODBC/unixODBC-2.0.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.1 2001/04/22 20:10:39 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
-SRC_URI="http://www.unixodbc.org/${A}"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
@@ -15,33 +14,35 @@ DEPEND="virtual/glibc
qt? ( >=x11-libs/qt-x11-2.3.0 )"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile.in Makefile.orig
- sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
-
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
}
-src_compile() {
- local myconf
- if [ "`use qt`" ]
- then
- myconf="--enable-gui=yes"
- else
- myconf="--enable-gui=no"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
-
- try make
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
}
src_install () {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
- prepalldocs
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
}
-
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index cc5309c95ca0..b2d93f4c7e42 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.1 2001/07/01 21:56:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
-SRC_URI="http://www.unixodbc.org/${A}"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
@@ -15,32 +14,35 @@ DEPEND="virtual/glibc
qt? ( >=x11-libs/qt-x11-2.3.0 )"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile.in Makefile.orig
- sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
-
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
}
+
src_compile() {
- local myconf
- if [ "`use qt`" ]
- then
- myconf="--enable-gui=yes"
- else
- myconf="--enable-gui=no"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
- try make
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+ make || die
}
src_install () {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
- prepalldocs
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
}