summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-01-25 18:38:10 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-01-25 18:38:10 +0000
commit896a285df0e7ff26a0fbb55116021b028ec21ef5 (patch)
tree4051789ac145440d862f3d1f3f7b5c5c185825a3
parentVersion bump fx-18.0.1 (diff)
downloadgentoo-2-896a285df0e7ff26a0fbb55116021b028ec21ef5.tar.gz
gentoo-2-896a285df0e7ff26a0fbb55116021b028ec21ef5.tar.bz2
gentoo-2-896a285df0e7ff26a0fbb55116021b028ec21ef5.zip
Add a configuration check for CONFIG_PCI_MSI as discussed in bug #405357
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sys-apps/irqbalance/ChangeLog7
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.5.ebuild11
2 files changed, 13 insertions, 5 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index 3978cd6c76a4..fefd7277ea0d 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/irqbalance
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.48 2012/12/16 13:54:55 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.49 2013/01/25 18:38:10 cardoe Exp $
+
+ 25 Jan 2013; Doug Goldstein <cardoe@gentoo.org> irqbalance-1.0.5.ebuild:
+ Add a configuration check for CONFIG_PCI_MSI as discussed in bug #405357
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> irqbalance-1.0.4.ebuild:
Stable for x86, wrt bug #441512
diff --git a/sys-apps/irqbalance/irqbalance-1.0.5.ebuild b/sys-apps/irqbalance/irqbalance-1.0.5.ebuild
index ba11a0cff664..0088b8ee1715 100644
--- a/sys-apps/irqbalance/irqbalance-1.0.5.ebuild
+++ b/sys-apps/irqbalance/irqbalance-1.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.5.ebuild,v 1.1 2012/12/04 15:45:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.5.ebuild,v 1.2 2013/01/25 18:38:10 cardoe Exp $
EAPI=4
-inherit systemd
+inherit systemd linux-info
DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
HOMEPAGE="http://irqbalance.googlecode.com/"
@@ -21,6 +21,11 @@ RDEPEND="dev-libs/glib:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
src_configure() {
econf \
$(use_with caps libcap-ng) \