summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-09 10:06:26 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-09 10:06:26 +0000
commit8a8a36314de54ce22c1c0594697d83ba04d1dac0 (patch)
treeac5a82a361777a8f01575fd1c03518ded935862f
parentFix Manifest (diff)
downloadgentoo-2-8a8a36314de54ce22c1c0594697d83ba04d1dac0.tar.gz
gentoo-2-8a8a36314de54ce22c1c0594697d83ba04d1dac0.tar.bz2
gentoo-2-8a8a36314de54ce22c1c0594697d83ba04d1dac0.zip
use system sqlite, bug #344609
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
-rw-r--r--x11-libs/qt-webkit/ChangeLog9
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.6.3-r2.ebuild51
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.0-r1.ebuild49
3 files changed, 108 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 5797e27a1c08..c3d4947fe176 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.108 2010/11/06 09:38:53 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.109 2010/11/09 10:06:26 wired Exp $
+
+*qt-webkit-4.7.0-r1 (09 Nov 2010)
+*qt-webkit-4.6.3-r2 (09 Nov 2010)
+
+ 09 Nov 2010; Alex Alexander <wired@gentoo.org> +qt-webkit-4.6.3-r2.ebuild,
+ +qt-webkit-4.7.0-r1.ebuild:
+ use system sqlite, bug #344609
06 Nov 2010; Alex Alexander <wired@gentoo.org> qt-webkit-4.7.0.ebuild:
removed alpha keyword from qt-4.7, bug #338289
diff --git a/x11-libs/qt-webkit/qt-webkit-4.6.3-r2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.6.3-r2.ebuild
new file mode 100644
index 000000000000..3000a69883fc
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.6.3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.6.3-r2.ebuild,v 1.1 2010/11/09 10:06:26 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="
+ dev-db/sqlite:3
+ ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( || ( media-sound/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.0-solaris-strnstr.patch
+ "${FILESDIR}"/${P}-flash-plugin-segfault.patch
+)
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit -system-sqlite $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.0-r1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.0-r1.ebuild
new file mode 100644
index 000000000000..bba78b8dfc00
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.0-r1.ebuild,v 1.1 2010/11/09 10:06:26 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="
+ dev-db/sqlite:3
+ ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( || ( media-sound/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit -system-sqlite $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}