summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-10-13 21:09:36 +0000
committerMichał Górny <mgorny@gentoo.org>2014-10-13 21:09:36 +0000
commit8d0ccde55af755af3317b0d432403f5cec271879 (patch)
tree614c25146f06f90c0d5ee75a8298c32e932c8526
parentVersion bump. (diff)
downloadgentoo-2-8d0ccde55af755af3317b0d432403f5cec271879.tar.gz
gentoo-2-8d0ccde55af755af3317b0d432403f5cec271879.tar.bz2
gentoo-2-8d0ccde55af755af3317b0d432403f5cec271879.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--games-simulation/bcs-demo/ChangeLog7
-rw-r--r--games-simulation/bcs-demo/bcs-demo-1.3.ebuild39
2 files changed, 28 insertions, 18 deletions
diff --git a/games-simulation/bcs-demo/ChangeLog b/games-simulation/bcs-demo/ChangeLog
index 01851c967896..019272e0dea4 100644
--- a/games-simulation/bcs-demo/ChangeLog
+++ b/games-simulation/bcs-demo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/bcs-demo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/ChangeLog,v 1.11 2012/12/31 14:42:06 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/ChangeLog,v 1.12 2014/10/13 21:09:36 mgorny Exp $
+
+ 13 Oct 2014; Michał Górny <mgorny@gentoo.org> bcs-demo-1.3.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
31 Dec 2012; Tupone Alfredo <tupone@gentoo.org> bcs-demo-1.3.ebuild:
Use QA_PREBUILT. Bug #431116 by Diego Elio Pettenò
diff --git a/games-simulation/bcs-demo/bcs-demo-1.3.ebuild b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
index 29de914d0fc6..10c069d49b4c 100644
--- a/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
+++ b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/bcs-demo-1.3.ebuild,v 1.11 2012/12/31 14:42:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/bcs-demo-1.3.ebuild,v 1.12 2014/10/13 21:09:36 mgorny Exp $
+
+EAPI=5
inherit unpacker games
@@ -16,16 +18,21 @@ IUSE=""
RESTRICT="strip"
RDEPEND="sys-libs/glibc
- virtual/opengl
- x86? (
- media-libs/libsdl
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-sdl )"
+ || (
+ (
+ media-libs/libsdl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
S=${WORKDIR}
@@ -45,18 +52,18 @@ src_install() {
rm -f "${Ddir}"/bcs-linux-openal-fixer.sh
exeinto "${dir}"
-# doexe bin/Linux/x86/rungame.sh || die
+# doexe bin/Linux/x86/rungame.sh
# exeinto ${dir}/lib
mv "${Ddir}"/bcs "${Ddir}"/bcs-bin
- newexe libopenal.so.0.0.6 libopenal.so.0 || die
+ newexe libopenal.so.0.0.6 libopenal.so.0
echo '#!/bin/bash' >> "${Ddir}"/bcs
echo 'LD_PRELOAD="./libopenal.so.0" ./bcs-bin' >> "${Ddir}"/bcs
fperms 750 "${dir}"/bcs
games_make_wrapper bcs-demo ./bcs "${dir}" "${dir}"
insinto "${dir}"
- doins *.cfg || die
- dodoc readme* || die
+ doins *.cfg
+ dodoc readme*
prepgamesdirs
}