summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-27 17:06:58 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-27 17:06:58 +0000
commit8ddd07ace9d38c923ff8003601444747362571b5 (patch)
tree0140af4458369c9752e06cafbc3777421410ab1c
parentremoved old ebuild (diff)
downloadgentoo-2-8ddd07ace9d38c923ff8003601444747362571b5.tar.gz
gentoo-2-8ddd07ace9d38c923ff8003601444747362571b5.tar.bz2
gentoo-2-8ddd07ace9d38c923ff8003601444747362571b5.zip
mark 0.20 stable, 0.20-r1 new revision with mcs compilation from scratch
-rw-r--r--dev-lang/mono/ChangeLog9
-rw-r--r--dev-lang/mono/files/digest-mono-0.20-r12
-rw-r--r--dev-lang/mono/mono-0.20-r1.ebuild66
-rw-r--r--dev-lang/mono/mono-0.20.ebuild4
4 files changed, 78 insertions, 3 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 137fa75b29ac..4a06181249ec 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.12 2003/02/24 15:53:41 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.13 2003/02/27 17:06:58 foser Exp $
+
+*mono-0.20-r1 (27 Feb 2003)
+
+ 27 Feb 2003; foser <foser@gentoo.org> mono-0.20-r1.ebuild :
+ Now also compiles mcs from scratch
+ Initial work done by Artur Brodowski <bzdurqa@wp.pl> in #16316
+ Hacked on a lot by me to get it right
*mono-0.20 (24 Feb 2003)
diff --git a/dev-lang/mono/files/digest-mono-0.20-r1 b/dev-lang/mono/files/digest-mono-0.20-r1
new file mode 100644
index 000000000000..792fe02465b5
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-0.20-r1
@@ -0,0 +1,2 @@
+MD5 4632b2dbee0d5d52cf7ba340c47e8b08 mono-0.20.tar.gz 3387623
+MD5 0e5fccb17be3de275456dd2c65d272d0 mcs-0.20.tar.gz 4000532
diff --git a/dev-lang/mono/mono-0.20-r1.ebuild b/dev-lang/mono/mono-0.20-r1.ebuild
new file mode 100644
index 000000000000..218ae2829c46
--- /dev/null
+++ b/dev-lang/mono/mono-0.20-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.20-r1.ebuild,v 1.1 2003/02/27 17:06:58 foser Exp $
+
+inherit eutils mono
+
+MCS_P="mcs-${PV}"
+MCS_S=${WORKDIR}/${MCS_P}
+
+IUSE=""
+DESCRIPTION="Mono runtime and class librarier, a C# compiler/interpreter"
+SRC_URI="http://www.go-mono.com/archive/${P}.tar.gz
+ http://www.go-mono.com/archive/${MCS_P}.tar.gz"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 -ppc"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-2.0
+ >=dev-libs/boehm-gc-6.1"
+
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # patch to select a diff corlib rootdir
+ # needed for in-place mcs compilation
+ # patch by foser <foser@gentoo.org>
+ epatch ${FILESDIR}/${P}-unix_rootdir_env.patch
+
+ # add our own little in-place mcs script
+ echo "${S}/mono/jit/mono ${S}/runtime/mcs.exe \"\$@\" " > ${S}/runtime/mcs
+ chmod +x ${S}/runtime/mcs
+}
+
+src_compile() {
+ econf --with-gc=boehm || die
+ MAKEOPTS="-j1" emake || die "MONO compilation failure"
+
+ cd ${MCS_S}
+ PATH=${PATH}:${S}/runtime:${S}/mono/jit MONO_ROOTDIR=${S}/runtime emake -f makefile.gnu || die "MCS compilation failure"
+}
+
+src_install () {
+ cd ${S}
+ einstall || die
+
+ dodoc AUTHORS ChangeLog COPYING.LIB NEWS README
+ docinto docs
+ dodoc docs/*
+
+ # now install our own compiled dlls
+ cd ${MCS_S}
+ einstall || die
+
+ docinto mcs
+ dodoc AUTHORS COPYING README* ChangeLog INSTALL.txt
+ docinto mcs/docs
+ dodoc docs/*.txt
+}
diff --git a/dev-lang/mono/mono-0.20.ebuild b/dev-lang/mono/mono-0.20.ebuild
index b5c470441e85..9c2f2e32e49b 100644
--- a/dev-lang/mono/mono-0.20.ebuild
+++ b/dev-lang/mono/mono-0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.20.ebuild,v 1.1 2003/02/24 15:53:41 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.20.ebuild,v 1.2 2003/02/27 17:06:58 foser Exp $
#FIXME : we dont compile mcs from scratch right now
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.go-mono.com/"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 -ppc"
+KEYWORDS="x86 -ppc"
DEPEND="virtual/glibc
>=dev-libs/glib-2.0