summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-02-18 15:58:30 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-02-18 15:58:30 +0000
commit8e71d1278f7cda6c75f2a0a421124425c04b9acc (patch)
tree8f8b4dd4450f2b3ac2b0ba006b504ff98da05903
parentCleanup RESTRICT (strip, test), add more documentation, create symlinks of so... (diff)
downloadgentoo-2-8e71d1278f7cda6c75f2a0a421124425c04b9acc.tar.gz
gentoo-2-8e71d1278f7cda6c75f2a0a421124425c04b9acc.tar.bz2
gentoo-2-8e71d1278f7cda6c75f2a0a421124425c04b9acc.zip
Version bump.
(Portage version: 2.1.2-r9)
-rw-r--r--app-accessibility/espeak/ChangeLog9
-rw-r--r--app-accessibility/espeak/espeak-1.20.ebuild53
-rw-r--r--app-accessibility/espeak/files/digest-espeak-1.203
-rw-r--r--app-accessibility/espeak/files/espeak-1.20-big-endian.patch30
-rw-r--r--app-accessibility/espeak/files/espeak-1.20-ppc64-segfault.patch13
5 files changed, 107 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index be4a8637a6dc..221893c85929 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.8 2007/02/10 13:41:51 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.9 2007/02/18 15:58:30 williamh Exp $
+
+*espeak-1.20 (18 Feb 2007)
+
+ 18 Feb 2007; William Hubbs <williamh@gentoo.org>
+ +files/espeak-1.20-big-endian.patch,
+ +files/espeak-1.20-ppc64-segfault.patch, +espeak-1.20.ebuild:
+ Version bump.
10 Feb 2007; Steve Dibb <beandog@gentoo.org> espeak-1.19.ebuild:
amd64 stable, bug 163285
diff --git a/app-accessibility/espeak/espeak-1.20.ebuild b/app-accessibility/espeak/espeak-1.20.ebuild
new file mode 100644
index 000000000000..027a31c0b258
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.20.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.20.ebuild,v 1.1 2007/02/18 15:58:30 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/portaudio-18.1-r5
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+
+ # Apply patch to support big-endian processors
+ epatch ${FILESDIR}/${P}-big-endian.patch
+
+ # Apply patch for ppc64 segfault
+ epatch ${FILESDIR}/${P}-ppc64-segfault.patch
+}
+
+src_compile() {
+ cd src
+ emake CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ cd "${S}"
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}
diff --git a/app-accessibility/espeak/files/digest-espeak-1.20 b/app-accessibility/espeak/files/digest-espeak-1.20
new file mode 100644
index 000000000000..72b5f5a73be6
--- /dev/null
+++ b/app-accessibility/espeak/files/digest-espeak-1.20
@@ -0,0 +1,3 @@
+MD5 47dbb852987d22892bcc1c71eff39d61 espeak-1.20-source.zip 669313
+RMD160 233f896de684a743313f70e0d953f90a29f76119 espeak-1.20-source.zip 669313
+SHA256 36933cb231081a4ce1053daf9cfc7a43767aeac2e278760e96888550446d2dc9 espeak-1.20-source.zip 669313
diff --git a/app-accessibility/espeak/files/espeak-1.20-big-endian.patch b/app-accessibility/espeak/files/espeak-1.20-big-endian.patch
new file mode 100644
index 000000000000..c69a3cee463c
--- /dev/null
+++ b/app-accessibility/espeak/files/espeak-1.20-big-endian.patch
@@ -0,0 +1,30 @@
+--- src/Makefile 2007-01-26 03:20:06.000000000 -0600
++++ src/Makefile 2007-02-06 20:37:41.000000000 -0600
+@@ -39,9 +39,6 @@
+ LIBS3=-lstdc++ ./libespeak.so
+
+ CXXFLAGS=-O2
+-ifeq ($(shell uname -m), ppc)
+- CXXFLAGS += -D ARCH_BIG
+-endif
+
+
+ all: $(BIN_NAME) $(LIB_NAME) $(BIN2_NAME)
+--- src/speech.h 2007-01-26 03:11:59.000000000 -0600
++++ src/speech.h 2007-02-06 20:41:11.000000000 -0600
+@@ -18,9 +18,15 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <sys/types.h>
++
+ // conditional compilation options
+
+
++#if defined(BYTE_ORDER) && BYTE_ORDER == BIG_ENDIAN
++#define ARCH_BIG
++#endif
++
+ #define PLATFORM_POSIX
+ #define PATHSEP '/'
+ #define USE_PORTAUDIO
diff --git a/app-accessibility/espeak/files/espeak-1.20-ppc64-segfault.patch b/app-accessibility/espeak/files/espeak-1.20-ppc64-segfault.patch
new file mode 100644
index 000000000000..ac39760ebcf3
--- /dev/null
+++ b/app-accessibility/espeak/files/espeak-1.20-ppc64-segfault.patch
@@ -0,0 +1,13 @@
+--- src/speak_lib.cpp 2007-02-01 19:34:01.360979913
++0000
++++ src/speak_lib.cpp 2007-02-01 19:34:13.708979913
++0000
+@@ -238,7 +238,7 @@
+ char *Alloc(int size)
+ {//==================
+ char *p;
+- if((p = (char *)malloc(size)) == NULL)
++ if((p = (char *)malloc(size+1)) == NULL)
+ fprintf(stderr,"Can't allocate memory\n");
+ return(p);
+ }