summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-24 13:34:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-24 13:34:07 +0000
commit92e8620749756c7bd2b34ef308e10e2c6943f692 (patch)
treee84f6b8aa779af9a3b7212e067ca1c222e37047c
parentFix journald prototype missync, bug #436098. (diff)
downloadgentoo-2-92e8620749756c7bd2b34ef308e10e2c6943f692.tar.gz
gentoo-2-92e8620749756c7bd2b34ef308e10e2c6943f692.tar.bz2
gentoo-2-92e8620749756c7bd2b34ef308e10e2c6943f692.zip
Add ucpp live ebuild as this will be required by lo 3.7.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
-rw-r--r--sys-devel/ucpp/ChangeLog11
-rw-r--r--sys-devel/ucpp/metadata.xml6
-rw-r--r--sys-devel/ucpp/ucpp-9999.ebuild32
3 files changed, 42 insertions, 7 deletions
diff --git a/sys-devel/ucpp/ChangeLog b/sys-devel/ucpp/ChangeLog
index 9fca931c9791..eec72026670b 100644
--- a/sys-devel/ucpp/ChangeLog
+++ b/sys-devel/ucpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/ucpp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ChangeLog,v 1.2 2011/08/02 14:19:29 alexxy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ChangeLog,v 1.3 2012/09/24 13:34:07 scarabeus Exp $
+
+*ucpp-9999 (24 Sep 2012)
+
+ 24 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +ucpp-9999.ebuild,
+ metadata.xml:
+ Add ucpp live ebuild as this will be required by lo 3.7.
02 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> ucpp-1.3.ebuild:
Add ~amd64-linux keyword
@@ -10,4 +16,3 @@
28 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +ucpp-1.3.ebuild,
+files/tune.h.patch, +metadata.xml:
Initial import to tree
-
diff --git a/sys-devel/ucpp/metadata.xml b/sys-devel/ucpp/metadata.xml
index efb490d78817..94f0af2341ee 100644
--- a/sys-devel/ucpp/metadata.xml
+++ b/sys-devel/ucpp/metadata.xml
@@ -1,8 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
+ <herd>openoffice</herd>
+ <herd>sci</herd>
</pkgmetadata>
diff --git a/sys-devel/ucpp/ucpp-9999.ebuild b/sys-devel/ucpp/ucpp-9999.ebuild
new file mode 100644
index 000000000000..bfe5cc8e4fea
--- /dev/null
+++ b/sys-devel/ucpp/ucpp-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-9999.ebuild,v 1.1 2012/09/24 13:34:07 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://github.com/scarabeusiv/ucpp.git"
+inherit eutils git-2 autotools
+
+DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
+HOMEPAGE="http://code.google.com/p/ucpp/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}