summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-04-22 08:04:20 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-04-22 08:04:20 +0000
commit936c422410a44503f65e7dcf56e9725ba13004fe (patch)
tree861b4f9647a5d9d3ece3b477cfc51d3d469412f2
parentStable for s390, wrt bug #449298 (diff)
downloadgentoo-2-936c422410a44503f65e7dcf56e9725ba13004fe.tar.gz
gentoo-2-936c422410a44503f65e7dcf56e9725ba13004fe.tar.bz2
gentoo-2-936c422410a44503f65e7dcf56e9725ba13004fe.zip
Revbump to EAPI-5. Added a patch to default enable libcap-ng and some additionaly tweaks in the ebuild (bug #466364). Reworked caps USE flag logic
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
-rw-r--r--net-fs/cifs-utils/ChangeLog11
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.0-r1.ebuild98
2 files changed, 108 insertions, 1 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index aa7e6b2c6c32..9d867665983f 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.62 2013/04/14 11:43:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.63 2013/04/22 08:04:20 polynomial-c Exp $
+
+*cifs-utils-6.0-r1 (22 Apr 2013)
+
+ 22 Apr 2013; Lars Wendler <polynomial-c@gentoo.org>
+ +cifs-utils-6.0-r1.ebuild:
+ Revbump to EAPI-5. Added a patch by Torsten Kurbad to default enable
+ libcap-ng and some additionaly tweaks in the ebuild (bug #466364). Reworked
+ USE flag logic. Now "caps" USE flag controls both caps implementations and
+ "caps-ng" is the switch between one of them.
14 Apr 2013; Agostino Sarubbo <ago@gentoo.org> cifs-utils-5.9-r1.ebuild:
Stable for sh, wrt bug #464356
diff --git a/net-fs/cifs-utils/cifs-utils-6.0-r1.ebuild b/net-fs/cifs-utils/cifs-utils-6.0-r1.ebuild
new file mode 100644
index 000000000000..e4ae96cccaa3
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.0-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-6.0-r1.ebuild,v 1.1 2013/04/22 08:04:20 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils linux-info multilib
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="acl ads +caps +caps-ng creds upcall"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( !caps-ng? ( sys-libs/libcap ) )
+ caps? ( caps-ng? ( sys-libs/libcap-ng ) )
+ creds? ( sys-apps/keyutils )
+ upcall? ( sys-apps/keyutils sys-libs/talloc virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="acl? ( upcall )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_configure() {
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf \
+ $(use_enable acl cifsacl cifsidmap) \
+ $(use_enable ads cifsupcall) \
+ $(use caps && use_with !caps-ng libcap || echo --without-libcap) \
+ $(use caps && use_with caps-ng libcap-ng || echo --without-libcap-ng) \
+ $(use_enable creds cifscreds) \
+ $(use_enable upcall cifsupcall)
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -print0 | xargs --null rmdir \
+ --ignore-fail-on-non-empty &>/dev/null
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym /usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ fi
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}