summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-09-09 21:44:59 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-09-09 21:44:59 +0000
commit956a981f0b8b95f1aceb475000072074d82ca5ea (patch)
tree067896b2a2f68ecd837c6ad29d3ec8365ad62284
parentMark 4.2.2_p3 stable on ia64. #146912 (diff)
downloadgentoo-2-956a981f0b8b95f1aceb475000072074d82ca5ea.tar.gz
gentoo-2-956a981f0b8b95f1aceb475000072074d82ca5ea.tar.bz2
gentoo-2-956a981f0b8b95f1aceb475000072074d82ca5ea.zip
More assert fixes to fix bug #146868. Thanks to Joel <joel_123@hotmail.com> for the patch.
(Portage version: 2.1.1)
-rw-r--r--dev-java/jython/ChangeLog9
-rw-r--r--dev-java/jython/files/2.1-assert-SimpleCompiler.py.patch11
-rw-r--r--dev-java/jython/files/digest-jython-2.1-r93
-rw-r--r--dev-java/jython/jython-2.1-r9.ebuild94
4 files changed, 116 insertions, 1 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
index 58e582a0c4e6..f61eb1774d73 100644
--- a/dev-java/jython/ChangeLog
+++ b/dev-java/jython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jython
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.32 2006/07/29 21:29:58 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.33 2006/09/09 21:44:59 betelgeuse Exp $
+
+*jython-2.1-r9 (09 Sep 2006)
+
+ 09 Sep 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +files/2.1-assert-SimpleCompiler.py.patch, +jython-2.1-r9.ebuild:
+ More assert fixes to fix bug #146868. Thanks to Joel <joel_123@hotmail.com>
+ for the patch.
*jython-2.1-r8 (29 Jul 2006)
diff --git a/dev-java/jython/files/2.1-assert-SimpleCompiler.py.patch b/dev-java/jython/files/2.1-assert-SimpleCompiler.py.patch
new file mode 100644
index 000000000000..55e154999195
--- /dev/null
+++ b/dev-java/jython/files/2.1-assert-SimpleCompiler.py.patch
@@ -0,0 +1,11 @@
+--- jython-2.1/Tools/jythonc/SimpleCompiler.py.orig 2006-09-08 13:21:29.000000000 -0600
++++ jython-2.1/Tools/jythonc/SimpleCompiler.py 2006-09-08 13:22:15.000000000 -0600
+@@ -577,7 +577,7 @@
+ args.append(message.asAny())
+
+ return jast.If(self.frame.getglobal("__debug__").nonzero(),
+- jast.InvokeStatic("Py", "assert", args))
++ jast.InvokeStatic("Py", "assert_", args))
+
+ def return_stmt(self, value=None):
+ if value is None:
diff --git a/dev-java/jython/files/digest-jython-2.1-r9 b/dev-java/jython/files/digest-jython-2.1-r9
new file mode 100644
index 000000000000..430b21a5c3b2
--- /dev/null
+++ b/dev-java/jython/files/digest-jython-2.1-r9
@@ -0,0 +1,3 @@
+MD5 74f21a0185135396c71453bc279c179f jython-2.1.tar.bz2 1301528
+RMD160 94ae22604c1a816af7d066f2ed88b2abaf5c51d1 jython-2.1.tar.bz2 1301528
+SHA256 faa57a55d137268e80221cd628b234ca67de13504b813be1c0499c9f4d5872b2 jython-2.1.tar.bz2 1301528
diff --git a/dev-java/jython/jython-2.1-r9.ebuild b/dev-java/jython/jython-2.1-r9.ebuild
new file mode 100644
index 000000000000..0080186d538d
--- /dev/null
+++ b/dev-java/jython/jython-2.1-r9.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r9.ebuild,v 1.1 2006/09/09 21:44:59 betelgeuse Exp $
+
+inherit base java-pkg-2
+
+DESCRIPTION="An implementation of Python written in Java"
+HOMEPAGE="http://www.jython.org"
+MY_PV="21"
+#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="JPython"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc64"
+IUSE="readline source doc"
+# servlet
+
+RDEPEND=">=virtual/jre-1.2
+ readline? ( >=dev-java/libreadline-java-0.8.0 )"
+# servlet? ( >=net-www/tomcat-5.0 )
+DEPEND=">=virtual/jdk-1.2
+ source? ( app-arch/zip )
+ ${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PV}-assert.patch
+ ${FILESDIR}/${PV}-assert-SimpleCompiler.py.patch"
+
+src_compile() {
+ local cp="."
+ local exclude=""
+
+ if use readline ; then
+ cp=${cp}:$(java-pkg_getjars libreadline-java)
+ else
+ exclude="${exclude} ! -name ReadlineConsole.java"
+ fi
+
+ #if use servlet; then
+ # cp=${cp}:$(java-pkg_getjars servlet)
+ #else
+ exclude="${exclude} ! -name PyServlet.java"
+ #fi
+
+ ejavac -classpath ${cp} -nowarn $(find org -name "*.java" ${exclude})
+
+ find org -name "*.class" | xargs jar cf ${PN}.jar
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README.txt NEWS ACKNOWLEDGMENTS
+ use doc && java-pkg_dohtml -A .css .jpg .gif -r Doc/*
+
+ java-pkg_dolauncher jythonc \
+ --main "org.python.util.jython" \
+ --java_args '-Dpython.home=/usr/share/jython' \
+ --pkg_args '/usr/share/jython/tools/jythonc/jythonc.py'
+
+ java-pkg_dolauncher jython \
+ --main 'org.python.util.jython' \
+ --java_args '-Dpython.home="/usr/share/jython"'
+
+ dodir /usr/share/jython/cachedir
+ chmod a+rw ${D}/usr/share/jython/cachedir
+
+ rm Demo/jreload/example.jar
+ insinto /usr/share/${PN}
+ doins -r Lib Demo registry
+
+ insinto /usr/share/${PN}/tools
+ doins -r Tools/*
+
+ use source && java-pkg_dosrc com org
+}
+
+pkg_postinst() {
+ if use readline; then
+ einfo "To use readline you need to add the following to your registery"
+ einfo
+ einfo "python.console=org.python.util.ReadlineConsole"
+ einfo "python.console.readlinelib=GnuReadline"
+ einfo
+ einfo "The global registry can be found in /usr/share/${PN}/registry"
+ einfo "User registry in \$HOME/.jython"
+ einfo "See http://www.jython.org/docs/registry.html for more information"
+ einfo ""
+ fi
+
+ elog "This revision renames org.python.core.Py.assert to assert_."
+ elog "This is the solution that upstream will use in the next release."
+ elog "Just note that this revision is not API compatible with vanilla 2.1."
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=142099"
+}