summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-12-23 16:11:49 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-12-23 16:11:49 +0000
commit95e455492fef2798a7c2678b26bd4696bea3edcf (patch)
tree10bbfe9bb5621ef64a25a6d0f0116809b4d0d2de
parentVersion bump (diff)
downloadgentoo-2-95e455492fef2798a7c2678b26bd4696bea3edcf.tar.gz
gentoo-2-95e455492fef2798a7c2678b26bd4696bea3edcf.tar.bz2
gentoo-2-95e455492fef2798a7c2678b26bd4696bea3edcf.zip
Version bump.
(Portage version: 2.1.4_rc11)
-rw-r--r--media-video/kino/ChangeLog7
-rw-r--r--media-video/kino/files/digest-kino-1.2.03
-rw-r--r--media-video/kino/kino-1.2.0.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/media-video/kino/ChangeLog b/media-video/kino/ChangeLog
index 3581a249475d..9f1c06eec671 100644
--- a/media-video/kino/ChangeLog
+++ b/media-video/kino/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/kino
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.93 2007/12/15 17:59:37 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.94 2007/12/23 16:11:49 calchan Exp $
+
+*kino-1.2.0 (23 Dec 2007)
+
+ 23 Dec 2007; Denis Dupeyron <calchan@gentoo.org> +kino-1.2.0.ebuild:
+ Version bump.
15 Dec 2007; Denis Dupeyron <calchan@gentoo.org> -kino-1.0.0.ebuild:
Post-stabilization cleanup.
diff --git a/media-video/kino/files/digest-kino-1.2.0 b/media-video/kino/files/digest-kino-1.2.0
new file mode 100644
index 000000000000..96672a7258c1
--- /dev/null
+++ b/media-video/kino/files/digest-kino-1.2.0
@@ -0,0 +1,3 @@
+MD5 8d7140fce089acce771eade7821d0981 kino-1.2.0.tar.gz 10637296
+RMD160 2cfd0d0c3d4a797e8f8986cdbcb444aeb4bde3a6 kino-1.2.0.tar.gz 10637296
+SHA256 e952622f7d5c1aa433947dff72948eeacb1c9a502ba297735e5fa81263c50197 kino-1.2.0.tar.gz 10637296
diff --git a/media-video/kino/kino-1.2.0.ebuild b/media-video/kino/kino-1.2.0.ebuild
new file mode 100644
index 000000000000..85eedc6ef414
--- /dev/null
+++ b/media-video/kino/kino-1.2.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-1.2.0.ebuild,v 1.1 2007/12/23 16:11:49 calchan Exp $
+
+DESCRIPTION="Kino is a non-linear DV editor for GNU/Linux"
+HOMEPAGE="http://www.kinodv.org/"
+SRC_URI="mirror://sourceforge/kino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa dvdr gpac lame gstreamer quicktime sox vorbis"
+
+# This ebuild would benefit a lot of USE dependencies but that has to wait for
+# EAPI 2. The usual fix is to issue built_with_use checks but in that particu-
+# lar case it would make the ebuild rather complicated to write and maintain
+# (certain features can be enabled in various different ways). Also it would
+# also force the emerge process to stop a bit too often for users not to comp-
+# lain. Thus, if you need features like theora, x264, xvid and maybe others,
+# make sure you activate the required support where it should be (ffmpeg, mostly).
+
+# Optional dependency on cinelerra-cvs (as a replacement for libquicktime)
+# dropped because kino may run with it but won't build anymore.
+
+DEPEND=">=x11-libs/gtk+-2.6.0
+ >=gnome-base/libglade-2.5.0
+ >=dev-libs/glib-2
+ x11-libs/libXv
+ dev-libs/libxml2
+ media-libs/audiofile
+ >=sys-libs/libraw1394-1.0.0
+ >=sys-libs/libavc1394-0.4.1
+ >=media-libs/libdv-0.103
+ media-libs/libsamplerate
+ !sparc? ( media-libs/libiec61883 )
+ alsa? ( >=media-libs/alsa-lib-1.0.9 )
+ >=media-video/ffmpeg-0.4.9_p20061016
+ quicktime? ( >=media-libs/libquicktime-0.9.5 )"
+RDEPEND="${DEPEND}
+ media-video/mjpegtools
+ media-sound/rawrec
+ dvdr? ( media-video/dvdauthor
+ app-cdr/dvd+rw-tools )
+ gpac? ( !sparc? ( media-video/gpac ) )
+ lame? ( media-sound/lame )
+ gstreamer? ( media-libs/gst-plugins-base )
+ sox? ( media-sound/sox )
+ vorbis? ( media-sound/vorbis-tools )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix to link with --as-needed
+ sed -i -e 's:LIBS="-lXext:LIBS="-lXext -lX11:' configure || die "sed failed"
+
+ # Deactivating automagic alsa configuration, bug #134725
+ if ! use alsa ; then
+ sed -i -e "s:HAVE_ALSA 1:HAVE_ALSA 0:" configure || die "sed failed"
+ fi
+
+ # Fix bug #169590
+ sed -i \
+ -e '/\$(LIBQUICKTIME_LIBS) \\/d' \
+ -e '/^[[:space:]]*\$(SRC_LIBS)/ a\
+ \$(LIBQUICKTIME_LIBS) \\' \
+ src/Makefile.in || die "sed failed"
+
+ # Fix bug #172687
+ sed -i \
+ -e 's/^install-exec-local:/install-exec-local: install-binPROGRAMS/' \
+ src/Makefile.in || die "sed failed"
+
+ # Fix test failure discovered in bug #193947
+ sed -i -e '$a\
+\
+ffmpeg/libavcodec/ps2/idct_mmi.c\
+ffmpeg/libavcodec/sparc/dsputil_vis.c\
+ffmpeg/libavcodec/sparc/vis.h\
+ffmpeg/libavutil/bswap.h\
+ffmpeg/libswscale/yuv2rgb_template.c\
+src/export.h\
+src/message.cc\
+src/page_bttv.cc' po/POTFILES.in || die "sed failed"
+
+ sed -i -e 's:^#include <quicktime.h>:#include <lqt/quicktime.h>:' \
+ src/filehandler.h || dies "sed failed"
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-local-ffmpeg \
+ $(use_enable quicktime) \
+ $(use_with sparc dv1394) \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README* TODO
+ # Fix bug #177378
+ fowners root:root -R /usr/share/kino/help
+}