summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2014-07-12 10:39:05 +0000
committerAlex Alexander <wired@gentoo.org>2014-07-12 10:39:05 +0000
commit9becc283211d04d2b6123637bbf57358d1ad4c43 (patch)
treee35c28aec2ae6a14a95ea48537fcbbe19c6e23e6
parentNew manifest due to wrong pre release tar ball (diff)
downloadgentoo-2-9becc283211d04d2b6123637bbf57358d1ad4c43.tar.gz
gentoo-2-9becc283211d04d2b6123637bbf57358d1ad4c43.tar.bz2
gentoo-2-9becc283211d04d2b6123637bbf57358d1ad4c43.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.15_p2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index a17817c6b363..34cd29991d9e 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.118 2014/06/15 17:03:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.119 2014/07/12 10:39:05 wired Exp $
+
+*pf-sources-3.15_p2 (12 Jul 2014)
+
+ 12 Jul 2014; Alex Alexander <wired@gentoo.org> +pf-sources-3.15_p2.ebuild:
+ version bump
*pf-sources-3.15_p1 (15 Jun 2014)
diff --git a/sys-kernel/pf-sources/pf-sources-3.15_p2.ebuild b/sys-kernel/pf-sources/pf-sources-3.15_p2.ebuild
new file mode 100644
index 000000000000..22b8d27c44be
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.15_p2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.15_p2.ebuild,v 1.1 2014/07/12 10:39:05 wired Exp $
+
+EAPI="5"
+inherit readme.gentoo versionator
+
+COMPRESSTYPE=".xz"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and UKSM"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_VERS="1"
+PF_FILE="patch-${PV/_p*/}-pf${PV/*_p/}${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${P} has the following optional runtime dependencies:
+- sys-apps/tuxonice-userui: provides minimal userspace progress
+information related to suspending and resuming process.
+- sys-power/hibernate-script or sys-power/pm-utils: runtime utilities
+for hibernating and suspending your computer."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+src_install() {
+ kernel-2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ readme.gentoo_print_elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."