summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-02-02 21:28:43 +0000
committerThomas Sachau <tommy@gentoo.org>2009-02-02 21:28:43 +0000
commita8a323c068d6e9ced2b6c3f6253102471d02c6a0 (patch)
tree1eaccd92e652ec0faeae9f413f6c7acfabf083fa
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-a8a323c068d6e9ced2b6c3f6253102471d02c6a0.tar.gz
gentoo-2-a8a323c068d6e9ced2b6c3f6253102471d02c6a0.tar.bz2
gentoo-2-a8a323c068d6e9ced2b6c3f6253102471d02c6a0.zip
Initial commit. Fixes bug 240447
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--net-mail/Freemail/ChangeLog10
-rw-r--r--net-mail/Freemail/Freemail-9999.ebuild47
-rw-r--r--net-mail/Freemail/files/build.patch76
-rw-r--r--net-mail/Freemail/metadata.xml9
4 files changed, 142 insertions, 0 deletions
diff --git a/net-mail/Freemail/ChangeLog b/net-mail/Freemail/ChangeLog
new file mode 100644
index 000000000000..2084cd4e20cd
--- /dev/null
+++ b/net-mail/Freemail/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/Freemail
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/Freemail/ChangeLog,v 1.1 2009/02/02 21:28:43 tommy Exp $
+
+*Freemail-9999 (02 Feb 2009)
+
+ 02 Feb 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +files/build.patch, +Freemail-9999.ebuild:
+ Initial commit. Fixes bug 240447
+
diff --git a/net-mail/Freemail/Freemail-9999.ebuild b/net-mail/Freemail/Freemail-9999.ebuild
new file mode 100644
index 000000000000..f67aa329fb9e
--- /dev/null
+++ b/net-mail/Freemail/Freemail-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/Freemail/Freemail-9999.ebuild,v 1.1 2009/02/02 21:28:43 tommy Exp $
+
+EAPI="2"
+
+ESVN_REPO_URI="http://freenet.googlecode.com/svn/trunk/apps/Freemail"
+ESVN_OPTIONS="--ignore-externals"
+EANT_BUILD_TARGET="dist"
+inherit eutils java-pkg-2 java-ant-2 subversion
+
+DESCRIPTION="Anonymous IMAP/SMTP e-mail server over Freenet"
+HOMEPAGE="http://www.freenetproject.org/tools.html"
+SRC_URI=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="dev-java/bcprov
+ net-p2p/freenet[freemail]"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+EANT_GENTOO_CLASSPATH="bcprov freenet"
+src_prepare() {
+ epatch "${FILESDIR}"/build.patch
+ java-ant_rewrite-classpath
+}
+
+src_install() {
+ java-pkg_dojar lib/Freemail.jar
+ dodir /var/freenet/plugins
+ dosym ../../../usr/share/Freemail/lib/Freemail.jar /var/freenet/plugins/Freemail.jar
+ dodoc README || die "installation of documentation failed"
+}
+
+pkg_postinst () {
+ elog "To load Freemail, go to the plugin page of freenet and enter at"
+ elog "Plugin-URL: plugins/Freemail.jar. This should load the Freemail plugin."
+ elog "Set your email client to IMAP port 3143 and SMTP port 3025 on localhost."
+ elog "To bind freemail to different ports, or to a different freenet node, edit"
+ elog "/var/freenet/globalconfig."
+}
diff --git a/net-mail/Freemail/files/build.patch b/net-mail/Freemail/files/build.patch
new file mode 100644
index 000000000000..4ac3a878cdaf
--- /dev/null
+++ b/net-mail/Freemail/files/build.patch
@@ -0,0 +1,76 @@
+--- build.xml 2008-10-08 18:58:11.000000000 +0200
++++ build.xml.new 2008-10-08 18:59:25.000000000 +0200
+@@ -4,64 +4,8 @@
+ <property name="src" location="src"/>
+ <property name="build" location="build"/>
+ <property name="lib" location="lib"/>
+- <property name="deps" location="deps"/>
+-
+- <property name="bcdist" value="lcrypto-jdk14-138"/>
+- <property name="freenetjarurl.url" value="http://downloads.freenetproject.org/alpha/freenet-testing-latest.jar.url"/>
+- <property name="freenetjarurl.localpath" value="${deps}/freenet-testing-latest.jar.url"/>
+- <property name="freenetjar" value="freenet-main.jar"/>
+-
+- <target name="freenetjar-check">
+- <available file="${deps}/${freenetjar}" property="freenetjar.present" />
+- </target>
+-
+- <!-- Fetching the Freenet jar here is far from optimal:
+- Ideally we'd compile against a the freenet jar or class files
+- which the user almost certainly has on their computer already.
+- Unfortunately about the only sensible way of doing this would
+- be with Maven2, and both Freenet and Freemail import code from
+- other projects which would make things difficult and/or ugly.
+- -->
+- <target name="freenetjar-fetch" depends="freenetjar-check" unless="freenetjar.present">
+- <echo>
+- Attempting to fetch Freenet main jar - ant cannot do this reliably, so if it fails, delete ${deps}/${freenetjar} and ${freenetjarurl.localpath} and run ant again.
+- </echo>
+- <mkdir dir="${deps}" />
+- <!-- loadresource directly from an HTTP URL is causing problems -->
+- <get src="${freenetjarurl.url}"
+- dest="${freenetjarurl.localpath}" />
+- <loadfile property="freenetjar.url"
+- srcFile="${freenetjarurl.localpath}" />
+- <get src="${freenetjar.url}"
+- dest="${deps}/${freenetjar}"
+- verbose="true" />
+- </target>
+-
+- <target name="bouncycastle-check">
+- <available file="${deps}/${bcdist}" property="bouncycastle-dist.present" />
+- <available file="${build}/org/bouncycastle" property="bouncycastle-bin.present" />
+- </target>
+-
+- <target name="bouncycastle-fetch" depends="bouncycastle-check" unless="bouncycastle-dist.present">
+- <mkdir dir="${deps}" />
+- <get src="http://www.bouncycastle.org/download/${bcdist}.zip"
+- dest="${deps}/${bcdist}.zip"
+- verbose="true"
+- usetimestamp="true" />
+-
+- <unzip src="${deps}/${bcdist}.zip" dest="${deps}" />
+- </target>
+-
+- <target name="bouncycastle-compile" depends="bouncycastle-fetch" unless="bouncycastle-bin.present">
+- <mkdir dir="build" />
+- <javac srcdir="${deps}/${bcdist}/src" destdir="${build}" debug="on" optimize="on" source="1.4" nowarn="true">
+- <exclude name="**/test/*" />
+- <exclude name="org/bouncycastle/util/IPTest.java" />
+- <exclude name="org/bouncycastle/util/AllTests.java" />
+- </javac>
+- </target>
+
+- <target name="compile" depends="bouncycastle-compile, freenetjar-fetch">
++ <target name="compile">
+ <mkdir dir="${build}"/>
+
+ <tstamp/>
+@@ -88,6 +33,7 @@
+ <manifest>
+ <attribute name="Main-Class" value="freemail.FreemailCli"/>
+ <attribute name="Plugin-Main-Class" value="freemail.FreemailPlugin"/>
++ <attribute name="Class-Path" value="/usr/share/bcprov/lib/bcprov.jar /usr/share/freenet/lib/freenet.jar"/>
+ <attribute name="Built-By" value="${user.name}"/>
+ <section name="common">
+ <attribute name="Implementation-Title" value="Freemail"/>
diff --git a/net-mail/Freemail/metadata.xml b/net-mail/Freemail/metadata.xml
new file mode 100644
index 000000000000..fed3658eec53
--- /dev/null
+++ b/net-mail/Freemail/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+</pkgmetadata>
+