summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-28 06:20:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-28 06:20:37 +0000
commitb2d88ce12fe417affb3fd8b410779d26b6e112d0 (patch)
tree818fb4d3660cb550b1df467f1338c88d8a1b7aaa
parentFix pykdeuic4 for recent PyQt4 (diff)
downloadgentoo-2-b2d88ce12fe417affb3fd8b410779d26b6e112d0.tar.gz
gentoo-2-b2d88ce12fe417affb3fd8b410779d26b6e112d0.tar.bz2
gentoo-2-b2d88ce12fe417affb3fd8b410779d26b6e112d0.zip
tweak lzma option to use xz and display configure script when running it
-rw-r--r--sys-apps/man/man-1.6f-r4.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-apps/man/man-1.6f-r4.ebuild b/sys-apps/man/man-1.6f-r4.ebuild
index 09ae828e4134..01cf89b91bfa 100644
--- a/sys-apps/man/man-1.6f-r4.ebuild
+++ b/sys-apps/man/man-1.6f-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6f-r4.ebuild,v 1.1 2010/01/27 02:35:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6f-r4.ebuild,v 1.2 2010/01/28 06:20:37 vapier Exp $
EAPI="2"
inherit eutils toolchain-funcs
@@ -45,6 +45,7 @@ src_prepare() {
sed -i -e '/^DEFAULTLESSOPT=/s:"$:R":' configure
}
+echoit() { echo "$@" ; "$@" ; }
src_configure() {
strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
@@ -62,12 +63,13 @@ src_configure() {
else
mylang="none"
fi
- if use lzma; then
- mycompress=/usr/bin/lzma
+ export COMPRESS
+ if use lzma ; then
+ COMPRESS=/usr/bin/xz
else
- mycompress=/bin/bzip2
+ COMPRESS=/bin/bzip2
fi
- COMPRESS=$mycompress \
+ echoit \
./configure \
-confdir=/etc \
+sgid +fhs \