summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-01-14 04:13:15 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-01-14 04:13:15 +0000
commitb7d90692888a404b28a8ee29964d70988ef4d050 (patch)
treea14b058c9f7dd65abeb833f182d913c49b1e298c
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-b7d90692888a404b28a8ee29964d70988ef4d050.tar.gz
gentoo-2-b7d90692888a404b28a8ee29964d70988ef4d050.tar.bz2
gentoo-2-b7d90692888a404b28a8ee29964d70988ef4d050.zip
Add patch by Stefan Vunckx <stefan.vunckx AT skynet DOT be> to fix compilation with gcc-4.1; bug #118816. Also added metadata.xml with maintainer-needed
(Portage version: 2.1_pre3-r1)
-rw-r--r--media-libs/libflash/ChangeLog11
-rw-r--r--media-libs/libflash/files/libflash-0.4.10-gcc41.patch51
-rw-r--r--media-libs/libflash/libflash-0.4.10-r1.ebuild11
-rw-r--r--media-libs/libflash/metadata.xml8
4 files changed, 74 insertions, 7 deletions
diff --git a/media-libs/libflash/ChangeLog b/media-libs/libflash/ChangeLog
index 9f5e2e177877..989eea7c34e0 100644
--- a/media-libs/libflash/ChangeLog
+++ b/media-libs/libflash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libflash
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/ChangeLog,v 1.11 2004/06/24 23:09:19 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/ChangeLog,v 1.12 2006/01/14 04:13:15 halcy0n Exp $
+
+ 14 Jan 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/libflash-0.4.10-gcc41.patch, +metadata.xml,
+ libflash-0.4.10-r1.ebuild:
+ Add patch by Stefan Vunckx <stefan.vunckx AT skynet DOT be> to fix
+ compilation with gcc-4.1; bug #118816. Also added metadata.xml
+ with maintainer-needed
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> libflash-0.4.10-r1.ebuild:
Add inherit eutils
diff --git a/media-libs/libflash/files/libflash-0.4.10-gcc41.patch b/media-libs/libflash/files/libflash-0.4.10-gcc41.patch
new file mode 100644
index 000000000000..c4b5df1725c9
--- /dev/null
+++ b/media-libs/libflash/files/libflash-0.4.10-gcc41.patch
@@ -0,0 +1,51 @@
+--- libflash-0.4.10/lib/matrix.h.old 2006-01-11 21:23:55.000000000 +0100
++++ libflash-0.4.10/lib/matrix.h 2006-01-11 21:24:19.000000000 +0100
+@@ -33,13 +33,13 @@
+ #endif
+
+ inline
+- long Matrix::getX(long x, long y)
++ long getX(long x, long y)
+ {
+ return (long) (x*a+y*b+tx);
+ };
+
+ inline
+- long Matrix::getY(long x, long y)
++ long getY(long x, long y)
+ {
+ return (long) (x*c+y*d+ty);
+ };
+--- libflash-0.4.10/lib/graphic16.h.old 2006-01-11 21:24:39.000000000 +0100
++++ libflash-0.4.10/lib/graphic16.h 2006-01-11 21:24:52.000000000 +0100
+@@ -24,7 +24,7 @@
+
+ class GraphicDevice16: public GraphicDevice {
+ private:
+- long GraphicDevice16::allocColor(Color color);
++ long allocColor(Color color);
+
+ public:
+ GraphicDevice16(FlashDisplay *fd);
+--- libflash-0.4.10/lib/graphic24.h.old 2006-01-11 21:25:06.000000000 +0100
++++ libflash-0.4.10/lib/graphic24.h 2006-01-11 21:25:39.000000000 +0100
+@@ -24,7 +24,7 @@
+
+ class GraphicDevice24: public GraphicDevice {
+ private:
+- long GraphicDevice24::allocColor(Color color);
++ long allocColor(Color color);
+
+ public:
+ GraphicDevice24(FlashDisplay *fd);
+--- libflash-0.4.10/lib/graphic32.h.old 2006-01-11 21:26:01.000000000 +0100
++++ libflash-0.4.10/lib/graphic32.h 2006-01-11 21:26:40.000000000 +0100
+@@ -24,7 +24,7 @@
+
+ class GraphicDevice32: public GraphicDevice {
+ private:
+- long GraphicDevice32::allocColor(Color color);
++ long allocColor(Color color);
+
+ public:
+ GraphicDevice32(FlashDisplay *fd);
diff --git a/media-libs/libflash/libflash-0.4.10-r1.ebuild b/media-libs/libflash/libflash-0.4.10-r1.ebuild
index f58e24d1d8b6..4ec84520921a 100644
--- a/media-libs/libflash/libflash-0.4.10-r1.ebuild
+++ b/media-libs/libflash/libflash-0.4.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/libflash-0.4.10-r1.ebuild,v 1.15 2004/07/14 20:07:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/libflash-0.4.10-r1.ebuild,v 1.16 2006/01/14 04:13:15 halcy0n Exp $
inherit eutils
@@ -17,15 +17,16 @@ DEPEND="media-libs/jpeg
sys-libs/zlib"
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A} ; cd "${S}"
# patch to fix the sqrt not defined problem in gcc3.1
# It should be ok with gcc2.95 thanks to Doug Goldstein
# <dougg@ufl.edu> (Cardoe)
- epatch ${FILESDIR}/${P}-sqrt.patch
+ epatch "${FILESDIR}"/${P}-sqrt.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
}
src_install() {
- make DESTDIR=${D} install || die "Install failed"
+ make DESTDIR="${D}" install || die "Install failed"
dodoc AUTHORS COPYING README
}
diff --git a/media-libs/libflash/metadata.xml b/media-libs/libflash/metadata.xml
new file mode 100644
index 000000000000..73420b6cf0f0
--- /dev/null
+++ b/media-libs/libflash/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>