summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-02-08 16:53:21 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-02-08 16:53:21 +0000
commitb92f6f92f50986653331f1e961c69a10d2b665a9 (patch)
tree34c5aaafb9470562cf8fe5e81e0a22f453b21dcf
parentsys-kernel/genkernel: Update iscsi to 2.0-872 (bug #314575) (diff)
downloadgentoo-2-b92f6f92f50986653331f1e961c69a10d2b665a9.tar.gz
gentoo-2-b92f6f92f50986653331f1e961c69a10d2b665a9.tar.bz2
gentoo-2-b92f6f92f50986653331f1e961c69a10d2b665a9.zip
Upstream version bump, closes Gentoo bugs: 321241, 339059, 353216
(Portage version: 2.1.9.35/cvs/Linux x86_64)
-rw-r--r--app-shells/bash-completion/ChangeLog10
-rw-r--r--app-shells/bash-completion/bash-completion-1.3.ebuild78
2 files changed, 86 insertions, 2 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 0c4c1a282516..912700a8c2ce 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.226 2010/11/15 16:51:22 darkside Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.227 2011/02/08 16:53:21 darkside Exp $
+
+*bash-completion-1.3 (08 Feb 2011)
+
+ 08 Feb 2011; Jeremy Olexa <darkside@gentoo.org>
+ +bash-completion-1.3.ebuild:
+ Upstream version bump, closes Gentoo bugs: 321241, 339059, 353216
15 Nov 2010; Jeremy Olexa <darkside@gentoo.org>
-bash-completion-1.1-r5.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-1.3.ebuild b/app-shells/bash-completion/bash-completion-1.3.ebuild
new file mode 100644
index 000000000000..1e8b93be1291
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-1.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.3.ebuild,v 1.1 2011/02/08 16:53:21 darkside Exp $
+
+EAPI=3
+inherit prefix
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/eselect
+ || ( >=app-shells/bash-3.2 app-shells/zsh )
+ sys-apps/miscfiles"
+PDEPEND="app-shells/gentoo-bashcomp"
+
+src_prepare() {
+ cp "${FILESDIR}"/bash-completion.sh-gentoo-1.2 "${T}"/bash-completion.sh || die
+ eprefixify "${T}"/bash-completion.sh
+}
+
+src_configure() { :; } # no-op
+src_compile() { :; } # no-op
+
+src_install() {
+ # Gentoo specific bash-completion.sh file.
+ dodir /etc/profile.d
+ cp "${T}"/bash-completion.sh \
+ "${ED}"/etc/profile.d/bash-completion.sh || die "cp failed"
+
+ # All files from contrib/ in source package get installed
+ dodir /usr/share/bash-completion
+ cp -r "${S}"/completions/* "${ED}"/usr/share/bash-completion/ \
+ || die "installation failed to move files"
+ awk -v D="$ED" '
+ BEGIN { out=".pre" }
+ /^# A lot of the following one-liners/ { out="base" }
+ /^# start of section containing completion functions called by other functions/ { out=".pre" }
+ /^# start of section containing completion functions for external programs/ { out="base" }
+ /^# source completion directory/ { out="" }
+ /^unset -f have/ { out=".post" }
+ out != "" { print > D"/usr/share/bash-completion/"out }' \
+ bash_completion || die "failed to split bash_completion"
+
+ dodoc AUTHORS CHANGES README TODO || die "dodocs failes"
+}
+
+pkg_postinst() {
+ elog "Any user can enable the module completions without editing their"
+ elog ".bashrc by running:"
+ elog
+ elog " eselect bashcomp enable <module>"
+ elog
+ elog "The system administrator can also be enable this globally with"
+ elog
+ elog " eselect bashcomp enable --global <module>"
+ elog
+ elog "Make sure you at least enable the base module! Additional completion"
+ elog "modules can be found by running"
+ elog
+ elog " eselect bashcomp list"
+ elog
+ elog "If you use non-login shells you still need to source"
+ elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
+
+ if has_version 'app-shells/zsh' ; then
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}