summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2009-12-24 12:13:12 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2009-12-24 12:13:12 +0000
commitbabef6fb403fb4ce8e0023d28381626db54b3b5b (patch)
tree679ad3f1f6e9a9bcc64fcc88d42bec21c4c167c3
parentInitial commit. (diff)
downloadgentoo-2-babef6fb403fb4ce8e0023d28381626db54b3b5b.tar.gz
gentoo-2-babef6fb403fb4ce8e0023d28381626db54b3b5b.tar.bz2
gentoo-2-babef6fb403fb4ce8e0023d28381626db54b3b5b.zip
php-5.3 compatibility, bug 274512
(Portage version: 2.1.7.15/cvs/Linux x86_64)
-rw-r--r--dev-php5/pecl-ssh2/ChangeLog6
-rw-r--r--dev-php5/pecl-ssh2/files/pecl-ssh2-0.11.0-php-5.3-compat.patch31
-rw-r--r--dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild7
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-php5/pecl-ssh2/ChangeLog b/dev-php5/pecl-ssh2/ChangeLog
index 7ef6f5487a12..5816a17f57f1 100644
--- a/dev-php5/pecl-ssh2/ChangeLog
+++ b/dev-php5/pecl-ssh2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/pecl-ssh2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/ChangeLog,v 1.2 2009/10/15 11:56:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/ChangeLog,v 1.3 2009/12/24 12:13:12 hoffie Exp $
+
+ 24 Dec 2009; Christian Hoffmann <hoffie@gentoo.org>
+ pecl-ssh2-0.11.0.ebuild, +files/pecl-ssh2-0.11.0-php-5.3-compat.patch:
+ php-5.3 compatibility, bug 274512
15 Oct 2009; Markus Meier <maekke@gentoo.org> pecl-ssh2-0.11.0.ebuild:
amd64/x86 stable, bug #288070
diff --git a/dev-php5/pecl-ssh2/files/pecl-ssh2-0.11.0-php-5.3-compat.patch b/dev-php5/pecl-ssh2/files/pecl-ssh2-0.11.0-php-5.3-compat.patch
new file mode 100644
index 000000000000..da1221287c17
--- /dev/null
+++ b/dev-php5/pecl-ssh2/files/pecl-ssh2-0.11.0-php-5.3-compat.patch
@@ -0,0 +1,31 @@
+Fixes compile failures due to behavior changes of php-5.3
+Christian Hoffmann <hoffie@gentoo.org>
+Inspired by http://osdir.com/ml/fedora-extras-commits/2009-07/msg03478.html
+and http://github.com/php/pecl-gearman/commit/e8e4579406d6b324caf0e0d4c0fcfffa0b68e8be
+
+diff -Naur ssh2-0.11.0.orig/ssh2.c ssh2-0.11.0/ssh2.c
+--- ssh2-0.11.0.orig/ssh2.c 2008-12-02 22:50:10.000000000 +0100
++++ ssh2-0.11.0/ssh2.c 2009-12-24 13:03:13.000000000 +0100
+@@ -48,7 +48,6 @@
+ #endif
+
+ #ifdef ZEND_ENGINE_2
+-static
+ ZEND_BEGIN_ARG_INFO(php_ssh2_first_arg_force_ref, 0)
+ ZEND_ARG_PASS_INFO(1)
+ ZEND_END_ARG_INFO()
+@@ -252,12 +251,13 @@
+ {
+ zval **handler, *copyval;
+ void *internal_handler;
++ TSRMLS_FETCH();
+
+ if (zend_hash_find(ht, callback, callback_len + 1, (void**)&handler) == FAILURE) {
+ return 0;
+ }
+
+- if (!handler || !*handler || !zend_is_callable(*handler, 0, NULL)) {
++ if (!handler || !*handler || !zend_is_callable(*handler, 0, NULL TSRMLS_CC)) {
+ return -1;
+ }
+
diff --git a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
index 2604745a9555..c6547732d848 100644
--- a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
+++ b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild,v 1.2 2009/10/15 11:56:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild,v 1.3 2009/12/24 12:13:12 hoffie Exp $
PHP_EXT_NAME="ssh2"
PHP_EXT_INI="yes"
@@ -18,3 +18,8 @@ DEPEND=">=net-libs/libssh2-0.18"
RDEPEND="${DEPEND}"
need_php_by_category
+
+src_unpack() {
+ php-ext-source-r1_src_unpack
+ epatch "${FILESDIR}"/${P}-php-5.3-compat.patch
+}