summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-01-09 06:32:57 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-01-09 06:32:57 +0000
commitbe1c3b90dd2bc3eef52ad0c87bd34df97708be44 (patch)
treec9136cb21abab5e69e9a08771993a8907d33fe01
parent (Manifest recommit) (diff)
downloadgentoo-2-be1c3b90dd2bc3eef52ad0c87bd34df97708be44.tar.gz
gentoo-2-be1c3b90dd2bc3eef52ad0c87bd34df97708be44.tar.bz2
gentoo-2-be1c3b90dd2bc3eef52ad0c87bd34df97708be44.zip
Fixed some paths in the help files, added a .desktop entry.
-rw-r--r--media-gfx/quickplot/ChangeLog5
-rw-r--r--media-gfx/quickplot/quickplot-0.8.5.ebuild18
2 files changed, 21 insertions, 2 deletions
diff --git a/media-gfx/quickplot/ChangeLog b/media-gfx/quickplot/ChangeLog
index a61ecb57aac4..6ef547851252 100644
--- a/media-gfx/quickplot/ChangeLog
+++ b/media-gfx/quickplot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/quickplot
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/ChangeLog,v 1.3 2005/01/07 03:52:57 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/ChangeLog,v 1.4 2005/01/09 06:32:57 cryos Exp $
+
+ 09 Jan 2005; Marcus Hanwell <cryos@gentoo.org> quickplot-0.8.5.ebuild:
+ Corrected paths in the help files, added a .desktop entry.
07 Jan 2005; Marcus Hanwell <cryos@gentoo.org> quickplot-0.8.5.ebuild:
Added sndfile USE flag, and tidied up documentation files.
diff --git a/media-gfx/quickplot/quickplot-0.8.5.ebuild b/media-gfx/quickplot/quickplot-0.8.5.ebuild
index 74d2f9bd83ee..98b24b79cabc 100644
--- a/media-gfx/quickplot/quickplot-0.8.5.ebuild
+++ b/media-gfx/quickplot/quickplot-0.8.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/quickplot-0.8.5.ebuild,v 1.2 2005/01/07 03:52:57 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/quickplot-0.8.5.ebuild,v 1.3 2005/01/09 06:32:57 cryos Exp $
+
+inherit eutils
DESCRIPTION="A fast interactive 2D plotter."
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -17,6 +19,17 @@ RDEPEND=">=dev-cpp/gtkmm-2.4.5
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.15"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some files have been moved around to more appropriate locations
+ sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ index.html.in
+ sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
+ sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
+ about.html.in
+}
+
src_compile() {
econf `use_with sndfile libsndfile` || die "econf step failed."
emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
@@ -31,4 +44,7 @@ src_install () {
rm COPYING quickplot_icon.png ChangeLog
mv ${D}/usr/share/pixmaps/quickplot_icon.png \
${D}/usr/share/pixmaps/quickplot.png
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot.png Graphics
+ mv ${D}/usr/share/applications/quickplot\ --no-pipe.desktop \
+ ${D}/usr/share/applications/quickplot.desktop
}