summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-11-02 22:48:37 +0000
committerNed Ludd <solar@gentoo.org>2003-11-02 22:48:37 +0000
commitcb627390398ce65cf0f35bc8feb144e1d00893a5 (patch)
tree6ab3f4c7a863b99a2f8f5c61a4d4deee555b253b
parentversion bump for apache-1.3.29 security fix (diff)
downloadgentoo-2-cb627390398ce65cf0f35bc8feb144e1d00893a5.tar.gz
gentoo-2-cb627390398ce65cf0f35bc8feb144e1d00893a5.tar.bz2
gentoo-2-cb627390398ce65cf0f35bc8feb144e1d00893a5.zip
version bump for apache-1.3.29 security fix
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/Manifest4
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.161
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.16.ebuild75
4 files changed, 84 insertions, 3 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 4e1270f365fa..eed3c693060b 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.19 2003/10/06 20:33:37 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.20 2003/11/02 22:48:34 solar Exp $
+
+*mod_ssl-2.8.16 (02 Nov 2003)
+
+ 02 Nov 2003; <solar@gentoo.org> mod_ssl-2.8.16.ebuild:
+ version bump for apache-1.3.29 security fix
06 Oct 2003; Jason Wever <weeve@gentoo.org> mod_ssl-2.8.15.ebuild:
Marked stable for sparc.
diff --git a/net-www/mod_ssl/Manifest b/net-www/mod_ssl/Manifest
index 9ec654f03430..250eb88992b8 100644
--- a/net-www/mod_ssl/Manifest
+++ b/net-www/mod_ssl/Manifest
@@ -1,5 +1,5 @@
-MD5 1f455a3ccc08cfb0bde21aad7c1a0a22 ChangeLog 2475
-MD5 ba56f3e04b1d0fbbca8510570960df02 mod_ssl-2.8.16.ebuild 2185
+MD5 af3e328dce9eb1842c3dc078354814d6 ChangeLog 2610
+MD5 bec537c5eb9db920cb0a915c61d3ed06 mod_ssl-2.8.16.ebuild 2185
MD5 ff384d96b39989f0b5689a90ca615604 mod_ssl-2.8.14.ebuild 2177
MD5 25569340e781f4df176971a8ff781853 mod_ssl-2.8.15.ebuild 2182
MD5 2d40e1b1ed8c3b290e75eda14bcd0948 files/digest-mod_ssl-2.8.16 73
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.16 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.16
new file mode 100644
index 000000000000..f3e983b37cf4
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.16
@@ -0,0 +1 @@
+MD5 4f6c580ffa07d33e8584406132b98e86 mod_ssl-2.8.16-1.3.29.tar.gz 754325
diff --git a/net-www/mod_ssl/mod_ssl-2.8.16.ebuild b/net-www/mod_ssl/mod_ssl-2.8.16.ebuild
new file mode 100644
index 000000000000..2aabea417144
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.16.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.16.ebuild,v 1.1 2003/11/02 22:48:34 solar Exp $
+
+MY_P=${P}-1.3.29
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1.3.29*
+ >=dev-libs/openssl-0.9.6k"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}