summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-07-19 15:43:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-07-19 15:43:09 +0000
commitcb6eb1c7eaf870c0a827707df904656490c9ee96 (patch)
treeb1aa26b761199e7d94c3d9056c9042761508573b
parentwhitespace (diff)
downloadgentoo-2-cb6eb1c7eaf870c0a827707df904656490c9ee96.tar.gz
gentoo-2-cb6eb1c7eaf870c0a827707df904656490c9ee96.tar.bz2
gentoo-2-cb6eb1c7eaf870c0a827707df904656490c9ee96.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-cpp/tbb/ChangeLog8
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.035-tests.patch11
-rw-r--r--dev-cpp/tbb/tbb-3.0.035.ebuild81
3 files changed, 99 insertions, 1 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 44fdd60e448a..23f6f5301cec 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.5 2010/05/28 19:09:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.6 2010/07/19 15:43:09 bicatali Exp $
+
+*tbb-3.0.035 (19 Jul 2010)
+
+ 19 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org> +tbb-3.0.035.ebuild,
+ +files/tbb-3.0.035-tests.patch:
+ Version bump
28 May 2010; Sébastien Fabbro <bicatali@gentoo.org> tbb-3.0.018.ebuild,
+files/tbb-3.0.018-tests.patch:
diff --git a/dev-cpp/tbb/files/tbb-3.0.035-tests.patch b/dev-cpp/tbb/files/tbb-3.0.035-tests.patch
new file mode 100644
index 000000000000..c756dfd908ea
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-3.0.035-tests.patch
@@ -0,0 +1,11 @@
+--- build/Makefile.test.orig 2010-07-16 16:45:38.000000000 +0100
++++ build/Makefile.test 2010-07-16 16:46:09.000000000 +0100
+@@ -191,7 +191,7 @@
+ # If a component Y uses component X, then tests for Y should come after tests for X.
+ # Note that usually run_cmd is empty, and tests run directly
+ test_tbb_plain: $(TEST_PREREQUISITE) $(TASK_CPP_DIRECTLY_INCLUDED) $(TEST_TBB_PLAIN.EXE)
+- $(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
++ #$(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
+ # Checking TBB version first to make sure the following testing has anything in it
+ $(run_cmd) ./test_assembly.$(TEST_EXT) $(args)
+ $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
diff --git a/dev-cpp/tbb/tbb-3.0.035.ebuild b/dev-cpp/tbb/tbb-3.0.035.ebuild
new file mode 100644
index 000000000000..5b54dfe973dc
--- /dev/null
+++ b/dev-cpp/tbb/tbb-3.0.035.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.035.ebuild,v 1.1 2010/07/19 15:43:09 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator toolchain-funcs alternatives
+# url number
+MYU="78/155"
+# release update
+MYR="%20update%20"1
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}${MYR}/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+DEPEND="!<=dev-cpp/tbb-2.1.016"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tests.patch
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ build/*.inc \
+ || die
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++ ]]; then
+ myconf="compiler=gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ myconf="compiler=icc"
+ fi
+ # from the Makefile, split debug
+ cd src
+ emake ${myconf} tbb_release tbbmalloc_release || die "emake failed"
+ if use debug || use examples; then
+ emake ${myconf} tbb_debug tbbmalloc_debug || die "emake debug failed"
+ fi
+}
+
+src_test() {
+ cd src
+ emake -j1 ${myconf} test_release || die "emake test failed"
+ if use debug || use examples; then
+ emake ${myconf} test_debug tbbmalloc_test_debug || die "emake test debug failed"
+ fi
+
+}
+
+src_install(){
+ for l in $(find build -name lib\*.so.\*); do
+ dolib.so ${l} || die
+ local bl=$(basename ${l})
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ insinto /usr
+ doins -r include || die
+
+ dodoc README CHANGES doc/Release_Notes.txt
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/html || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples || die
+ fi
+}