summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-26 09:36:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-26 09:36:20 +0000
commitd0f11bf129fcdd16791855444944a74275b7136d (patch)
treebad1f6b76011a504737117f881f7d3f5da16b970
parentfix init.d-script to properly stop libvirt-snmp (diff)
downloadgentoo-2-d0f11bf129fcdd16791855444944a74275b7136d.tar.gz
gentoo-2-d0f11bf129fcdd16791855444944a74275b7136d.tar.bz2
gentoo-2-d0f11bf129fcdd16791855444944a74275b7136d.zip
Bump
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
-rw-r--r--dev-php/awl/ChangeLog8
-rw-r--r--dev-php/awl/awl-0.52.ebuild41
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-php/awl/ChangeLog b/dev-php/awl/ChangeLog
index ee0ec7f4bc86..6ea60e6f6e16 100644
--- a/dev-php/awl/ChangeLog
+++ b/dev-php/awl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/awl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.2 2012/03/22 00:20:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.3 2012/06/26 09:36:20 patrick Exp $
+
+*awl-0.52 (26 Jun 2012)
+
+ 26 Jun 2012; Patrick Lauer <patrick@gentoo.org> +awl-0.52.ebuild:
+ Bump
*awl-0.51-r1 (22 Mar 2012)
@@ -92,4 +97,3 @@
23 Jun 2008; lebarjack <francois.perichon@univ-lille2.fr>
+libawl-php-0.29.ebuild, +metadata.xml:
New ebuild for bug 229025 - (initial work by Cory Coager <ccoager@gmail.com>)
-
diff --git a/dev-php/awl/awl-0.52.ebuild b/dev-php/awl/awl-0.52.ebuild
new file mode 100644
index 000000000000..e796d47cfecc
--- /dev/null
+++ b/dev-php/awl/awl-0.52.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/awl-0.52.ebuild,v 1.1 2012/06/26 09:36:20 patrick Exp $
+
+EAPI=2
+
+inherit depend.php php-lib-r1
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/php[pdo,postgres,xml]
+ doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="${DEPEND}"
+
+need_php5
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini" || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ local docs="debian/README.Debian debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r "docs/api/" || die "dohtml failed"
+ fi
+
+ php-lib-r1_src_install . dba/* inc/* scripts/*
+}