summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-05 14:01:39 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-05 14:01:39 +0000
commitd1180ba24047fd570d983fad3a5d29a62e411a58 (patch)
tree1abd06743935714a3b4b64794dd2d6da5df8e71a
parent DRDB package splitted in drbd + drbd-kernel, conversion to linux-mod. (diff)
downloadgentoo-2-d1180ba24047fd570d983fad3a5d29a62e411a58.tar.gz
gentoo-2-d1180ba24047fd570d983fad3a5d29a62e411a58.tar.bz2
gentoo-2-d1180ba24047fd570d983fad3a5d29a62e411a58.zip
New revision with patch to fix fftw problem (see bug #194708).
(Portage version: 2.1.3.11)
-rw-r--r--sci-libs/scipy/ChangeLog9
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.6.0-r13
-rw-r--r--sci-libs/scipy/files/scipy-0.6.0-fftw-fix.patch12
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r1.ebuild127
4 files changed, 150 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index a3adfd7d15aa..12845b755b69 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.23 2007/09/25 21:54:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.24 2007/10/05 14:01:38 markusle Exp $
+
+*scipy-0.6.0-r1 (05 Oct 2007)
+
+ 05 Oct 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/scipy-0.6.0-fftw-fix.patch, +scipy-0.6.0-r1.ebuild:
+ New revision with patch to fix fftw problem (see bug #194708).
+ Thanks much to David Heavens <david.heavens@gmail.com> for his patch.
*scipy-0.6.0 (25 Sep 2007)
diff --git a/sci-libs/scipy/files/digest-scipy-0.6.0-r1 b/sci-libs/scipy/files/digest-scipy-0.6.0-r1
new file mode 100644
index 000000000000..aa28d16fa675
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.6.0-r1
@@ -0,0 +1,3 @@
+MD5 417adf3bfe03f4c23c9fb265018e545c scipy-0.6.0.tar.gz 6572954
+RMD160 391f2067f7dcc133e7e8622df93a2a0cd5ebbe5b scipy-0.6.0.tar.gz 6572954
+SHA256 5f70390963fb4e3ae8cf5effa301c160ef68c791098e2ea95b99380e298eac4f scipy-0.6.0.tar.gz 6572954
diff --git a/sci-libs/scipy/files/scipy-0.6.0-fftw-fix.patch b/sci-libs/scipy/files/scipy-0.6.0-fftw-fix.patch
new file mode 100644
index 000000000000..8db84dd8dcdd
--- /dev/null
+++ b/sci-libs/scipy/files/scipy-0.6.0-fftw-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur scipy-0.6.0/scipy/fftpack/src/zfftnd_fftw.c scipy-0.6.0-new/scipy/fftpack/src/zfftnd_fftw.c
+--- scipy-0.6.0/scipy/fftpack/src/zfftnd_fftw.c 2007-09-22 03:56:38.000000000 -0400
++++ scipy-0.6.0-new/scipy/fftpack/src/zfftnd_fftw.c 2007-10-05 09:20:19.000000000 -0400
+@@ -25,7 +25,7 @@
+ free(caches_zfftnd_fftw[id].dims);, 10)
+
+
+-extern void zfftnd_mkl(complex_double * inout, int rank,
++extern void zfftnd_fftw(complex_double * inout, int rank,
+ int *dims, int direction, int howmany,
+ int normalize)
+ {
diff --git a/sci-libs/scipy/scipy-0.6.0-r1.ebuild b/sci-libs/scipy/scipy-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..eccfa7dd551b
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.6.0-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r1.ebuild,v 1.1 2007/10/05 14:01:38 markusle Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils distutils fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+
+IUSE="fftw umfpack sandbox"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-python/numpy-1.0.3.1
+ virtual/lapack
+ fftw? ( =sci-libs/fftw-2.1* )
+ umfpack? ( sci-libs/umfpack dev-lang/swig )
+ sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
+
+RDEPEND=">=dev-python/numpy-1.0.3.1
+ dev-python/imaging
+ virtual/lapack
+ fftw? ( =sci-libs/fftw-2.1* )
+ umfpack? ( sci-libs/umfpack )
+ sandbox? ( >=sci-libs/netcdf-3.6 x11-libs/libX11 )"
+
+# test still buggy on lapack with 2 failures on check_syevr
+# (lapack float). check every version bump.
+RESTRICT="test"
+
+DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
+
+scipy_fortran_setup() {
+ FORTRAN="gfortran g77 ifc"
+ fortran_pkg_setup
+ local fc=
+ case ${FORTRANC} in
+ gfortran) fc=gnu95 ;;
+ g77) fc=gnu ;;
+ ifc|ifort)
+ if use ia64; then
+ fc=intele
+ elif use amd64; then
+ fc=intelem
+ else
+ fc=intel
+ fi
+ ;;
+ *) eerror "Unknown fortran compiler: ${FORTRANC}"
+ die "scipy_fortran_setup failed" ;;
+ esac
+
+ # when fortran flags are set, pic is removed.
+ use amd64 && [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
+ export SCIPY_FCONFIG="config_fc --fcompiler=${fc}"
+}
+
+# see numpy ebuild about unsetting LDFLAGS
+LDFLAGS_sav="${LDFLAGS}"
+unset LDFLAGS
+
+pkg_setup() {
+ [[ -n ${LDFLAGS_sav} ]] && einfo "Ignoring LDFLAGS=${LDFLAGS_sav}"
+ if use umfpack && ! built_with_use dev-lang/swig python; then
+ eerror "With umfpack enabled you need"
+ eerror "dev-lang/swig with python enabled"
+ einfo "Please re-emerge swig with USE=python"
+ die "needs swig with python"
+ fi
+ # scipy automatically detects libraries by default
+ export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
+ use fftw && unset FFTW
+ use umfpack && unset UMFPACK
+ use sandbox && elog "Warning: using sandbox modules at your own risk!"
+ scipy_fortran_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-randomkit.patch
+ epatch "${FILESDIR}"/${P}-cdf.patch
+ epatch "${FILESDIR}"/${P}-fftw-fix.patch
+
+ if use sandbox; then
+ cd scipy/sandbox
+ ls -1 */__init__.py \
+ | sed -e 's:/__init__.py::' \
+ | grep -v exmplpackage \
+ > enabled_packages.txt \
+ || die "sandbox listing failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile ${SCIPY_FCONFIG}
+}
+
+src_test() {
+ "${python}" setup.py install \
+ --home="${S}"/test \
+ --no-compile \
+ ${SCIPY_FCONFIG} || die "install test failed"
+ pushd "${S}"/test/lib*/python
+ PYTHONPATH=. "${python}" -c \
+ "import scipy as s;import sys;sys.exit(s.test(10,3))" \
+ 2>&1 | tee test.log
+ grep -q OK test.log || die "test failed"
+ popd
+ rm -rf test
+}
+
+src_install() {
+ distutils_src_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer if you don't like the default one. Ex:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}