summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-08-25 17:43:39 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-08-25 17:43:39 +0000
commitd3cb9ce4338861bd70a7efe2edf980d8a3ed1c70 (patch)
tree914aeb3d184edb73d1529c0cf81fd6056887f859
parentStable on x86 and amd64. Since hppa is already done too. Per bug #333595. (diff)
downloadgentoo-2-d3cb9ce4338861bd70a7efe2edf980d8a3ed1c70.tar.gz
gentoo-2-d3cb9ce4338861bd70a7efe2edf980d8a3ed1c70.tar.bz2
gentoo-2-d3cb9ce4338861bd70a7efe2edf980d8a3ed1c70.zip
Moved from science overlay, bug # 135573
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--sci-electronics/xnec2c/ChangeLog25
-rw-r--r--sci-electronics/xnec2c/metadata.xml27
-rw-r--r--sci-electronics/xnec2c/xnec2c-1.4.ebuild39
3 files changed, 91 insertions, 0 deletions
diff --git a/sci-electronics/xnec2c/ChangeLog b/sci-electronics/xnec2c/ChangeLog
new file mode 100644
index 000000000000..cfbe327f8188
--- /dev/null
+++ b/sci-electronics/xnec2c/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for sci-electronics/xnec2c
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.1 2010/08/25 17:43:39 tomjbe Exp $
+
+ 25 Aug 2010; Thomas Beierlein <tomjbe@gentoo.org> +xnec2c-1.4.ebuild,
+ +metadata.xml:
+ Moved from science overlay, bug # 135573
+
+*xnec2c-1.4 (13 Jul 2010)
+
+ 13 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org> -xnec2c-1.3.ebuild,
+ -files/xnec2c-1.3-filename.patch, +xnec2c-1.4.ebuild:
+ Version bump. Fixes only bug wrt buffer overflow on long filenames.
+
+ 10 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org> xnec2c-1.3.ebuild,
+ +files/xnec2c-1.3-filename.patch:
+ Fixed handling of long path and filenames
+
+*xnec2c-1.3 (01 Jul 2010)
+
+ 01 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org> +xnec2c-1.3.ebuild,
+ +metadata.xml:
+ New ebuild for Xnec2c. Based on the work of Dominique Michel
+ <dominique.michel@vtxnet.ch> in bug #138770
+
diff --git a/sci-electronics/xnec2c/metadata.xml b/sci-electronics/xnec2c/metadata.xml
new file mode 100644
index 000000000000..e97b927852fd
--- /dev/null
+++ b/sci-electronics/xnec2c/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-electronics</herd>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <longdescription>
+ xnec2c is a GTK+ graphical interactive version of nec2c. It incorporates
+ the nec2c core which it uses for reading input files and calculating
+ output data, but it does not need and indeed does not produce an output
+ file by default. Since xnec2c incorporates the nec2c core, it has access
+ to all internal buffers, including structure data, frequency-related
+ data (structure currents, input impedance, gain etc) and radiation
+ pattern data (for the far field and near field). It therefore has the
+ ability to graphically display user-requested data directly, as the
+ frequency loop progresses or after input from the user. Graphs of
+ frequency-related data and the current or charge distribution evolve as
+ the frequency loop progresses, and radiation patterns (far and near
+ field) are sequentially drawn for each frequency step. A new frequency
+ can be entered by the user from spin buttons in the main or radiation
+ pattern windows or by clicking on the graphs of frequency-related data.
+ New output data are then computed and displayed in text and graphical
+ form.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-electronics/xnec2c/xnec2c-1.4.ebuild b/sci-electronics/xnec2c/xnec2c-1.4.ebuild
new file mode 100644
index 000000000000..b43cefc59feb
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-1.4.ebuild,v 1.1 2010/08/25 17:43:39 tomjbe Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c."
+HOMEPAGE="http://5b4az.chronos.org.uk/pages/nec2.html"
+SRC_URI="http://5b4az.chronos.org.uk/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}"
+
+RDEPEND="dev-libs/glib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS README doc/*.txt || die
+ dohtml -r doc/* || die
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ fi
+}