summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-26 19:58:58 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-26 19:58:58 +0000
commitd6bb3a5357accb6585711f1612a0a8fa09413c64 (patch)
tree826b9d8009704de2e806101948c45d7e2714753a
parentadded ChangeLog (diff)
downloadgentoo-2-d6bb3a5357accb6585711f1612a0a8fa09413c64.tar.gz
gentoo-2-d6bb3a5357accb6585711f1612a0a8fa09413c64.tar.bz2
gentoo-2-d6bb3a5357accb6585711f1612a0a8fa09413c64.zip
Split out the "nessus" ebuild to the individual nessues components to allow pieces to build and install properly. "nessus" is still an installable ebuild, it just pulls in the individual components. nessus-plugins is the third of those components.
-rw-r--r--net-analyzer/nessus-plugins/ChangeLog13
-rw-r--r--net-analyzer/nessus-plugins/files/digest-nessus-plugins-1.2.31
-rw-r--r--net-analyzer/nessus-plugins/nessus-plugins-1.2.3.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/nessus-plugins/ChangeLog b/net-analyzer/nessus-plugins/ChangeLog
new file mode 100644
index 000000000000..b56ffe31f145
--- /dev/null
+++ b/net-analyzer/nessus-plugins/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-analyzer/nessus-plugins
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-plugins/ChangeLog,v 1.1 2002/07/26 19:58:58 raker Exp $
+
+*nessus-plugins-1.2.3 (26 Jul 2002)
+
+ 26 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ nessus-plugins-1.2.3.ebuild, files/digest-nessus-plugins-1.2.3 :
+
+ Split out the "nessus" ebuild to the individual nessues components
+ to allow pieces to build and install properly. "nessus" is still
+ an installable ebuild, it just pulls in the individual components.
+ nessus-plugins is the third of those components.
diff --git a/net-analyzer/nessus-plugins/files/digest-nessus-plugins-1.2.3 b/net-analyzer/nessus-plugins/files/digest-nessus-plugins-1.2.3
new file mode 100644
index 000000000000..790fd9b65ab7
--- /dev/null
+++ b/net-analyzer/nessus-plugins/files/digest-nessus-plugins-1.2.3
@@ -0,0 +1 @@
+MD5 0303341cf3721ff897faa219f021af9c nessus-plugins-1.2.3.tar.gz 826738
diff --git a/net-analyzer/nessus-plugins/nessus-plugins-1.2.3.ebuild b/net-analyzer/nessus-plugins/nessus-plugins-1.2.3.ebuild
new file mode 100644
index 000000000000..3da3d295ccb1
--- /dev/null
+++ b/net-analyzer/nessus-plugins/nessus-plugins-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2000-2002 Achim Gottinger
+# Distributed under the GPL by Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-plugins/nessus-plugins-1.2.3.ebuild,v 1.1 2002/07/26 19:58:58 raker Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (nessus-plugins)"
+HOMEPAGE="http://www.nessus.org/"
+
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-1.2.3/src/${P}.tar.gz"
+
+DEPEND="=net-analyzer/nessus-core-1.2.3"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/state \
+ mandir=${D}/usr/share/man \
+ install || die "make install failed"
+
+ cd ${S}
+ docinto nessus-plugins
+ dodoc docs/*.txt plugins/accounts/accounts.txt
+
+}