summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-01 14:16:40 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-01 14:16:40 +0000
commitd7c3c7492b28b49b1f8dee2426cd5850e08269ca (patch)
treef284d5f8ab9802cffcabbcbe00f7c900eca9edfc
parentarm/s390/sh stable (diff)
downloadgentoo-2-d7c3c7492b28b49b1f8dee2426cd5850e08269ca.tar.gz
gentoo-2-d7c3c7492b28b49b1f8dee2426cd5850e08269ca.tar.bz2
gentoo-2-d7c3c7492b28b49b1f8dee2426cd5850e08269ca.zip
Version bump #180538.
(Portage version: 2.1.2.9)
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.2.313
-rw-r--r--sys-apps/findutils/findutils-4.2.31.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 584b7a855e44..2d46717ad0c2 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.110 2007/06/01 02:52:34 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.111 2007/06/01 14:16:40 vapier Exp $
+
+*findutils-4.2.31 (01 Jun 2007)
+
+ 01 Jun 2007; Mike Frysinger <vapier@gentoo.org> +findutils-4.2.31.ebuild:
+ Version bump #180538.
01 Jun 2007; Joshua Kinard <kumba@gentoo.org> findutils-4.2.30.ebuild,
findutils-4.3.4.ebuild:
diff --git a/sys-apps/findutils/files/digest-findutils-4.2.31 b/sys-apps/findutils/files/digest-findutils-4.2.31
new file mode 100644
index 000000000000..536c58f38bc7
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.2.31
@@ -0,0 +1,3 @@
+MD5 a0e31a0f18a49709bf5a449867c8049a findutils-4.2.31.tar.gz 1326294
+RMD160 0b6775ebf5455e99bf594dd02432d8eeee508ace findutils-4.2.31.tar.gz 1326294
+SHA256 e0d34b8faca0b3cca0703f6c6b498afbe72f0ba16c35980c10ec9ef7724d6204 findutils-4.2.31.tar.gz 1326294
diff --git a/sys-apps/findutils/findutils-4.2.31.ebuild b/sys-apps/findutils/findutils-4.2.31.ebuild
new file mode 100644
index 000000000000..3457558b7030
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.2.31.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.31.ebuild,v 1.1 2007/06/01 14:16:40 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+SELINUX_PATCH="findutils-4.2.24-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls build selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
+ econf $(use_enable nls) ${myconf} || die "configure failed"
+ emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" libexecdir="${D}/usr/lib/find" install || die
+
+ rm -rf "${D}"/usr/var
+ use build \
+ && rm -rf "${D}"/usr/share \
+ || dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "Please note that the locate and updatedb binaries"
+ ewarn "are now provided by slocate, not findutils."
+}