summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-17 14:44:36 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-17 14:44:36 +0000
commite647b873de1e9c68706ffd49e34e0f3bccf9bf20 (patch)
tree71b579338b320d94eacea125e16b0b5daacb298a
parentnew version (diff)
downloadgentoo-2-e647b873de1e9c68706ffd49e34e0f3bccf9bf20.tar.gz
gentoo-2-e647b873de1e9c68706ffd49e34e0f3bccf9bf20.tar.bz2
gentoo-2-e647b873de1e9c68706ffd49e34e0f3bccf9bf20.zip
new version, fixes yahoo messenger bug
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/files/digest-gaim-0.59.51
-rw-r--r--net-im/gaim/gaim-0.59.5.ebuild88
3 files changed, 95 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index cb51d22a490c..896833692779 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.27 2002/10/12 08:11:04 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.28 2002/10/17 14:44:36 foser Exp $
+
+*gaim-0.95.5 (17 Oct 2002)
+
+ 17 Oct 2002; foser <foser@gentoo.org> gaim-0.95.5.ebuild :
+ New version. Fixes a bug in the yahoo transport.
*gaim-0.59.4 (07 Oct 2002)
diff --git a/net-im/gaim/files/digest-gaim-0.59.5 b/net-im/gaim/files/digest-gaim-0.59.5
new file mode 100644
index 000000000000..66af8ea2abea
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.59.5
@@ -0,0 +1 @@
+MD5 ac67eebcc80320199d44191f1f802254 gaim-0.59.5.tar.bz2 1532983
diff --git a/net-im/gaim/gaim-0.59.5.ebuild b/net-im/gaim/gaim-0.59.5.ebuild
new file mode 100644
index 000000000000..127c9f9f40e2
--- /dev/null
+++ b/net-im/gaim/gaim-0.59.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.59.5.ebuild,v 1.1 2002/10/17 14:44:36 foser Exp $
+
+IUSE="nas nls esd gnome arts gtk2 perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK Instant Messenger client"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+HOMEPAGE="http://gaim.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( sys-devel/gettext )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gtk2? ( =x11-libs/gtk+-2.0* =dev-libs/glib-2.0* )
+ || ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2*
+ ( gnome? ( =gnome-base/gnome-panel-1.4* >=media-libs/gdk-pixbuf-0.16.0 ) ) )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf gnomeopts
+
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ if [ "` use arts`" ]; then
+ inherit kde-functions
+ set-kdedir 3
+ # $KDEDIR now points to arts location
+ else
+ myconf="${myconf} --disable-artsc"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ gnomeopts="${myconf}"
+
+ if [ "`use gtk2`" ];
+ then
+
+ # GTK+ 2 support
+ myconf="${myconf} --enable-gtk2"
+
+ fi
+
+ gnomeopts="${myconf}"
+
+ # Gnome is disabled for GTK+ 2.0 build and first build of GTK 1.4 version
+ myconf="${myconf} --disable-gnome"
+
+ # always build standalone gaim program
+ econf ${myconf} || die
+ emake || die
+
+ # if gnome support is enabled (and gtk2 disabled), then build gaim_applet
+ if [ "`use gnome`" -a -z "`use gtk2`" ];
+ then
+ gnomeopts="${gnomeopts} --with-gnome=${GNOME_PATH} --enable-panel"
+
+ # save appletless version and clean up
+ cp src/gaim ${S}/gaim || die "standalone version failed to build"
+ make distclean || die
+
+ econf ${gnomeopts} || die
+ emake || die
+ fi
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ # if gnome enabled, make sure to install standalone version also
+ use gnome && dobin ${S}/gaim
+
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}