summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-08 10:28:42 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-08 10:28:42 +0000
commitf17eb7466a1ed4691c8fb95163fb406ae9db4155 (patch)
tree48059fb0961bf71b78d2206b1b70718d4cdfaa29
parentReplaced java-pkg-2 eclass with java-pkg-opt-2 (diff)
downloadgentoo-2-f17eb7466a1ed4691c8fb95163fb406ae9db4155.tar.gz
gentoo-2-f17eb7466a1ed4691c8fb95163fb406ae9db4155.tar.bz2
gentoo-2-f17eb7466a1ed4691c8fb95163fb406ae9db4155.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--dev-ruby/httpclient/ChangeLog8
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.6.1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 830011d27edf..ca9b733212e5 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.23 2011/01/02 10:32:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.24 2011/01/08 10:28:42 graaff Exp $
+
+*httpclient-2.1.6.1 (08 Jan 2011)
+
+ 08 Jan 2011; Hans de Graaff <graaff@gentoo.org>
+ +httpclient-2.1.6.1.ebuild:
+ Version bump.
*httpclient-2.1.6 (02 Jan 2011)
diff --git a/dev-ruby/httpclient/httpclient-2.1.6.1.ebuild b/dev-ruby/httpclient/httpclient-2.1.6.1.ebuild
new file mode 100644
index 000000000000..fded0ad94989
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.1.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.6.1.ebuild,v 1.1 2011/01/08 10:28:42 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="http://dev.ctor.org/http-access2/"
+SRC_URI="http://dev.ctor.org/download/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+# tests are known to fail, but at least they fail for all
+# implementations in the same way. Bug 335451.
+RESTRICT="test"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+# JRuby-specific dependency
+USE_RUBY="jruby" ruby_add_rdepend dev-ruby/jruby-openssl