summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-06-27 05:04:18 +0000
committerMatt Turner <mattst88@gentoo.org>2011-06-27 05:04:18 +0000
commitf36eb6719c25f0507593eaf4f0dd8e3d19b91fea (patch)
treeab19b0c0020320ab02d4f78dac6e77c3f77afcac
parentAdd pkgconfıg to info_pkgs (diff)
downloadgentoo-2-f36eb6719c25f0507593eaf4f0dd8e3d19b91fea.tar.gz
gentoo-2-f36eb6719c25f0507593eaf4f0dd8e3d19b91fea.tar.bz2
gentoo-2-f36eb6719c25f0507593eaf4f0dd8e3d19b91fea.zip
Fix arch file installation with catalyst_2 git branch
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-util/catalyst/ChangeLog6
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild5
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild5
3 files changed, 13 insertions, 3 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 54488b0b716d..856ef8c6be9b 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.230 2011/06/26 16:46:48 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.231 2011/06/27 05:04:18 mattst88 Exp $
+
+ 27 Jun 2011; Matt Turner <mattst88@gentoo.org> catalyst-2.0.6.916.ebuild,
+ catalyst-9999.ebuild:
+ Fix arch file installation with catalyst_2 git branch
26 Jun 2011; Sebastian Pipping <sping@gentoo.org> catalyst-9999.ebuild:
Add asciidoc build dependency to live ebuild, sync ebuilds
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
index 304f1e81e72c..f7d8e5d71636 100644
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.3 2011/06/26 16:40:39 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.4 2011/06/27 05:04:18 mattst88 Exp $
# catalyst-9999 -> latest Git
# catalyst-VER -> normal catalyst release
@@ -63,6 +63,9 @@ src_install() {
doexe catalyst || die "copying catalyst"
if [[ ${PV} == 9999* ]]; then
doins -r modules files || die "copying files"
+
+ # arch files don't live in modules/ in catalyst_2
+ [[ ${EGIT_BRANCH} == "catalyst_2" ]] && { doins -r arch || die "copying files"; }
else
doins -r arch modules livecd || die "copying files"
fi
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index 5caf7aa7b992..b5a7094a4e08 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.13 2011/06/26 16:46:48 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.14 2011/06/27 05:04:18 mattst88 Exp $
# catalyst-9999 -> latest Git
# catalyst-VER -> normal catalyst release
@@ -67,6 +67,9 @@ src_install() {
doexe catalyst || die "copying catalyst"
if [[ ${PV} == 9999* ]]; then
doins -r modules files || die "copying files"
+
+ # arch files don't live in modules/ in catalyst_2
+ [[ ${EGIT_BRANCH} == "catalyst_2" ]] && { doins -r arch || die "copying files"; }
else
doins -r arch modules livecd || die "copying files"
fi