summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-11 07:40:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-11 07:40:38 +0000
commitf4bae023dc65e1f5e8f1427ee2cd2ef6d7aa606e (patch)
tree59b7e73772847a8fe4fd997bb0062dcba16efe15
parent(#258543) Remove duplicate python deps (walch.martin at web.de). (diff)
downloadgentoo-2-f4bae023dc65e1f5e8f1427ee2cd2ef6d7aa606e.tar.gz
gentoo-2-f4bae023dc65e1f5e8f1427ee2cd2ef6d7aa606e.tar.bz2
gentoo-2-f4bae023dc65e1f5e8f1427ee2cd2ef6d7aa606e.zip
add a patch from upstream to fix build on bsd/solaris
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--dev-libs/libdaemon/ChangeLog8
-rw-r--r--dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch39
-rw-r--r--dev-libs/libdaemon/libdaemon-0.13-r1.ebuild9
3 files changed, 50 insertions, 6 deletions
diff --git a/dev-libs/libdaemon/ChangeLog b/dev-libs/libdaemon/ChangeLog
index a38ccacdbccc..6689f3edc351 100644
--- a/dev-libs/libdaemon/ChangeLog
+++ b/dev-libs/libdaemon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libdaemon
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.56 2008/10/05 20:22:00 eva Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.57 2009/02/11 07:40:38 aballier Exp $
+
+ 11 Feb 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/libdaemon-0.13-bsd.patch, libdaemon-0.13-r1.ebuild:
+ add a patch from upstream to fix build on bsd/solaris
*libdaemon-0.13-r1 (05 Oct 2008)
diff --git a/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch b/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch
new file mode 100644
index 000000000000..8a439d52a62e
--- /dev/null
+++ b/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch
@@ -0,0 +1,39 @@
+commit 5b1daf072556c1fc9a00e8735fa0cdba280c2231
+Author: Diego 'Flameeyes' Pettenò <flameeyes@gmail.com>
+Date: Wed Oct 1 13:26:32 2008 +0200
+
+ Fix building on OpenSolaris (without _NSIG definition).
+
+ On OpenSolaris, the _NSIG macro is not defined, but NSIG is; as it's
+ not possible to use NSIG under glibc (it would miss the SIGRT*
+ series), define a SIGNAL_UPPER_BOUND depending on the system (and
+ error out if the system lacks both NSIG and _NSIG).
+
+diff --git a/libdaemon/dfork.c b/libdaemon/dfork.c
+index f1ba7c1..6b94944 100644
+--- a/libdaemon/dfork.c
++++ b/libdaemon/dfork.c
+@@ -42,6 +42,14 @@
+ #include "dnonblock.h"
+ #include "dlog.h"
+
++#if defined(_NSIG) /* On glibc NSIG does not count RT signals */
++# define SIGNAL_UPPER_BOUND _NSIG
++#elif defined(NSIG) /* Solaris defines just this */
++# define SIGNAL_UPPER_BOUND NSIG
++#else
++# error "Unknown upper bound for signals"
++#endif
++
+ static int _daemon_retval_pipe[2] = { -1, -1 };
+
+ static int _null_open(int f, int fd) {
+@@ -665,7 +673,7 @@ int daemon_reset_sigs(int except, ...) {
+ int daemon_reset_sigsv(const int except[]) {
+ int sig;
+
+- for (sig = 1; sig < _NSIG; sig++) {
++ for (sig = 1; sig < SIGNAL_UPPER_BOUND; sig++) {
+ int reset = 1;
+
+ switch (sig) {
diff --git a/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild b/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild
index 2d11b4587763..f2706e113f03 100644
--- a/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild
+++ b/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild,v 1.1 2008/10/05 20:22:00 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild,v 1.2 2009/02/11 07:40:38 aballier Exp $
-inherit libtool
+inherit libtool eutils
DESCRIPTION="Simple library for creating daemon processes in C"
HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
@@ -18,7 +18,8 @@ DEPEND="doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
-
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-bsd.patch"
elibtoolize
}